summaryrefslogtreecommitdiffstats
path: root/meta-smx6-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-01-19 11:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-01-31 08:53:15 +0000
commitc0c98ab5cc94b914b4df4382e7aee5bc2a1cb263 (patch)
treec128a7b853539029f5c1014e72b2570a3e6f3f1a /meta-smx6-extras
parent07b4960e438f4eb772dde4d1ccac153785cf151e (diff)
downloadmeta-boot2qt-c0c98ab5cc94b914b4df4382e7aee5bc2a1cb263.tar.gz
kontron: update SMARC-sAMX6i BSP to r03.00
Change-Id: Ia33509ecbbc9394b7cbdcd548abb0f6f28cf3c73 Reviewed-by: Rainer Keller <Rainer.Keller@qt.io>
Diffstat (limited to 'meta-smx6-extras')
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch52
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch59
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch31
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6_4.10.11.bbappend (renamed from meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend)16
-rw-r--r--meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend32
-rw-r--r--meta-smx6-extras/recipes/perf/perf.bbappend30
-rw-r--r--meta-smx6-extras/recipes/qt5/qtbase_git.bbappend30
7 files changed, 94 insertions, 156 deletions
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch b/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
deleted file mode 100644
index ee61a74..0000000
--- a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From ef372125fd64fc181869be4cf528488f9e8b46c2 Mon Sep 17 00:00:00 2001
2From: Behan Webster <behanw@converseincode.com>
3Date: Wed, 24 Sep 2014 01:06:46 +0100
4Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
5
6With compilers which follow the C99 standard (like modern versions of gcc and
7clang), "extern inline" does the wrong thing (emits code for an externally
8linkable version of the inline function). In this case using static inline
9and removing the NULL version of return_address in return_address.c does
10the right thing.
11
12Signed-off-by: Behan Webster <behanw@converseincode.com>
13Reviewed-by: Mark Charlebois <charlebm@gmail.com>
14Acked-by: Steven Rostedt <rostedt@goodmis.org>
15Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
16---
17 arch/arm/include/asm/ftrace.h | 2 +-
18 arch/arm/kernel/return_address.c | 5 -----
19 2 files changed, 1 insertion(+), 6 deletions(-)
20
21diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
22index f89515a..2bb8cac 100644
23--- a/arch/arm/include/asm/ftrace.h
24+++ b/arch/arm/include/asm/ftrace.h
25@@ -45,7 +45,7 @@ void *return_address(unsigned int);
26
27 #else
28
29-extern inline void *return_address(unsigned int level)
30+static inline void *return_address(unsigned int level)
31 {
32 return NULL;
33 }
34diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
35index fafedd8..f6aa84d 100644
36--- a/arch/arm/kernel/return_address.c
37+++ b/arch/arm/kernel/return_address.c
38@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
39 #warning "TODO: return_address should use unwind tables"
40 #endif
41
42-void *return_address(unsigned int level)
43-{
44- return NULL;
45-}
46-
47 #endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
48
49 EXPORT_SYMBOL_GPL(return_address);
50--
511.9.1
52
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch b/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
deleted file mode 100644
index 064e28b..0000000
--- a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
+++ /dev/null
@@ -1,59 +0,0 @@
1From eb38d22ea05961666878dfb88c68629eacfb1399 Mon Sep 17 00:00:00 2001
2From: Behan Webster <behanw@converseincode.com>
3Date: Tue, 3 Sep 2013 22:27:26 -0400
4Subject: [PATCH] ARM: LLVMLinux: Change "extern inline" to "static inline" in
5 glue-cache.h
6
7With compilers which follow the C99 standard (like modern versions of gcc and
8clang), "extern inline" does the wrong thing (emits code for an externally
9linkable version of the inline function). "static inline" is the correct choice
10instead.
11
12Author: Behan Webster <behanw@converseincode.com>
13Signed-off-by: Behan Webster <behanw@converseincode.com>
14Reviewed-by: Mark Charlebois <charlebm@gmail.com>
15---
16 arch/arm/include/asm/glue-cache.h | 22 +++++++++++-----------
17 1 file changed, 11 insertions(+), 11 deletions(-)
18
19diff --git a/arch/arm/include/asm/glue-cache.h b/arch/arm/include/asm/glue-cache.h
20index c81adc0..a3c24cd 100644
21--- a/arch/arm/include/asm/glue-cache.h
22+++ b/arch/arm/include/asm/glue-cache.h
23@@ -130,22 +130,22 @@
24 #endif
25
26 #ifndef __ASSEMBLER__
27-extern inline void nop_flush_icache_all(void) { }
28-extern inline void nop_flush_kern_cache_all(void) { }
29-extern inline void nop_flush_kern_cache_louis(void) { }
30-extern inline void nop_flush_user_cache_all(void) { }
31-extern inline void nop_flush_user_cache_range(unsigned long a,
32+static inline void nop_flush_icache_all(void) { }
33+static inline void nop_flush_kern_cache_all(void) { }
34+static inline void nop_flush_kern_cache_louis(void) { }
35+static inline void nop_flush_user_cache_all(void) { }
36+static inline void nop_flush_user_cache_range(unsigned long a,
37 unsigned long b, unsigned int c) { }
38
39-extern inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
40-extern inline int nop_coherent_user_range(unsigned long a,
41+static inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
42+static inline int nop_coherent_user_range(unsigned long a,
43 unsigned long b) { return 0; }
44-extern inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
45+static inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
46
47-extern inline void nop_dma_flush_range(const void *a, const void *b) { }
48+static inline void nop_dma_flush_range(const void *a, const void *b) { }
49
50-extern inline void nop_dma_map_area(const void *s, size_t l, int f) { }
51-extern inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
52+static inline void nop_dma_map_area(const void *s, size_t l, int f) { }
53+static inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
54 #endif
55
56 #ifndef MULTI_CACHE
57--
581.9.1
59
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch b/meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch
deleted file mode 100644
index c61a4dc..0000000
--- a/meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 56e321cd19ee4909ca623ce1c351c966904123a9 Mon Sep 17 00:00:00 2001
2From: Pantelis Antoniou <panto@antoniou-consulting.com>
3Date: Fri, 4 Jan 2013 00:32:33 +0200
4Subject: [PATCH] arm: Export cache flush management symbols when !MULTI_CACHE
5
6When compiling a kernel without CONFIG_MULTI_CACHE enabled the
7dma access functions end up not being exported. Fix it.
8
9Signed-off-by: Pantelis Antoniou <panto@antoniou-consulting.com>
10Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
11---
12 arch/arm/kernel/setup.c | 9 +++++++++
13 1 file changed, 9 insertions(+)
14
15diff --git a/arch/arm/kernel/setup.c b/arch/arm/kernel/setup.c
16index 1e8b030..c6a9a61 100644
17--- a/arch/arm/kernel/setup.c
18+++ b/arch/arm/kernel/setup.c
19@@ -1080,3 +1080,12 @@ const struct seq_operations cpuinfo_op = {
20 .stop = c_stop,
21 .show = c_show
22 };
23+
24+/* export the cache management functions */
25+#ifndef MULTI_CACHE
26+
27+EXPORT_SYMBOL(__glue(_CACHE,_dma_map_area));
28+EXPORT_SYMBOL(__glue(_CACHE,_dma_unmap_area));
29+EXPORT_SYMBOL(__glue(_CACHE,_dma_flush_range));
30+
31+#endif
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend b/meta-smx6-extras/recipes/linux/linux-smx6_4.10.11.bbappend
index 574e60b..c8222b9 100644
--- a/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend
+++ b/meta-smx6-extras/recipes/linux/linux-smx6_4.10.11.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -27,19 +27,7 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 30do_configure_prepend() {
31SRC_URI += " \
32 file://0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch \
33 file://0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch \
34 file://0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch \
35 "
36
37do_preconfigure_prepend() {
38 sed -e '/CONFIG_USB_FUNCTIONFS_ETH=/d' \
39 -e '/CONFIG_USB_FUNCTIONFS_RNDIS=/d' \
40 -i ${WORKDIR}/defconfig
41
42 echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig 31 echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
43 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
44 echo "CONFIG_CGROUPS=y" >> ${WORKDIR}/defconfig 32 echo "CONFIG_CGROUPS=y" >> ${WORKDIR}/defconfig
45} 33}
diff --git a/meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend b/meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend
new file mode 100644
index 0000000..9f11d6a
--- /dev/null
+++ b/meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30EXTRA_OECONF += "--disable-libunwind"
31
32PROVIDES += "virtual/libgbm"
diff --git a/meta-smx6-extras/recipes/perf/perf.bbappend b/meta-smx6-extras/recipes/perf/perf.bbappend
new file mode 100644
index 0000000..afbed0d
--- /dev/null
+++ b/meta-smx6-extras/recipes/perf/perf.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30EXTRA_OEMAKE += "NO_JVMTI=1"
diff --git a/meta-smx6-extras/recipes/qt5/qtbase_git.bbappend b/meta-smx6-extras/recipes/qt5/qtbase_git.bbappend
new file mode 100644
index 0000000..602782e
--- /dev/null
+++ b/meta-smx6-extras/recipes/qt5/qtbase_git.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG += "gbm kms"