summaryrefslogtreecommitdiffstats
path: root/meta-smx6-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-23 13:23:56 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-24 09:42:12 +0000
commit0d5594111ea1712f731cff174f21b3e2c4246c15 (patch)
tree341021629532e54e679c05de8fedf4fe030b4b2d /meta-smx6-extras
parenteb86db52fda9ef2c88312172e4608993104d3b00 (diff)
downloadmeta-boot2qt-0d5594111ea1712f731cff174f21b3e2c4246c15.tar.gz
kontron: update to Yocto BSP for SMARC-sAMX6i R02.00
Change-Id: If0f8dc2c786bc63fba69531fa009efd8ae8111b7 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-smx6-extras')
-rw-r--r--meta-smx6-extras/conf/layer.conf37
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend26
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-smx6-extras/conf/layer.conf b/meta-smx6-extras/conf/layer.conf
new file mode 100644
index 0000000..097fefe
--- /dev/null
+++ b/meta-smx6-extras/conf/layer.conf
@@ -0,0 +1,37 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28 "
29
30BBFILE_COLLECTIONS += "b2qt_smx6"
31BBFILE_PATTERN_b2qt_smx6 := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_smx6 = "20"
33
34# meta-smx6 depends on fsl-demos, but that's not needed
35LAYERDEPENDS_smx6 = ""
36# meta-smx6 layer.conf modifies qtbase PACKAGECONFIG
37PACKAGECONFIG_remove_pn-qtbase = "examples"
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend b/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend
new file mode 100644
index 0000000..00f3c11
--- /dev/null
+++ b/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend
@@ -0,0 +1,26 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22do_configure_prepend() {
23 echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
24 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
25 echo "CONFIG_CGROUPS=y" >> ${WORKDIR}/defconfig
26}