summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-08-18 13:06:48 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-08-19 06:09:41 +0000
commitdb175fc660e65ef9ded6d999087a9b9aa307b4e5 (patch)
tree34d521a5b92c8cb420052a0567429529afd05d09 /meta-renesas-extras
parentcdf98603a186c49ece6007d3c300b6e6aa845b74 (diff)
downloadmeta-boot2qt-db175fc660e65ef9ded6d999087a9b9aa307b4e5.tar.gz
renesas: fix build issues caused by pyro change
Change-Id: I25f74a1fb8e912f1f069b657fc63e66a9eb1e887 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-renesas-extras')
-rw-r--r--meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend8
-rw-r--r--meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h24
-rw-r--r--meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend30
-rw-r--r--meta-renesas-extras/recipes/mesa/mesa_%.bbappend (renamed from meta-renesas-extras/recipes/mesa/mesa_12.%.bbappend)0
-rw-r--r--meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend4
-rw-r--r--meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend30
-rw-r--r--meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend30
7 files changed, 126 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend b/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend
index 8a9bda0..9806a3c 100644
--- a/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend
+++ b/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend
@@ -27,4 +27,12 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI_append = " file://gl3ext.h"
33
30DEPENDS = "mesa" 34DEPENDS = "mesa"
35
36do_install_append() {
37 install -m 644 ${WORKDIR}/gl3ext.h ${D}/${includedir}/GLES3/
38}
diff --git a/meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h b/meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h
new file mode 100644
index 0000000..4d4ea96
--- /dev/null
+++ b/meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h
@@ -0,0 +1,24 @@
1#ifndef __gl3ext_h_
2#define __gl3ext_h_
3
4/* $Revision: 17809 $ on $Date:: 2012-05-14 08:03:36 -0700 #$ */
5
6/*
7 * This document is licensed under the SGI Free Software B License Version
8 * 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
9 */
10
11/* OpenGL ES 3 Extensions
12 *
13 * After an OES extension's interactions with OpenGl ES 3.0 have been documented,
14 * its tokens and function definitions should be added to this file in a manner
15 * that does not conflict with gl2ext.h or gl3.h.
16 *
17 * Tokens and function definitions for extensions that have become standard
18 * features in OpenGL ES 3.0 will not be added to this file.
19 *
20 * Applications using OpenGL-ES-2-only extensions should include gl2ext.h
21 */
22
23#endif /* __gl3ext_h_ */
24
diff --git a/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 0000000..85be953
--- /dev/null
+++ b/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DEPENDS += "wayland-kms libgbm"
diff --git a/meta-renesas-extras/recipes/mesa/mesa_12.%.bbappend b/meta-renesas-extras/recipes/mesa/mesa_%.bbappend
index 0542b65..0542b65 100644
--- a/meta-renesas-extras/recipes/mesa/mesa_12.%.bbappend
+++ b/meta-renesas-extras/recipes/mesa/mesa_%.bbappend
diff --git a/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend b/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend
index 361abbf..47fe2ce 100644
--- a/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend
+++ b/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend
@@ -27,10 +27,14 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30LICENSE = "GPLv2+"
31
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 32FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31 33
32SRC_URI += "file://0001-compiler-.h-sync-include-linux-compiler-.h-with-Linu.patch" 34SRC_URI += "file://0001-compiler-.h-sync-include-linux-compiler-.h-with-Linu.patch"
33 35
36S = "${WORKDIR}/git"
37
34do_deploy_prepend() { 38do_deploy_prepend() {
35 cp ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC} 39 cp ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
36} 40}
diff --git a/meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend b/meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend
new file mode 100644
index 0000000..0cd3eec
--- /dev/null
+++ b/meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DEPENDS += "wayland-native"
diff --git a/meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend b/meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend
new file mode 100644
index 0000000..ef14c2f
--- /dev/null
+++ b/meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30EXTRA_OECONF += "WAYLAND_PROTOCOLS_SYSROOT_DIR=${RECIPE_SYSROOT}"