summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/qt5
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-03 16:57:08 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-06 05:57:52 +0000
commit80402502806c94d2954852549d6549c9e333c586 (patch)
treee389c8d6d8ab2b53471f24e2cfc002dc98870b1a /meta-renesas-extras/recipes/qt5
parentcfebf8586735f4db9c9573c1af9eb1553132c0e8 (diff)
downloadmeta-boot2qt-80402502806c94d2954852549d6549c9e333c586.tar.gz
renesas: update recipes to work with krogoth
Extra patch needed for linux libc headers to get systemd to build. ../git/src/basic/btrfs-util.c:1122:23: error: 'BTRFS_IOC_QUOTA_RESCAN_WAIT' undeclared (first use in this function) Change-Id: I52492cff70228bee477b1e5b287af66138564dd1 Reviewed-by: Tuomas Heimonen <tuomas.heimonen@theqtcompany.com>
Diffstat (limited to 'meta-renesas-extras/recipes/qt5')
-rw-r--r--meta-renesas-extras/recipes/qt5/qt3d/0001-Remove-qgltf.patch25
-rw-r--r--meta-renesas-extras/recipes/qt5/qt3d_git.bbappend34
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/qt5/qt3d/0001-Remove-qgltf.patch b/meta-renesas-extras/recipes/qt5/qt3d/0001-Remove-qgltf.patch
new file mode 100644
index 0000000..48a4085
--- /dev/null
+++ b/meta-renesas-extras/recipes/qt5/qt3d/0001-Remove-qgltf.patch
@@ -0,0 +1,25 @@
1From 49a04f4faa135fa6ef56fc35dfb9dfe55ff2a3c4 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 18 Nov 2015 10:14:18 +0200
4Subject: [PATCH] Remove qgltf
5
6assimp does not compile for ARM because of GCC bug
7(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66964)
8
9Task-number: QTBUG-49153
10---
11 tools/tools.pro | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/tools/tools.pro b/tools/tools.pro
15index 055f412..c1eba7f 100644
16--- a/tools/tools.pro
17+++ b/tools/tools.pro
18@@ -1,3 +1,3 @@
19 TEMPLATE = subdirs
20-SUBDIRS = qgltf
21+#SUBDIRS = qgltf
22 qgltf.CONFIG += host_build
23--
241.9.1
25
diff --git a/meta-renesas-extras/recipes/qt5/qt3d_git.bbappend b/meta-renesas-extras/recipes/qt5/qt3d_git.bbappend
new file mode 100644
index 0000000..d32d0e6
--- /dev/null
+++ b/meta-renesas-extras/recipes/qt5/qt3d_git.bbappend
@@ -0,0 +1,34 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31
32SRC_URI_append_class-target = " \
33 file://0001-Remove-qgltf.patch \
34 "