summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb
diff options
context:
space:
mode:
authorLouai Al-Khanji <louai.al-khanji@theqtcompany.com>2016-03-14 16:53:56 -0700
committerLouai Al-Khanji <louai.al-khanji@qt.io>2016-05-10 15:26:17 +0000
commita42496a9498739cb7362d11dd7c22d08b39ccbb9 (patch)
treeb6a6e84fcc9c69f81689979a043234ff748bab8d /meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb
parent4a0beee17a7b3be144771363920419604f1facec (diff)
downloadmeta-boot2qt-a42496a9498739cb7362d11dd7c22d08b39ccbb9.tar.gz
Add Support for Renesas R-Car Gen2 Devices
I have only personally tested the porter build as it's the only device I have, but getting the others to work as well should be straight forward. Please see the note in conf/distro/include/rcar-gen2.inc about the binary drivers. The documentation we ship with Qt Creator should expand on how to install the drivers. Additionally we must check with Renesas how we could redistribute prebuilt images if we want to do that. Change-Id: I82e03aad9b43bee068aaa0472aeac4d394f049a8 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb')
-rw-r--r--meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb b/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb
new file mode 100644
index 0000000..cfa9a66
--- /dev/null
+++ b/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-libav_1.2.3.bb
@@ -0,0 +1,27 @@
1DEFAULT_PREFERENCE = "-1"
2
3include recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
7 file://ext/libav/gstav.h;beginline=1;endline=18;md5=a752c35267d8276fd9ca3db6994fca9c \
8 file://gst-libs/ext/libav/LICENSE;md5=23a54f59b82572c203a559346e89ed57 \
9 file://gst-libs/ext/libav/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://gst-libs/ext/libav/COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
11 file://gst-libs/ext/libav/COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
12 file://gst-libs/ext/libav/COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
13
14SRC_URI = " \
15 http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${PV}.tar.xz \
16 file://0001-Disable-yasm-for-libav-when-disable-yasm.patch \
17 "
18SRC_URI[md5sum] = "58c7998a054d8d8ca041fa35738f72b6"
19SRC_URI[sha256sum] = "ebc7fbe10955f40df6ccc4bf689075e7e296205fc7ecd8ff383d43c5cdf5bcd6"
20LIBAV_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
21 --cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
22 --ranlib='${RANLIB}' \
23 ${GSTREAMER_1_0_DEBUG}"
24
25S = "${WORKDIR}/gst-libav-${PV}"
26
27