summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/conf
diff options
context:
space:
mode:
authorLouai Al-Khanji <louai.al-khanji@theqtcompany.com>2016-03-14 16:53:56 -0700
committerLouai Al-Khanji <louai.al-khanji@qt.io>2016-05-10 15:26:17 +0000
commita42496a9498739cb7362d11dd7c22d08b39ccbb9 (patch)
treeb6a6e84fcc9c69f81689979a043234ff748bab8d /meta-renesas-extras/conf
parent4a0beee17a7b3be144771363920419604f1facec (diff)
downloadmeta-boot2qt-a42496a9498739cb7362d11dd7c22d08b39ccbb9.tar.gz
Add Support for Renesas R-Car Gen2 Devices
I have only personally tested the porter build as it's the only device I have, but getting the others to work as well should be straight forward. Please see the note in conf/distro/include/rcar-gen2.inc about the binary drivers. The documentation we ship with Qt Creator should expand on how to install the drivers. Additionally we must check with Renesas how we could redistribute prebuilt images if we want to do that. Change-Id: I82e03aad9b43bee068aaa0472aeac4d394f049a8 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-renesas-extras/conf')
-rw-r--r--meta-renesas-extras/conf/layer.conf32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-renesas-extras/conf/layer.conf b/meta-renesas-extras/conf/layer.conf
new file mode 100644
index 0000000..7961748
--- /dev/null
+++ b/meta-renesas-extras/conf/layer.conf
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28 "
29
30BBFILE_COLLECTIONS += "b2qt_renesas"
31BBFILE_PATTERN_b2qt_renesas := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_renesas = "20"