summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-03-31 11:01:04 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 14:47:11 +0300
commitae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5 (patch)
treeacaecd3b089b341f87dd27384bb800c9b497148d /meta-raspberrypi-extras
parent5fcb893d078d718318ca94bf7f284ef35355c152 (diff)
downloadmeta-boot2qt-ae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5.tar.gz
Build Qt5 and all addons
Use meta-qt5 layer to build Qt5, commercial addons and b2qt addons. Create new image and toolchain recipes with Qt5 content, so that the existing image and toolchain remain as-is without Qt5. Currently support only for imx6 targets. Change-Id: I398750dd1a62c6ff8ea216cfe364da273d8e9a77 Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend b/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend
new file mode 100644
index 0000000..92e08b7
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_prepend_rpi() {
24 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
25 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
26RPI_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
27
28QMAKE_INCDIR_EGL = \$\$[QT_SYSROOT]/usr/include/interface/vcos/pthreads \
29 \$\$[QT_SYSROOT]/usr/include/interface/vmcs_host/linux
30QMAKE_INCDIR_OPENGL_ES2 = \$\${QMAKE_INCDIR_EGL}
31
32QMAKE_LIBS_EGL = -lEGL -lGLESv2
33QMAKE_CFLAGS += \$\$RPI_CFLAGS
34QMAKE_CXXFLAGS += \$\$RPI_CFLAGS
35
36EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/../devices/linux-rasp-pi-g++/qeglfshooks_pi.cpp
37EGLFS_PLATFORM_HOOKS_LIBS = -lbcm_host
38
39load(qt_config)
40
41EOF
42}