summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2018-04-24 12:21:02 +0200
committerUlf Hermann <ulf.hermann@qt.io>2018-04-25 08:53:19 +0000
commit9484422a256f2b2d8aea29302a76d03bff377bfb (patch)
tree05c543f7a8c2759f13efb5e8dd3c1e94fc6e51e6 /meta-raspberrypi-extras
parent59e7092a7fd85186157ce87b70fedda1d190e0e5 (diff)
downloadmeta-boot2qt-9484422a256f2b2d8aea29302a76d03bff377bfb.tar.gz
Enable uprobes for raspberrypi
Task-number: QTBUG-67891 Change-Id: Ie9e2e6775aeb5fca16d624a02ef570447a97145d Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend b/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend
new file mode 100644
index 0000000..d6ea12f
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_configure_prepend() {
31 echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
32}