summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-07 15:52:32 +0200
committerRisto Avila <risto.avila@theqtcompany.com>2016-03-08 07:29:34 +0000
commit6136e6009970859fc02477cdd37fb29a2031566f (patch)
treed9e111fe72ed1703541b48dd8a3298d5a294db03 /meta-raspberrypi-extras/recipes
parent7eba608a92ee934440a5468ed81237bbae90f12a (diff)
downloadmeta-boot2qt-6136e6009970859fc02477cdd37fb29a2031566f.tar.gz
RPi2: add support for touch display
The RPi touch display need the rpi-tf5604 devicetree to enable touch. Add it to the kernel build and enabled it in the config.txt. Update meta-raspberrypi to latest revision for the PiTFT support. Change-Id: Ibc5ba51c844bc17b541d8021a755f141a5ff2a0c Reviewed-by: Risto Avila <risto.avila@theqtcompany.com>
Diffstat (limited to 'meta-raspberrypi-extras/recipes')
-rw-r--r--meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 0000000..b711ab5
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,27 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22do_deploy_append() {
23 if [ "${RPI_FT5604}" = "1" ]; then
24 echo "# Enable rpi-ft5604 touch" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
25 echo "dtoverlay=rpi-ft5406" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
26 fi
27}