summaryrefslogtreecommitdiffstats
path: root/meta-nvidia-logan-extras
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2015-11-27 12:35:49 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-14 15:06:53 +0000
commit0d752a4b59a72f3cc95390083e1c606962b42411 (patch)
treea9d04c6f5acde61a3f29d78fa61f38b66061ba9d /meta-nvidia-logan-extras
parented793d57679af4065a4326946ce42415fd9484e1 (diff)
downloadmeta-boot2qt-0d752a4b59a72f3cc95390083e1c606962b42411.tar.gz
Added support for Jetson-tk1-pro device.
The configuration has dependency to the interal repositories (meta-tegra and jetson-tk1-pro). Change-Id: I5e13377cf8cfbe4fad3f19215a292b49195f1546 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-nvidia-logan-extras')
-rw-r--r--meta-nvidia-logan-extras/conf/layer.conf33
-rw-r--r--meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend33
-rw-r--r--meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf4
-rw-r--r--meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend24
-rw-r--r--meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend24
5 files changed, 118 insertions, 0 deletions
diff --git a/meta-nvidia-logan-extras/conf/layer.conf b/meta-nvidia-logan-extras/conf/layer.conf
new file mode 100644
index 0000000..0fc22ca
--- /dev/null
+++ b/meta-nvidia-logan-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29"
30
31BBFILE_COLLECTIONS += "b2qt_nvidia-logan"
32BBFILE_PATTERN_b2qt_nvidia-logan := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_nvidia-logan = "20"
diff --git a/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend
new file mode 100644
index 0000000..becde5f
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf.bbappend
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25FILES_${PN} += "etc/connman/main.conf"
26
27SRC_URI += "file://main.conf \
28 "
29
30do_install_append() {
31 install -d ${D}${sysconfdir}/connman
32 install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
33}
diff --git a/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
new file mode 100644
index 0000000..a1e45b9
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
@@ -0,0 +1,4 @@
1[General]
2PreferredTechnologies=ethernet,wifi,cellular
3NetworkInterfaceBlacklist=eth0
4
diff --git a/meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend
new file mode 100644
index 0000000..1cb7143
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/qt5/qtbase_git.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DEPENDS += "graphics-headers"
24
diff --git a/meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend
new file mode 100644
index 0000000..78453ef
--- /dev/null
+++ b/meta-nvidia-logan-extras/recipes/qt5/qtwebengine_git.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
24