summaryrefslogtreecommitdiffstats
path: root/meta-nvidia-extras
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2016-04-13 15:47:51 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-05 08:16:14 +0000
commit86ce53afdeb5fbf863100231b83521bf34375930 (patch)
tree2926e8631c2197bdcb10a35c0d31cf5c4e078945 /meta-nvidia-extras
parent5800a3bfe48a2092ac3b8cf250f04840a6397f3f (diff)
downloadmeta-boot2qt-86ce53afdeb5fbf863100231b83521bf34375930.tar.gz
Fix to NVidia's tegra configurations.
Changed both nvidia-logan and tegra-t18x to use the same metalayer from the Vibrante 4.0 SDK. Kernel sources and libraries are stored into the internal CI repository. These definitions can be overridden by SDK folder using following environment variables: export KERN_DIR=~/Vibrante4.0_RC1/vibrante-t186ref-linux_src/kernel export PLATFORM_TOPDIR=~/Vibrante4.0_RC1/vibrante-t186ref-linux export TOOLCHAIN_PATH=~/Vibrante4.0_RC1/toolchains/tegra-4.9-nv export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE TOOLCHAIN_PATH KERN_DIR PLATFORM_TOPDIR" Change-Id: If58a0fcbe01daa9a55dd041b79a9d80a90fde284 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-nvidia-extras')
-rw-r--r--meta-nvidia-extras/conf/layer.conf32
-rw-r--r--meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend32
-rw-r--r--meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf4
-rw-r--r--meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend28
-rw-r--r--meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend4
-rw-r--r--meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend23
-rw-r--r--meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend23
-rw-r--r--meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch18
-rw-r--r--meta-nvidia-extras/recipes/systemd/systemd_%.bbappend1
-rw-r--r--meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend12
-rw-r--r--meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend9
11 files changed, 0 insertions, 186 deletions
diff --git a/meta-nvidia-extras/conf/layer.conf b/meta-nvidia-extras/conf/layer.conf
deleted file mode 100644
index aa447a5..0000000
--- a/meta-nvidia-extras/conf/layer.conf
+++ /dev/null
@@ -1,32 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28"
29
30BBFILE_COLLECTIONS += "b2qt_nvidia"
31BBFILE_PATTERN_b2qt_nvidia := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_nvidia = "20"
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend b/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend
deleted file mode 100644
index 86f0571..0000000
--- a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend
+++ /dev/null
@@ -1,32 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23
24FILES_${PN} += "etc/connman/main.conf"
25
26SRC_URI += "file://main.conf \
27 "
28
29do_install_append() {
30 install -d ${D}${sysconfdir}/connman
31 install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
32}
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf b/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
deleted file mode 100644
index a1e45b9..0000000
--- a/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
+++ /dev/null
@@ -1,4 +0,0 @@
1[General]
2PreferredTechnologies=ethernet,wifi,cellular
3NetworkInterfaceBlacklist=eth0
4
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
deleted file mode 100644
index f9d9cc6..0000000
--- a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
1do_kernel_defconfig_prepend_tegra-t18x () {
2}
3
4do_install_append_tegra-t18x () {
5 s=$(readlink -m "${S}")
6 kernsrc="${STAGING_KERNEL_DIR}"
7
8 if [ "${s}" != "${kernsrc}" ]; then
9 mkdir -p "${kernsrc}"
10 rm -rf "${kernsrc}"
11 mv "${S}" "${STAGING_KERNEL_DIR}"
12 ln -sf "${kernsrc}" "${s}"
13 fi
14}
15
16do_compile_prepend_tegra-t18x () {
17 if [ -z "${TOOLCHAIN_PATH}" ] ; then
18 echo "TOOLCHAIN_PATH must be set"
19 exit -1
20 fi
21
22 export PATH="${TOOLCHAIN_PATH}/usr/bin/aarch64-gnu-linux:${PATH}"
23
24 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
25 echo "CONFIG_USB_ACM=m" >> ${B}/.config
26
27 make olddefconfig
28}
diff --git a/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend b/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend
deleted file mode 100644
index 1800e5e..0000000
--- a/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
1RDEPENDS_${PN}_remove_tegra-t18x = "\
2libgbm-dev \
3"
4
diff --git a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend
deleted file mode 100644
index cd74ddf..0000000
--- a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DEPENDS_nvidia-logan += "graphics-headers"
23PACKAGECONFIG_nvidia-logan += "kms"
diff --git a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend
deleted file mode 100644
index 97acf20..0000000
--- a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
23COMPATIBLE_MACHINE_aarch64 = "(.*)"
diff --git a/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch b/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
deleted file mode 100644
index 629ccf4..0000000
--- a/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
+++ /dev/null
@@ -1,18 +0,0 @@
1diff --git a/configure.ac b/configure.ac
2index 97a29d6..b0e4060 100644
3--- a/configure.ac
4+++ b/configure.ac
5@@ -208,10 +208,6 @@ AS_CASE([$CC], [*clang*],
6 -Wno-gnu-variable-sized-type-not-at-end \
7 ])])
8
9-AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
10- [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
11- -flto -ffat-lto-objects])],
12- [AC_MSG_RESULT([skipping -flto, optimization not enabled])])
13 AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags")
14
15 AS_CASE([$CFLAGS], [*-O[[12345\ ]]*],
16--
172.5.0
18
diff --git a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend b/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend
deleted file mode 100644
index d86ee9d..0000000
--- a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend_tegra-t18x := "${THISDIR}/${PN}:"
diff --git a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
deleted file mode 100644
index 85a2996..0000000
--- a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
1GRAPHICS_PACKAGES = " \
2virtual/libgles2 \
3virtual/libegl \
4virtual/egl \
5libgbm \
6libgbm-dev \
7"
8
9PROVIDES_append = " ${GRAPHICS_PACKAGES}"
10RPROVIDES_append_${PN} = " ${GRAPHICS_PACKAGES}"
11CONFLICTS_append_${PN} = " ${GRAPHICS_PACKAGES}"
12REPLACES_append_${PN} = " ${GRAPHICS_PACKAGES}"
diff --git a/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend b/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend
deleted file mode 100644
index db0da64..0000000
--- a/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
1EXTRA_PROVIDES = " \
2virtual/wayland-native \
3wayland-native \
4"
5
6PROVIDES_append = "${EXTRA_PROVIDES}"
7RPROVIDES_append_${PN} = "${EXTRA_PROVIDES}"
8CONFLICTS_append_${PN} = "${EXTRA_PROVIDES}"
9REPLACES_append_${PN} = "${EXTRA_PROVIDES}"