diff options
author | Louai Al-Khanji <louai.al-khanji@theqtcompany.com> | 2016-03-10 23:39:46 -0800 |
---|---|---|
committer | Louai Al-Khanji <louai.al-khanji@theqtcompany.com> | 2016-03-22 14:16:00 +0000 |
commit | 431c82aefd72d6eb7a73b704bc7c6dadcd9295c5 (patch) | |
tree | 7474e42ac03bc705a772a3174c542ff8eef7032a /meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend | |
parent | ccec3da8bfeef0e86a153772130212e36f68e8c8 (diff) | |
download | meta-boot2qt-431c82aefd72d6eb7a73b704bc7c6dadcd9295c5.tar.gz |
nvidia-t18x support
Steps to use this:
Set up vibrante installation, mine looks like this:
$ ls -l ~/VibranteSDK
total 234880
drwxrwxr-x 1 louai louai 298 Mar 20 2014 eclipse
-r-xr-xr-x 1 louai louai 171826846 Jan 4 09:59 NVIDIA_Tegra_Graphics_Debugger_2.1_linux-v4l_l4t-egl.run
-r--r--r-- 1 louai louai 68688729 Jan 4 09:59 NVIDIA_Tegra_System_Profiler_2.5-linux-x64.tar.gz
drwxr-xr-x 1 louai louai 262 Jan 5 14:50 toolchains
drwxrwxr-x 1 louai louai 34 Jan 5 13:55 vibrante-oss-src
drwxr-xr-x 1 louai louai 12 Jan 4 09:47 vibrante-t186ref-cuda
drwxrwxr-x 1 louai louai 264 Feb 10 10:50 vibrante-t186ref-foundation
drwxr-xr-x 1 louai louai 164 Jan 5 14:49 vibrante-t186ref-foundation_src
drwxrwxr-x 1 louai louai 228 Jan 5 13:56 vibrante-t186ref-linux
drwxr-xr-x 1 louai louai 314 Feb 10 10:58 vibrante-t186ref-linux_sr
Set up Yocto build dir:
$ mkdir ~/work
$ cd ~/work
$ ~/tqtc-b2qt/yocto-meta/b2qt-init-build-env init --device tegra-t18x
Add NVIDIA's Yocto things:
$ mkdir ~/work/sources/nvidia-layer
$ cd ~/work/sources/nvidia-layer
$ tar xf ~/VibranteSDK/vibrante-t186ref-linux_src/yocto/nvidia-layer.tgz
$ cd -
Set up build environment:
$ export MACHINE=tegra-t18x
$ . setup-environment.sh
Set the following environment variables:
$ export KERN_DIR=~/VibranteSDK/vibrante-t186ref-linux_src/kernel
$ export PLATFORM_TOPDIR=~/VibranteSDK/vibrante-t186ref-linux
$ export TOOLCHAIN_PATH=~/VibranteSDK/toolchains/tegra-4.9-nv
$ export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE TOOLCHAIN_PATH KERN_DIR PLATFORM_TOPDIR"
Add NVLAYER_DIR to local.conf:
$ echo 'NVLAYER_DIR = "${TOPDIR}/../sources/nvidia-layer"' >> conf/local.conf
Build your image:
$ bitbake b2qt-embedded-qt5-image
Flash your board:
$ cd $PLATFORM_TOPDIR
$ mv targetfs targetfs-old
$ cd targetfs && tar xf /path/to/rootfs.tar.bz2
$ cd ../../vibrante-t186ref-foundation/utils/scripts/bootburn
$ ./bootburn.sh -b p2382-t186
Change-Id: I4209cd0c19a007c4457460fd67342fc579c2a735
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend')
-rw-r--r-- | meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend new file mode 100644 index 0000000..cd74ddf --- /dev/null +++ b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend | |||
@@ -0,0 +1,23 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DEPENDS_nvidia-logan += "graphics-headers" | ||
23 | PACKAGECONFIG_nvidia-logan += "kms" | ||