summaryrefslogtreecommitdiffstats
path: root/meta-nuc-extras
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-02-21 10:37:05 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2016-02-23 11:18:52 +0000
commit769ae5571a5501cbe9c3b12c560a3e6916bff4ca (patch)
tree33c5254310011553b5cbaa2d0303920ab0df6da1 /meta-nuc-extras
parentf6af3a3551f3cb6c90aa05d90941c6140a674279 (diff)
downloadmeta-boot2qt-769ae5571a5501cbe9c3b12c560a3e6916bff4ca.tar.gz
NUC: Use custom image layout
This patch adds a new image class 'image_dd', by default it has an empty boot partition. image_dd_efi extends this class to support Intel NUC board. The layout of a generated image is a prerequisite for OSTree integarion. Image generated by 'hddimg' produces rootfs.img (ext3 filesystem file) and then "live" boots it from initramfs by mounting rootfs.img via loop device. For OTA integration we need to access contents of rootfs.img already from boot loader. The custom 'image_nuc_efi' layout allow for fully atomic updates on EFI based system, by keeping GRUB-EFI binary on a dedicated EFI system partition (ESP). OSTree currently is not fully atomic on EFI systems, but with this setup we use GRUB-BIOS code path in OSTree, which is atomic. After EFI firmware has loaded the GRUB-EFI binary, everything else is done on rootfs parition. One limitation from the above scenario is that you would need to update /EFI/BOOT/bootx64.efi (GRUB-EFI) binary manually. Not sure how common it is to update a boot loader binary on a deployed system, but its not impossible. Change-Id: Ibf2840aecd548000372131c4ded5cffa11ff1b0f Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-nuc-extras')
-rw-r--r--meta-nuc-extras/classes/image_dd_efi.bbclass45
-rw-r--r--meta-nuc-extras/recipes/grub/grub-efi/grub.cfg10
-rw-r--r--meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend40
3 files changed, 95 insertions, 0 deletions
diff --git a/meta-nuc-extras/classes/image_dd_efi.bbclass b/meta-nuc-extras/classes/image_dd_efi.bbclass
new file mode 100644
index 0000000..7bbff62
--- /dev/null
+++ b/meta-nuc-extras/classes/image_dd_efi.bbclass
@@ -0,0 +1,45 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Extends image_dd class to boot via GRUB-EFI and initramfs."
23LICENSE = "CLOSED"
24
25inherit image_dd
26
27EXTRA_IMAGECMD_ext3 += "-L rootfs"
28IMAGE_DEPENDS_ext3 += "initramfs-basic:do_rootfs"
29
30IMAGE_CMD_ext3_prepend() {
31
32 # https://www.kernel.org/doc/Documentation/x86/early-microcode.txt
33 microcode="${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', '${DEPLOY_DIR_IMAGE}/microcode.cpio ', '', d)}"
34 cat ${microcode} ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz > ${IMAGE_ROOTFS}/boot/initramfs
35 chmod 0644 ${IMAGE_ROOTFS}/boot/initramfs
36}
37
38do_populate_boot() {
39
40 mkdir -p ${WORKDIR}/EFI/BOOT/
41 # Path where EFI firmware searches for EFI executable
42 cp ${DEPLOY_DIR_IMAGE}/bootx64.efi ${WORKDIR}/EFI/BOOT/
43 mcopy -s -i ${WORKDIR}/boot.img ${WORKDIR}/EFI ::/EFI
44}
45
diff --git a/meta-nuc-extras/recipes/grub/grub-efi/grub.cfg b/meta-nuc-extras/recipes/grub/grub-efi/grub.cfg
new file mode 100644
index 0000000..ca53537
--- /dev/null
+++ b/meta-nuc-extras/recipes/grub/grub-efi/grub.cfg
@@ -0,0 +1,10 @@
1# Created by meta-b2qt
2serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
3default=boot
4timeout=10
5
6menuentry 'boot' {
7 linux /boot/bzImage root=LABEL=rootfs
8 initrd /boot/initramfs
9}
10
diff --git a/meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend
new file mode 100644
index 0000000..d002240
--- /dev/null
+++ b/meta-nuc-extras/recipes/grub/grub-efi_2.00.bbappend
@@ -0,0 +1,40 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI += "file://grub.cfg"
24
25do_deploy_prepend() {
26
27cat > ${WORKDIR}/cfg <<EOF
28search.file /boot/grub2/grub.cfg root
29set prefix=/boot/grub2
30EOF
31}
32
33do_install_append() {
34
35 install -d ${D}/boot/grub2/
36 install -m 644 ${WORKDIR}/grub.cfg ${D}/boot/grub2/
37}
38
39PACKAGES += "${PN}-config"
40FILES_${PN}-config = "/boot/grub2/"