summaryrefslogtreecommitdiffstats
path: root/meta-nuc-extras
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2015-11-16 11:41:46 +0200
committerTeemu Holappa <teemu.holappa@theqtcompany.com>2015-11-17 08:00:47 +0000
commit506bad783cc354f164a5460f037034607b758f52 (patch)
treea9bc701eb9aec6cccbce4a896472f4eefb9ac7e7 /meta-nuc-extras
parent143e61048250cb6b90c005b0acfec3fbd3e1dd5d (diff)
downloadmeta-boot2qt-506bad783cc354f164a5460f037034607b758f52.tar.gz
Added Realtek wlan modules for nuc device
Change-Id: I9cc71e06e33dbacde1a6f567218ffb8f9092f2d8 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-nuc-extras')
-rw-r--r--meta-nuc-extras/conf/layer.conf33
-rw-r--r--meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg9
-rw-r--r--meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend26
3 files changed, 68 insertions, 0 deletions
diff --git a/meta-nuc-extras/conf/layer.conf b/meta-nuc-extras/conf/layer.conf
new file mode 100644
index 0000000..6eb4d71
--- /dev/null
+++ b/meta-nuc-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29 "
30
31BBFILE_COLLECTIONS += "b2qt_nuc"
32BBFILE_PATTERN_b2qt_nuc := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_nuc = "20"
diff --git a/meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg b/meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
new file mode 100644
index 0000000..65ac248
--- /dev/null
+++ b/meta-nuc-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
@@ -0,0 +1,9 @@
1CONFIG_RTLWIFI=m
2CONFIG_RTLWIFI_DEBUG=n
3CONFIG_RTL8723AE=m
4CONFIG_RTL8192SE=m
5CONFIG_RTL8192DE=m
6CONFIG_RTL8192CU=m
7CONFIG_RTL8192CE=m
8CONFIG_RTL8192C_COMMON=m
9CONFIG_RTL8188EE=m
diff --git a/meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend b/meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend
new file mode 100644
index 0000000..d6182fc
--- /dev/null
+++ b/meta-nuc-extras/recipes/linux/linux-yocto_3.%.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += "\
25 file://wlan-realtek.cfg \
26 "