summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-03-07 19:51:40 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-03-08 09:53:59 +0200
commitcb9fe99a41d6e0855cb6a7d5febc903b42c52d28 (patch)
tree8e6ca602aeb562ca2e0a2388b6569bbeaf8e4992 /meta-intel-extras
parent36136bf5bd5fe184c3c87e6283bcd8c3f2549b97 (diff)
parentf5baecf4a633d8a4b4117d9c0f9910118c18256a (diff)
downloadmeta-boot2qt-cb9fe99a41d6e0855cb6a7d5febc903b42c52d28.tar.gz
Merge remote-tracking branch 'origin/morty' into pyro
Not entirely a normal kind of merge. In previous merge from origin/morty into pyro several automotive suite specific commits were left out from the merge due conflicts in automotive component recipes between used platforms (morty 5.9 vs. pyro 5.10). The commits previously left out fo the merge are now included in this merge by a direct copy of origin/morty branch's recipes-qt/automotive folder into pyro. An exception is a single commit in pyro (8513b63 - neptune-ui: bump srcrev, install fonts system-wide) that's left in place and merged with origin/morty content. Also, the toolchain changes under packagegroups folder for automotive are applied, thus making the following included commits list: origin/morty: qtdeviceutilities: update to latest version meta-qt5: update meta layer meta-qt5: update meta layer neptune-ui: fetch sources from code.qt.io instead of github automotive: update neptune-ui automotive: update qtapplicationmanager automotive: update components intel: update mesa to 17.0.2 automotive: update qtapplicationmanager automotive: update qtivi & qtapplicatiomanager Update GammaRay to the 2.9.0 release automotive: update qtivi automotive: update revisions automotive: update revisions automotive: update revisions automotive: update revisions Neptune-UI: Update to use the latest Neptune-UI qtivi: Fix the broken python3 binary inside an yocto SDK Update GammaRay qtquickcontrols2: Fix background regression kontron: update SMARC-sAMX6i BSP to r03.00 origin/morty (previously left out): Fix license checksum due to incremented year number Update GammaRay revision multiscreen-demo: update revision and fix startup automotive: update revisions sdk: add qtapplicationmanger staticdev package qtivi: enable ivigenerator for toolchain appman: add dependency to nativesdk-qtdeclarative qtivi: Update to the latest version and add PACKAGECONFIG options for qtsimulator Conflicts: recipes-qt/automotive/gammaray_git.bb recipes-qt/automotive/multiscreen-demo_git.bb recipes-qt/automotive/neptune-ui_git.bb recipes-qt/automotive/qtapplicationmanager_git.bb recipes-qt/automotive/qtivi_git.bb recipes-qt/b2qt-addons/b2qt-demos.bb recipes-qt/qt5/qtdeviceutilities.bb recipes-qt/qt5/qtsystems_git.bbappend scripts/manifest.xml Change-Id: I95ee06882d88e0dc91be1b9a769e4d88e0b11591
Diffstat (limited to 'meta-intel-extras')
-rw-r--r--meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch37
-rw-r--r--meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch29
-rw-r--r--meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch26
-rw-r--r--meta-intel-extras/recipes/mesa/mesa_17.0.2.bb18
4 files changed, 110 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
new file mode 100644
index 0000000..e49695b
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
@@ -0,0 +1,37 @@
1From 2f68fcaaf4964e7feeb383f5c26851965cda037c Mon Sep 17 00:00:00 2001
2From: Jussi Kukkonen <jussi.kukkonen@intel.com>
3Date: Tue, 15 Nov 2016 15:20:49 +0200
4Subject: [PATCH] Simplify wayland-scanner lookup
5
6Don't use pkg-config to lookup the path of a binary that's in the path.
7
8Alternatively we'd have to prefix the path returned by pkg-config with
9PKG_CONFIG_SYSROOT_DIR.
10
11Upstream-Status: Pending
12Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
13---
14 configure.ac | 7 +------
15 1 file changed, 1 insertion(+), 6 deletions(-)
16
17diff --git a/configure.ac b/configure.ac
18index e56e35a..a92005a 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -2020,12 +2020,7 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
22 AC_MSG_ERROR([cannot build egl state tracker without EGL library])
23 fi
24
25-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
26- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
27- WAYLAND_SCANNER='')
28-if test "x$WAYLAND_SCANNER" = x; then
29- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
30-fi
31+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
32
33 # Do per-EGL platform setups and checks
34 egl_platforms=`IFS=', '; echo $with_egl_platforms`
35--
362.1.4
37
diff --git a/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
new file mode 100644
index 0000000..d2d6755
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
@@ -0,0 +1,29 @@
1Configure checks for compiler to be gcc and then it enables asm_offsets
2generation. see
3
4https://cgit.freedesktop.org/mesa/mesa/commit/?id=73c9b4b0e05fc66629ba250846948dc55c0e7a0d
5
6However, we missed the check when enabling this on cross compilation
7when architecture for both host and target is x86
8
9Fixes errors like
10./gen_matypes > matypes.h
11/bin/bash: ./gen_matypes: No such file or directory
12
13-Khem
14
15Upstream-Status: Submitted
16
17Index: mesa-12.0.1/configure.ac
18===================================================================
19--- mesa-12.0.1.orig/configure.ac
20+++ mesa-12.0.1/configure.ac
21@@ -732,7 +732,7 @@ test "x$enable_asm" = xno && AC_MSG_RESU
22 if test "x$enable_asm" = xyes -a "x$cross_compiling" = xyes; then
23 case "$host_cpu" in
24 i?86 | x86_64 | amd64)
25- if test "x$host_cpu" != "x$target_cpu"; then
26+ if test "x$host_cpu" != "x$target_cpu" -o "x$acv_mesa_CLANG" = xyes; then
27 enable_asm=no
28 AC_MSG_RESULT([no, cross compiling])
29 fi
diff --git a/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch b/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch
new file mode 100644
index 0000000..0280ee8
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch
@@ -0,0 +1,26 @@
1endianness check is OS wide and not specific to libc
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Pending
5
6Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
7---
8 src/util/u_endian.h | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/util/u_endian.h b/src/util/u_endian.h
12index b9d563d..2d5eab9 100644
13--- a/src/util/u_endian.h
14+++ b/src/util/u_endian.h
15@@ -27,7 +27,7 @@
16 #ifndef U_ENDIAN_H
17 #define U_ENDIAN_H
18
19-#if defined(__GLIBC__) || defined(ANDROID)
20+#if defined(__linux__)
21 #include <endian.h>
22
23 #if __BYTE_ORDER == __LITTLE_ENDIAN
24--
252.1.4
26
diff --git a/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb b/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb
new file mode 100644
index 0000000..b95f301
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb
@@ -0,0 +1,18 @@
1require recipes-graphics/mesa/${BPN}.inc
2
3SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7"
8
9SRC_URI[md5sum] = "8f808e92b893d412fbd6510e1d16f5c5"
10SRC_URI[sha256sum] = "f8f191f909e01e65de38d5bdea5fb057f21649a3aed20948be02348e77a689d4"
11
12#because we cannot rely on the fact that all apps will use pkgconfig,
13#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
14do_install_append() {
15 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
16 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
17 fi
18}