summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-06-05 15:59:59 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-06-06 12:31:55 +0000
commitb852f57c001f4b0843e9df0ea60698b91cbc0bb8 (patch)
treedf15e227fa335f2c3b5034aa670d01222edb1e24 /meta-intel-extras
parent49af1e5e2a6fcd6f0d8722c411fe7a1a3847a424 (diff)
downloadmeta-boot2qt-b852f57c001f4b0843e9df0ea60698b91cbc0bb8.tar.gz
NUC: disable hw cursor for intel nuc
This is a workaround for a bug, where fonts are not drawn when hw mouse cursor is used together with Qt Quick Controls 2 Task-number: QTBUG-60957 Task-number: QTBUG-61191 Change-Id: Ia7fc6731eff88f1490c788faa87be3b775ffad6a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-intel-extras')
-rw-r--r--meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend38
-rw-r--r--meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf7
-rw-r--r--meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf3
-rw-r--r--meta-intel-extras/recipes/qt5/qtbase_git.bbappend (renamed from meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend)0
4 files changed, 48 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend b/meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend
new file mode 100644
index 0000000..708ed85
--- /dev/null
+++ b/meta-intel-extras/recipes/qt5/b2qt-appcontroller.bbappend
@@ -0,0 +1,38 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://kms.conf"
33
34FILES_${PN} += "${sysconfdir}/kms.conf"
35
36do_install_append() {
37 install -m 0644 ${WORKDIR}/kms.conf ${D}${sysconfdir}/
38}
diff --git a/meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf
new file mode 100644
index 0000000..ca5f455
--- /dev/null
+++ b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/appcontroller.conf
@@ -0,0 +1,7 @@
1env=QT_QPA_EGLFS_KMS_CONFIG=/etc/kms.conf
2env=QML2_IMPORT_PATH=/data/user/qt/qmlplugins
3env=QT_IM_MODULE=qtvirtualkeyboard
4env=QT_QPA_EGLFS_FORCE888=0
5env=QT_QUICK_CONTROLS_1_STYLE=Flat
6env=XDG_RUNTIME_DIR=/tmp
7base=linux
diff --git a/meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf
new file mode 100644
index 0000000..d6da06c
--- /dev/null
+++ b/meta-intel-extras/recipes/qt5/b2qt-appcontroller/kms.conf
@@ -0,0 +1,3 @@
1{
2 "hwcursor": false
3}
diff --git a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/qt5/qtbase_git.bbappend
index 602782e..602782e 100644
--- a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
+++ b/meta-intel-extras/recipes/qt5/qtbase_git.bbappend