summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-04-20 14:17:33 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-04-20 14:19:13 +0300
commit61b4e74f5daaa43cde2a7594e8f70cbd2364263e (patch)
treeacc6a88e44bf684a8de484ca56f222c32eb35fe4 /meta-intel-extras
parent28a32f08bb3c24081efa28598125a663b3ea264b (diff)
parent6e3ac7bfe108acf3e84d073f9067302a39709f2f (diff)
downloadmeta-boot2qt-61b4e74f5daaa43cde2a7594e8f70cbd2364263e.tar.gz
Merge remote-tracking branch 'origin/morty' into pyro
* origin/morty: 6e3ac7b meta-qt5: update meta layer b250388 meta-qt5: update meta layer 763a607 qtdeviceutilities: update revision 0c1582c poky: update to latest revision in morty branch 4489683 nuc: use modprobe to load kernel module 45f1fec quickcompiler: Update QC to 5.9.5 version 65f8274 nuc: enable boot from internal sd cardreader Conflicts: meta-boot2qt/recipes-graphics/hunspell/hunspell-dicts_git.bb meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb scripts/manifest.xml Change-Id: I6fbfe531d34716aacb4a7220c4fc2688152651a2
Diffstat (limited to 'meta-intel-extras')
-rw-r--r--meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend38
-rw-r--r--meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh3
-rw-r--r--meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend30
-rw-r--r--meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg2
4 files changed, 73 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend b/meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend
new file mode 100644
index 0000000..ab69a09
--- /dev/null
+++ b/meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend
@@ -0,0 +1,38 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://init-device.sh"
33
34do_install_append () {
35 install -m 0755 ${WORKDIR}/init-device.sh ${D}/init-device
36}
37
38FILES_${PN} += "/init-device"
diff --git a/meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh b/meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh
new file mode 100644
index 0000000..09eadbf
--- /dev/null
+++ b/meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3modprobe rtsx_pci_sdmmc
diff --git a/meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend b/meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend
new file mode 100644
index 0000000..1ac5f03
--- /dev/null
+++ b/meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGE_INSTALL += "kernel-module-rtsx-pci-sdmmc"
diff --git a/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg b/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg
index 7902798..af765b5 100644
--- a/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg
+++ b/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg
@@ -1 +1,3 @@
1CONFIG_HID_MULTITOUCH=m 1CONFIG_HID_MULTITOUCH=m
2CONFIG_MMC_REALTEK_PCI=m
3CONFIG_MFD_RTSX_PCI=m