summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-26 11:28:13 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-28 08:58:16 +0000
commit57273bc2626ac89abc616e51e1607e6c8bf8125e (patch)
tree131c8d0ff131d4aaf313dfa77a2e6483fb44425b /meta-intel-extras
parent08713303e05da028ec4001710331fdc5edf00439 (diff)
downloadmeta-boot2qt-57273bc2626ac89abc616e51e1607e6c8bf8125e.tar.gz
intel: update to sumo
Update meta-intel layer to the latest revision on sumo branch and make the necessary adaptations. Use WIC for the image creation and remove previously used classes that are no longer needed. Mesa is now recent enough, removing all existing recipes. Change-Id: I747505ac25397a0b2f0a811bb9a7c5e5e1a53cfe Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-intel-extras')
-rw-r--r--meta-intel-extras/classes/image_dd_efi.bbclass49
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi_%.bbappend (renamed from meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend)0
-rw-r--r--meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch37
-rw-r--r--meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch29
-rw-r--r--meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch26
-rw-r--r--meta-intel-extras/recipes/mesa/mesa_17.0.2.bb18
6 files changed, 0 insertions, 159 deletions
diff --git a/meta-intel-extras/classes/image_dd_efi.bbclass b/meta-intel-extras/classes/image_dd_efi.bbclass
deleted file mode 100644
index 4454051..0000000
--- a/meta-intel-extras/classes/image_dd_efi.bbclass
+++ /dev/null
@@ -1,49 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Extends image_dd class to boot via GRUB-EFI and initramfs."
31LICENSE = "CLOSED"
32
33inherit image_dd
34
35EXTRA_IMAGECMD_ext3 += "-L rootfs"
36
37do_populate_boot() {
38 GRUB_IMAGE="grub-efi-bootia32.efi"
39 DEST_IMAGE="bootia32.efi"
40 if [ "${TARGET_ARCH}" = "x86_64" ]; then
41 GRUB_IMAGE="grub-efi-bootx64.efi"
42 DEST_IMAGE="bootx64.efi"
43 fi
44
45 mkdir -p ${WORKDIR}/EFI/BOOT/
46 # Path where EFI firmware searches for EFI executable
47 cp ${DEPLOY_DIR_IMAGE}/${GRUB_IMAGE} ${WORKDIR}/EFI/BOOT/${DEST_IMAGE}
48 mcopy -s -i ${WORKDIR}/boot.img ${WORKDIR}/EFI ::/EFI
49}
diff --git a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_%.bbappend
index f3a95f2..f3a95f2 100644
--- a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
+++ b/meta-intel-extras/recipes/grub/grub-efi_%.bbappend
diff --git a/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
deleted file mode 100644
index e49695b..0000000
--- a/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 2f68fcaaf4964e7feeb383f5c26851965cda037c Mon Sep 17 00:00:00 2001
2From: Jussi Kukkonen <jussi.kukkonen@intel.com>
3Date: Tue, 15 Nov 2016 15:20:49 +0200
4Subject: [PATCH] Simplify wayland-scanner lookup
5
6Don't use pkg-config to lookup the path of a binary that's in the path.
7
8Alternatively we'd have to prefix the path returned by pkg-config with
9PKG_CONFIG_SYSROOT_DIR.
10
11Upstream-Status: Pending
12Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
13---
14 configure.ac | 7 +------
15 1 file changed, 1 insertion(+), 6 deletions(-)
16
17diff --git a/configure.ac b/configure.ac
18index e56e35a..a92005a 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -2020,12 +2020,7 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
22 AC_MSG_ERROR([cannot build egl state tracker without EGL library])
23 fi
24
25-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
26- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
27- WAYLAND_SCANNER='')
28-if test "x$WAYLAND_SCANNER" = x; then
29- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
30-fi
31+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
32
33 # Do per-EGL platform setups and checks
34 egl_platforms=`IFS=', '; echo $with_egl_platforms`
35--
362.1.4
37
diff --git a/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
deleted file mode 100644
index d2d6755..0000000
--- a/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1Configure checks for compiler to be gcc and then it enables asm_offsets
2generation. see
3
4https://cgit.freedesktop.org/mesa/mesa/commit/?id=73c9b4b0e05fc66629ba250846948dc55c0e7a0d
5
6However, we missed the check when enabling this on cross compilation
7when architecture for both host and target is x86
8
9Fixes errors like
10./gen_matypes > matypes.h
11/bin/bash: ./gen_matypes: No such file or directory
12
13-Khem
14
15Upstream-Status: Submitted
16
17Index: mesa-12.0.1/configure.ac
18===================================================================
19--- mesa-12.0.1.orig/configure.ac
20+++ mesa-12.0.1/configure.ac
21@@ -732,7 +732,7 @@ test "x$enable_asm" = xno && AC_MSG_RESU
22 if test "x$enable_asm" = xyes -a "x$cross_compiling" = xyes; then
23 case "$host_cpu" in
24 i?86 | x86_64 | amd64)
25- if test "x$host_cpu" != "x$target_cpu"; then
26+ if test "x$host_cpu" != "x$target_cpu" -o "x$acv_mesa_CLANG" = xyes; then
27 enable_asm=no
28 AC_MSG_RESULT([no, cross compiling])
29 fi
diff --git a/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch b/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch
deleted file mode 100644
index 0280ee8..0000000
--- a/meta-intel-extras/recipes/mesa/files/replace_glibc_check_with_linux.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1endianness check is OS wide and not specific to libc
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Pending
5
6Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
7---
8 src/util/u_endian.h | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/util/u_endian.h b/src/util/u_endian.h
12index b9d563d..2d5eab9 100644
13--- a/src/util/u_endian.h
14+++ b/src/util/u_endian.h
15@@ -27,7 +27,7 @@
16 #ifndef U_ENDIAN_H
17 #define U_ENDIAN_H
18
19-#if defined(__GLIBC__) || defined(ANDROID)
20+#if defined(__linux__)
21 #include <endian.h>
22
23 #if __BYTE_ORDER == __LITTLE_ENDIAN
24--
252.1.4
26
diff --git a/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb b/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb
deleted file mode 100644
index b95f301..0000000
--- a/meta-intel-extras/recipes/mesa/mesa_17.0.2.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1require recipes-graphics/mesa/${BPN}.inc
2
3SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7"
8
9SRC_URI[md5sum] = "8f808e92b893d412fbd6510e1d16f5c5"
10SRC_URI[sha256sum] = "f8f191f909e01e65de38d5bdea5fb057f21649a3aed20948be02348e77a689d4"
11
12#because we cannot rely on the fact that all apps will use pkgconfig,
13#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
14do_install_append() {
15 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
16 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
17 fi
18}