summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-16 09:27:00 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-08 12:51:37 +0000
commit2f745904ddf909956d325594d99840891735556b (patch)
treeddbc3ce72247e2c09738d7c71ba2aed16f0f12a3 /meta-intel-extras
parent9a46c8174a1814a628b63b795b31cf4e181b72a3 (diff)
downloadmeta-boot2qt-2f745904ddf909956d325594d99840891735556b.tar.gz
NUC: use the common intel-corei7-64 BSP
meta-intel no longer has specific BSPs for each machine, but they share a common BSP based on the architecture. Change-Id: Ibbb7b8b2153103367168ea37d904ce23bc245108 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-intel-extras')
-rw-r--r--meta-intel-extras/classes/image_dd_efi.bbclass45
-rw-r--r--meta-intel-extras/conf/layer.conf32
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi/grub.cfg10
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend40
-rw-r--r--meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg9
-rw-r--r--meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend25
-rw-r--r--meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend22
7 files changed, 183 insertions, 0 deletions
diff --git a/meta-intel-extras/classes/image_dd_efi.bbclass b/meta-intel-extras/classes/image_dd_efi.bbclass
new file mode 100644
index 0000000..7bbff62
--- /dev/null
+++ b/meta-intel-extras/classes/image_dd_efi.bbclass
@@ -0,0 +1,45 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Extends image_dd class to boot via GRUB-EFI and initramfs."
23LICENSE = "CLOSED"
24
25inherit image_dd
26
27EXTRA_IMAGECMD_ext3 += "-L rootfs"
28IMAGE_DEPENDS_ext3 += "initramfs-basic:do_rootfs"
29
30IMAGE_CMD_ext3_prepend() {
31
32 # https://www.kernel.org/doc/Documentation/x86/early-microcode.txt
33 microcode="${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', '${DEPLOY_DIR_IMAGE}/microcode.cpio ', '', d)}"
34 cat ${microcode} ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz > ${IMAGE_ROOTFS}/boot/initramfs
35 chmod 0644 ${IMAGE_ROOTFS}/boot/initramfs
36}
37
38do_populate_boot() {
39
40 mkdir -p ${WORKDIR}/EFI/BOOT/
41 # Path where EFI firmware searches for EFI executable
42 cp ${DEPLOY_DIR_IMAGE}/bootx64.efi ${WORKDIR}/EFI/BOOT/
43 mcopy -s -i ${WORKDIR}/boot.img ${WORKDIR}/EFI ::/EFI
44}
45
diff --git a/meta-intel-extras/conf/layer.conf b/meta-intel-extras/conf/layer.conf
new file mode 100644
index 0000000..3b7be9d
--- /dev/null
+++ b/meta-intel-extras/conf/layer.conf
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28 "
29
30BBFILE_COLLECTIONS += "b2qt_intel"
31BBFILE_PATTERN_b2qt_intel := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_intel = "20"
diff --git a/meta-intel-extras/recipes/grub/grub-efi/grub.cfg b/meta-intel-extras/recipes/grub/grub-efi/grub.cfg
new file mode 100644
index 0000000..ca53537
--- /dev/null
+++ b/meta-intel-extras/recipes/grub/grub-efi/grub.cfg
@@ -0,0 +1,10 @@
1# Created by meta-b2qt
2serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
3default=boot
4timeout=10
5
6menuentry 'boot' {
7 linux /boot/bzImage root=LABEL=rootfs
8 initrd /boot/initramfs
9}
10
diff --git a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
new file mode 100644
index 0000000..d002240
--- /dev/null
+++ b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
@@ -0,0 +1,40 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI += "file://grub.cfg"
24
25do_deploy_prepend() {
26
27cat > ${WORKDIR}/cfg <<EOF
28search.file /boot/grub2/grub.cfg root
29set prefix=/boot/grub2
30EOF
31}
32
33do_install_append() {
34
35 install -d ${D}/boot/grub2/
36 install -m 644 ${WORKDIR}/grub.cfg ${D}/boot/grub2/
37}
38
39PACKAGES += "${PN}-config"
40FILES_${PN}-config = "/boot/grub2/"
diff --git a/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg b/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
new file mode 100644
index 0000000..65ac248
--- /dev/null
+++ b/meta-intel-extras/recipes/linux/linux-yocto/wlan-realtek.cfg
@@ -0,0 +1,9 @@
1CONFIG_RTLWIFI=m
2CONFIG_RTLWIFI_DEBUG=n
3CONFIG_RTL8723AE=m
4CONFIG_RTL8192SE=m
5CONFIG_RTL8192DE=m
6CONFIG_RTL8192CU=m
7CONFIG_RTL8192CE=m
8CONFIG_RTL8192C_COMMON=m
9CONFIG_RTL8188EE=m
diff --git a/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend b/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend
new file mode 100644
index 0000000..55ac1a2
--- /dev/null
+++ b/meta-intel-extras/recipes/linux/linux-yocto_3.%.bbappend
@@ -0,0 +1,25 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI += "\
24 file://wlan-realtek.cfg \
25 "
diff --git a/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
new file mode 100644
index 0000000..2346521
--- /dev/null
+++ b/meta-intel-extras/recipes/recipes-qt/qtbase_git.bbappend
@@ -0,0 +1,22 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22PACKAGECONFIG += "kms"