summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-09 10:56:57 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-10 09:43:26 +0000
commit1ff09a4d31a15986163bb402a191e38c71d293f0 (patch)
tree7997ee095271f046533e3154915f814e9ce68361 /meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
parented0f0bfceb44cd431fe65e94e6952c486332a42c (diff)
downloadmeta-boot2qt-1ff09a4d31a15986163bb402a191e38c71d293f0.tar.gz
intel: Update to latest mesa
Current mesa version (17.0.2) has poor performance on Intel NUC with Qt 3D Studio. Use the latest recipe available from poky/master. Task-number: QTBUG-71025 Change-Id: Id5ea895681bb83c341f80bcc8c4b540ab735bf5b Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch')
-rw-r--r--meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch b/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
new file mode 100644
index 0000000..5e735ca
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/files/0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
@@ -0,0 +1,44 @@
1From 8b42fb47138f91d9378439ab716bac7701e4e326 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 5 Jun 2018 11:11:10 -0300
4Subject: [PATCH 3/6] Properly get LLVM version when using LLVM Git releases
5Organization: O.S. Systems Software LTDA.
6
7$ llvm-config-host --version
85.0.0git-9a5c333388c
9
10We need to ignore everything after 5.0.0 which is what the cut cmd is
11doing
12
13Upstream-Status: Pending
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
16---
17 configure.ac | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/configure.ac b/configure.ac
21index 916d0bd207..dd172f1ebe 100644
22--- a/configure.ac
23+++ b/configure.ac
24@@ -1090,7 +1090,7 @@ strip_unwanted_llvm_flags() {
25
26 llvm_set_environment_variables() {
27 if test "x$LLVM_CONFIG" != xno; then
28- LLVM_VERSION=`$LLVM_CONFIG --version | egrep -o '^[[0-9.]]+'`
29+ LLVM_VERSION=`$LLVM_CONFIG --version | cut -c1-5`
30 LLVM_CPPFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cppflags"`
31 LLVM_INCLUDEDIR=`$LLVM_CONFIG --includedir`
32 LLVM_LIBDIR=`$LLVM_CONFIG --libdir`
33@@ -2808,7 +2808,7 @@ detect_old_buggy_llvm() {
34 dnl ourselves.
35 dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
36 dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
37- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
38+ LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version | cut -c1-5`
39 AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
40
41 if test "x$llvm_have_one_so" = xyes; then
42--
432.18.0
44