summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-22 16:08:46 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-08 12:50:50 +0000
commit8fce9c93cc04c9ab7587c66f4bf8fa27226c4232 (patch)
treedbdd1ba0f85ce22e9f69c8ef0b4c7063ecae50bd /meta-fsl-extras
parentf01da62c4c3be2cc79f1e8ea2993e2b7549d87e6 (diff)
downloadmeta-boot2qt-8fce9c93cc04c9ab7587c66f4bf8fa27226c4232.tar.gz
imx53: remove support for imx53
OE has moved to gcc 5.2 which cannot be used to build the old kernel that imx53 still uses, therefore all support for it was dropped from meta-fsl-arm. Change-Id: Ic57310f8ae6d06f62274a7c1874df0d01c95b5e9 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch26
-rw-r--r--meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend25
2 files changed, 0 insertions, 51 deletions
diff --git a/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch b/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch
deleted file mode 100644
index 0a3cd76..0000000
--- a/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51/0001-fix-glTexImage2D-API.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From ec1c2b5f637145e2a473820401ab96ecf0f16def Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Mon, 8 Sep 2014 10:23:46 +0300
4Subject: [PATCH] fix glTexImage2D API
5
6internalformat should be GLint and not GLenum.
7---
8 usr/include/GLES2/gl2.h | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/usr/include/GLES2/gl2.h b/usr/include/GLES2/gl2.h
12index c0e3a44..5aa6c26 100755
13--- a/usr/include/GLES2/gl2.h
14+++ b/usr/include/GLES2/gl2.h
15@@ -579,7 +579,7 @@ GL_APICALL void GL_APIENTRY glStencilMask (GLuint mask);
16 GL_APICALL void GL_APIENTRY glStencilMaskSeparate (GLenum face, GLuint mask);
17 GL_APICALL void GL_APIENTRY glStencilOp (GLenum fail, GLenum zfail, GLenum zpass);
18 GL_APICALL void GL_APIENTRY glStencilOpSeparate (GLenum face, GLenum fail, GLenum zfail, GLenum zpass);
19-GL_APICALL void GL_APIENTRY glTexImage2D (GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const void* pixels);
20+GL_APICALL void GL_APIENTRY glTexImage2D (GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid* pixels);
21 GL_APICALL void GL_APIENTRY glTexParameterf (GLenum target, GLenum pname, GLfloat param);
22 GL_APICALL void GL_APIENTRY glTexParameterfv (GLenum target, GLenum pname, const GLfloat* params);
23 GL_APICALL void GL_APIENTRY glTexParameteri (GLenum target, GLenum pname, GLint param);
24--
251.8.3.2
26
diff --git a/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend b/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend
deleted file mode 100644
index 102fbfe..0000000
--- a/meta-fsl-extras/recipes/amd-gpu-bin-mx51/amd-gpu-bin-mx51_11.09.01.bbappend
+++ /dev/null
@@ -1,25 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23SRC_URI += " \
24 file://0001-fix-glTexImage2D-API.patch \
25 "