summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-11 11:34:45 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-12 10:14:50 +0000
commit1908d95fae1f57e451068b54927cbfeb7079c253 (patch)
tree47bd9b14ad845dcb8a90187267a2881046b37876 /meta-fsl-extras
parente8a3c3509903716ebacc9e73927f586b94994574 (diff)
downloadmeta-boot2qt-1908d95fae1f57e451068b54927cbfeb7079c253.tar.gz
u-boot-boundary: Add support for KOE tx31d200vm0baa display
Change-Id: I765336429009433cd361dd1bacae9c743ed58fd5 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch90
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend25
2 files changed, 115 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
new file mode 100644
index 0000000..0343f06
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
@@ -0,0 +1,90 @@
1From 554d219b3485402c6992abc0aa32c74e8f251876 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Thu, 11 Feb 2016 10:17:51 +0200
4Subject: [PATCH] Add support for KOE tx31d200vm0baa display
5
6Used for the cluster demo
7---
8 arch/arm/include/asm/imx-common/fbpanel.h | 27 +++++++++++++++++++++++++++
9 board/boundary/nitrogen6_max/nitrogen6_max.c | 1 +
10 board/boundary/nitrogen6sx/nitrogen6sx.c | 1 +
11 board/boundary/nitrogen6x/nitrogen6x.c | 1 +
12 4 files changed, 30 insertions(+)
13
14diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h
15index b6f7af4..b8acdae 100644
16--- a/arch/arm/include/asm/imx-common/fbpanel.h
17+++ b/arch/arm/include/asm/imx-common/fbpanel.h
18@@ -39,6 +39,33 @@ void fbp_enable_fb(struct display_info_t const *di, int enable);
19 int fbp_detect_i2c(struct display_info_t const *di);
20 void fbp_setup_display(const struct display_info_t *displays, int cnt);
21
22+/* tx31d200vm0baa == koe */
23+#define IMX_VD_KOE(_mode, _detect, _bus) \
24+{\
25+ .bus = _bus,\
26+ .addr = 0,\
27+ .pixfmt = IPU_PIX_FMT_RGB666,\
28+ .detect = NULL,\
29+ .enable = fbp_enable_fb,\
30+ .fbtype = FB_##_mode,\
31+ .fbflags = 0,\
32+ .mode = {\
33+ .name = "koe",\
34+ .refresh = 60,\
35+ .xres = 1280,\
36+ .yres = 480,\
37+ .pixclock = 1000000000000ULL/((1280+80+48+32)*(480+15+2+6)*60),\
38+ .left_margin = 80,\
39+ .right_margin = 48,\
40+ .upper_margin = 15,\
41+ .lower_margin = 2,\
42+ .hsync_len = 32,\
43+ .vsync_len = 6,\
44+ .sync = FB_SYNC_EXT,\
45+ .vmode = FB_VMODE_NONINTERLACED\
46+ }\
47+}
48+
49 /* hdmi settings */
50 #define IMX_VD50_1280_720M_60(_mode, _detect, _bus) \
51 {\
52diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c
53index 337e9b5..ba29aee 100644
54--- a/board/boundary/nitrogen6_max/nitrogen6_max.c
55+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c
56@@ -568,6 +568,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
57 }
58
59 static const struct display_info_t displays[] = {
60+ IMX_VD_KOE(LVDS, 0, 2),
61 /* hdmi */
62 IMX_VD50_1280_720M_60(HDMI, 1, 1),
63 IMX_VD50_1920_1080M_60(HDMI, 0, 1),
64diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c
65index cdabcd8..de6582e 100644
66--- a/board/boundary/nitrogen6sx/nitrogen6sx.c
67+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c
68@@ -685,6 +685,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
69
70
71 static const struct display_info_t displays[] = {
72+ IMX_VD_KOE(LVDS, 0, 2),
73 /* hdmi/lcd */
74 _IMX_VD_1280_720M_60(LCD, 1, 2, 50, 0),
75 _IMX_VD_1920_1080M_60(LCD, 0, 2, 50, 0),
76diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c
77index 21d6cd7..b24f2f6 100644
78--- a/board/boundary/nitrogen6x/nitrogen6x.c
79+++ b/board/boundary/nitrogen6x/nitrogen6x.c
80@@ -525,6 +525,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
81 }
82
83 static const struct display_info_t displays[] = {
84+ IMX_VD_KOE(LVDS, 0, 2),
85 /* hdmi */
86 IMX_VD50_1280_720M_60(HDMI, 1, 1),
87 IMX_VD50_1920_1080M_60(HDMI, 0, 1),
88--
891.9.1
90
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
new file mode 100644
index 0000000..7487f7d
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
@@ -0,0 +1,25 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23SRC_URI += " \
24 file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \
25 "