diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2014-11-10 10:30:35 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2014-11-12 15:10:53 +0200 |
commit | 6f7d4e00b70172846d856c46cae493c11bafa4c8 (patch) | |
tree | 9e579ff2995d99008b4fe56c8e97d3653f7acfec /meta-fsl-extras | |
parent | c8f80d317f55f5644cace08798c6932e776f2a60 (diff) | |
download | meta-boot2qt-6f7d4e00b70172846d856c46cae493c11bafa4c8.tar.gz |
nitrogen6x: include Broadcom WiFi firmware
Adding Broadcom bcm4330 firmware allows use of the same image on
Nitrogen6_Lite.
Change-Id: I2eebe658ea9f81f42d670a47acd7dcd2c6d0909c
Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com>
Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r-- | meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend | 3 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/broadcom-nvram-config/nitrogen6x/brcmfmac4330-sdio.txt | 80 |
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend b/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend new file mode 100644 index 0000000..e7331d5 --- /dev/null +++ b/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}:" | ||
2 | |||
3 | COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|wandboard-dual|wandboard-quad)" | ||
diff --git a/meta-fsl-extras/recipes/broadcom-nvram-config/nitrogen6x/brcmfmac4330-sdio.txt b/meta-fsl-extras/recipes/broadcom-nvram-config/nitrogen6x/brcmfmac4330-sdio.txt new file mode 100644 index 0000000..6183cca --- /dev/null +++ b/meta-fsl-extras/recipes/broadcom-nvram-config/nitrogen6x/brcmfmac4330-sdio.txt | |||
@@ -0,0 +1,80 @@ | |||
1 | # | ||
2 | # Board configuration for Boundary Devices Nitrogen6-Lite | ||
3 | # | ||
4 | manfid=0x2d0 | ||
5 | prodid=0x0547 | ||
6 | vendid=0x14e4 | ||
7 | devid=0x4360 | ||
8 | boardtype=0x05e1 | ||
9 | boardrev=0x1202 | ||
10 | boardflags=0x0080200 | ||
11 | nocrc=1 | ||
12 | xtalfreq=37400 | ||
13 | boardnum=22 | ||
14 | ag0=254 | ||
15 | aa2g=1 | ||
16 | ccode=ALL | ||
17 | pa0itssit=0x20 | ||
18 | pa0b0=5367 | ||
19 | pa0b1=-633 | ||
20 | pa0b2=-158 | ||
21 | rssismf2g=0xa | ||
22 | rssismc2g=0x3 | ||
23 | rssisav2g=0x7 | ||
24 | #rssi params for 5GHz | ||
25 | rssismf5g=0x4 | ||
26 | rssismc5g=0x3 | ||
27 | rssisav5g=0x7 | ||
28 | #PA parameters for lower a-band | ||
29 | pa1lob0=4378 | ||
30 | pa1lob1=-596 | ||
31 | pa1lob2=-180 | ||
32 | #PA parameters for midband | ||
33 | pa1b0=4672 | ||
34 | pa1b1=-603 | ||
35 | pa1b2=-172 | ||
36 | #PA parameters for high band | ||
37 | pa1hib0=4752 | ||
38 | pa1hib1=-609 | ||
39 | pa1hib2=-173 | ||
40 | rxpo5g=0 | ||
41 | maxp2ga0=76 | ||
42 | maxp5ga0=0x42 | ||
43 | maxp5gla0=0x42 | ||
44 | maxp5gha0=0x42 | ||
45 | # 2.4G Tx Power offsets | ||
46 | cck2gpo=0x4444 | ||
47 | ofdm2gpo=0x66666666 | ||
48 | mcs2gpo0=0x8888 | ||
49 | mcs2gpo1=0x8888 | ||
50 | # 5G Tx Power offsets | ||
51 | ofdm5gpo=0x44444444 | ||
52 | ofdm5glpo=0x44444444 | ||
53 | ofdm5ghpo=0x44444444 | ||
54 | mcs5gpo0=0x6666 | ||
55 | mcs5gpo1=0x6666 | ||
56 | mcs5glpo0=0x6666 | ||
57 | mcs5glpo1=0x6666 | ||
58 | mcs5ghpo0=0x6666 | ||
59 | mcs5ghpo1=0x46666 | ||
60 | sromrev=3 | ||
61 | # il0macaddr=00:90:4c:c5:12:38 | ||
62 | wl0id=0x431b | ||
63 | cckPwrOffset=4 | ||
64 | swctrlmap_2g=0x44844484,0x42824282,0x40804484,0x18282,0x1ff | ||
65 | triso5g=0 | ||
66 | swctrlmap_5g=0x00100010,0x20202020,0x20202020,0x14202,0x0f0 | ||
67 | rfreg033=0x19 | ||
68 | rfreg033_cck=0x1f | ||
69 | dacrate2g=160 | ||
70 | dacrate5g=160 | ||
71 | txalpfbyp2g=1 | ||
72 | bphyscale=17 | ||
73 | cckPwrIdxCorr=-15 | ||
74 | pacalidx2g=50 | ||
75 | #pacalidx5g=20 | ||
76 | noise_cal_ref_2g=53 | ||
77 | noise_cal_po_2g=0 | ||
78 | noise_cal_ref_5g=52 | ||
79 | noise_cal_po_5g=5,0,0 | ||
80 | |||