summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-01 09:43:22 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-09-12 12:34:50 +0000
commitae2d6d14123d0eae08b04e9e31bdd129aff119e6 (patch)
tree644c68739a558794241095f79a92df1f0b9c4e00 /meta-fsl-extras
parentadc61820f15efe4e57e9089372e55ad20aaf1efb (diff)
downloadmeta-boot2qt-ae2d6d14123d0eae08b04e9e31bdd129aff119e6.tar.gz
toradex: stop using meta-toradex
All needed toradex recipes are now in meta-fsl-arm-extra Change-Id: I3eedacd83845087d2369cf4d4b6df2a030d6d283 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend37
-rw-r--r--meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend35
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb76
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr6
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr6
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr6
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr6
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr2
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr3
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch47
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch12
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch25
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch14
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend43
14 files changed, 318 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend
new file mode 100644
index 0000000..b696b19
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend
@@ -0,0 +1,37 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# kernel image files are not needed in the image
31RDEPENDS_kernel-base = ""
32
33do_configure_prepend () {
34 # FunctionFS for adb
35 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
36 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
37}
diff --git a/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend
new file mode 100644
index 0000000..77ce484
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend
@@ -0,0 +1,35 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_configure_prepend () {
31 # FunctionFS for adb
32 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
33 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
34 echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig
35}
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb
new file mode 100644
index 0000000..bb209ad
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -0,0 +1,76 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "The-Qt-Company-DCLA-2.1"
31LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
32DEPENDS = "u-boot-mkimage-native"
33
34PV = "v2.3"
35
36SRC_URI = " \
37 file://flash_mmc.scr \
38 file://flash_blk.scr \
39 "
40
41S = "${WORKDIR}"
42
43inherit deploy
44
45do_mkimage () {
46 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
47 -n "update script" -d ${WORKDIR}/flash_mmc.scr \
48 flash_mmc.img
49
50 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
51 -n "update script" -d ${WORKDIR}/flash_blk.scr \
52 flash_blk.img
53}
54
55addtask mkimage after do_compile before do_install
56
57do_deploy () {
58 install -d ${DEPLOYDIR}
59 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img
60 install ${S}/flash_blk.img ${DEPLOYDIR}/flash_blk-${MACHINE}-${PV}-${PR}.img
61
62 cd ${DEPLOYDIR}
63 rm -f flash_mmc-${MACHINE}.img
64 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img
65 rm -f flash_blk-${MACHINE}.img
66 ln -sf flash_blk-${MACHINE}-${PV}-${PR}.img flash_blk-${MACHINE}.img
67}
68
69addtask deploy after do_install before do_build
70
71do_compile[noexec] = "1"
72do_install[noexec] = "1"
73do_populate_sysroot[noexec] = "1"
74
75PACKAGE_ARCH = "${MACHINE_ARCH}"
76COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6|colibri-imx7)"
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr
new file mode 100644
index 0000000..ee87e85
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_blk.scr
@@ -0,0 +1,6 @@
1test -n ${interface} || setenv interface mmc
2test -n ${drive} || setenv drive 1
3
4setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200'
5setenv update_uboot 'fatload ${interface} ${drive}:1 ${loadaddr} u-boot.imx && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}'
6echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr
new file mode 100644
index 0000000..207c7db
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx6/flash_mmc.scr
@@ -0,0 +1,6 @@
1#flash_mmc has been renamed to flash_blk, ensure compatibilty when updating from older versions
2test -n ${interface} || setenv interface mmc
3test -n ${drive} || setenv drive 1
4
5fatload ${interface} ${drive}:1 ${loadaddr} flash_blk.img
6source ${loadaddr}
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr
new file mode 100644
index 0000000..3e05a85
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr
@@ -0,0 +1,6 @@
1test -n ${interface} || setenv interface mmc
2test -n ${drive} || setenv drive 0
3
4setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200'
5setenv update_uboot 'fatload ${interface} ${drive}:1 ${loadaddr} u-boot.imx && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}'
6echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr
new file mode 100644
index 0000000..0c16652
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr
@@ -0,0 +1,6 @@
1#flash_mmc has been renamed to flash_blk, ensure compatibility when updating from older versions
2test -n ${interface} || setenv interface mmc
3test -n ${drive} || setenv drive 0
4
5fatload ${interface} ${drive}:1 ${loadaddr} flash_blk.img
6source ${loadaddr}
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
new file mode 100644
index 0000000..be8ec8d
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
@@ -0,0 +1,2 @@
1setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot'
2echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr
new file mode 100644
index 0000000..e0770a0
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_mmc.scr
@@ -0,0 +1,3 @@
1setenv interface mmc
2fatload ${interface} 0:1 ${loadaddr} flash_blk.img
3source ${loadaddr}
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch
new file mode 100644
index 0000000..5a456c5
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch
@@ -0,0 +1,47 @@
1From 4569a8b4997340aae34365f2f896b842f8cc114b Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Mon, 27 Oct 2014 14:53:25 +0200
4Subject: [PATCH] Update default args for apalis imx6
5
6Boot from sd card by default
7---
8 include/configs/apalis_imx6.h | 13 +++++++------
9 1 file changed, 7 insertions(+), 6 deletions(-)
10
11diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h
12index 3ea4a5c..53d9a0c 100644
13--- a/include/configs/apalis_imx6.h
14+++ b/include/configs/apalis_imx6.h
15@@ -252,14 +252,14 @@
16 "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0"
17
18 #define SD_BOOTCMD \
19- "sdargs=ip=off root=/dev/mmcblk1p2 rw,noatime rootfstype=ext3 " \
20- "rootwait\0" \
21+ "drive=2\0" \
22 "sdboot=run setup; " \
23- "setenv bootargs ${defargs} ${sdargs} ${setupargs} " \
24+ "setenv bootargs ${defargs} ip=off root=/dev/mmcblk${drive}p2 " \
25+ "rw,noatime rootfstype=ext3 rootwait ${setupargs} " \
26 "${vidargs}; echo Booting from SD card in 8-bit slot...; " \
27- "run sddtbload; load mmc 1:1 ${kernel_addr_r} " \
28+ "run sddtbload; load mmc ${drive}:1 ${kernel_addr_r} " \
29 "${boot_file} && bootm ${kernel_addr_r} ${dtbparam}\0" \
30- "sddtbload=setenv dtbparam; load mmc 1:1 ${fdt_addr_r} " \
31+ "sddtbload=setenv dtbparam; load mmc ${drive}:1 ${fdt_addr_r} " \
32 "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0"
33
34 #define USB_BOOTCMD \
35@@ -279,7 +279,8 @@
36 #define FDT_FILE "imx6q-apalis_v1_0-eval.dtb"
37 #endif
38 #define CONFIG_EXTRA_ENV_SETTINGS \
39- "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \
40+ "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \
41+ "run emmcboot ; echo ; echo emmcboot failed ; " \
42 "run nfsboot ; echo ; echo nfsboot failed ; " \
43 "usb start ;" \
44 "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \
45--
461.9.1
47
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch
new file mode 100644
index 0000000..501ad33
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx7-fix-update-u-boot.patch
@@ -0,0 +1,12 @@
1diff -Naur git.orig/include/configs/colibri_imx7.h git/include/configs/colibri_imx7.h
2--- git.orig/include/configs/colibri_imx7.h 2016-07-15 12:31:35.915934824 +0300
3+++ git/include/configs/colibri_imx7.h 2016-07-15 12:32:40.867937388 +0300
4@@ -248,7 +248,7 @@
5 "${board}/flash_eth.img && source ${loadaddr}\0" \
6 "setsdupdate=mmc rescan && setenv interface mmc && " \
7 "fatload ${interface} 0:1 ${loadaddr} " \
8- "${board}/flash_blk.img && source ${loadaddr}\0" \
9+ "/flash_blk.img && source ${loadaddr}\0" \
10 "setup=setenv setupargs " \
11 "console=tty1 console=${console}" \
12 ",${baudrate}n8 ${memargs} consoleblank=0 ${mtdparts}\0" \
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch
new file mode 100644
index 0000000..b54a4ae
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch
@@ -0,0 +1,25 @@
1From f480a948551b0e5592d93cb7a5dc1653de900909 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Wed, 24 Feb 2016 16:01:33 +0200
4Subject: [PATCH] colibri vf: remove console from tty1
5
6---
7 include/configs/colibri_vf.h | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
11index b870812..0726fc5 100644
12--- a/include/configs/colibri_vf.h
13+++ b/include/configs/colibri_vf.h
14@@ -202,7 +202,7 @@
15 "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \
16 "source ${loadaddr}\0" \
17 "setup=setenv setupargs " \
18- "console=tty1 console=${console}" \
19+ "console=${console}" \
20 ",${baudrate}n8 ${memargs} consoleblank=0\0" \
21 "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \
22 "setusbupdate=usb start && setenv interface usb && " \
23--
241.9.1
25
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch
new file mode 100644
index 0000000..25476dd
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0002-colibri-vf-fix-mmc-boot.patch
@@ -0,0 +1,14 @@
1diff -Naur git.orig/include/configs/colibri_vf.h git/include/configs/colibri_vf.h
2--- git.orig/include/configs/colibri_vf.h 2016-07-15 12:05:41.263873456 +0300
3+++ git/include/configs/colibri_vf.h 2016-07-15 12:06:19.759874976 +0300
4@@ -161,8 +161,8 @@
5 "sdargs=root=/dev/mmcblk0p2 rw rootwait\0" \
6 "sdboot=run setup; setenv bootargs ${defargs} ${sdargs} " \
7 "${setupargs} ${vidargs}; echo Booting from MMC/SD card...; " \
8- "load mmc 0:2 ${kernel_addr_r} /boot/${kernel_file} && " \
9- "load mmc 0:2 ${fdt_addr_r} /boot/${soc}-colibri-${fdt_board}.dtb && " \
10+ "load mmc 0:1 ${kernel_addr_r} /${kernel_file} && " \
11+ "load mmc 0:1 ${fdt_addr_r} /${soc}-colibri-${fdt_board}.dtb && " \
12 "run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \
13
14 #define NFS_BOOTCMD \
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
new file mode 100644
index 0000000..cb94605
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
@@ -0,0 +1,43 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \
32 file://0001-colibri-vf-remove-console-from-tty1.patch \
33 file://0002-colibri-vf-fix-mmc-boot.patch \
34 file://0001-Update-default-args-for-apalis-imx6.patch \
35 file://0001-colibri-imx7-fix-update-u-boot.patch \
36 "
37
38do_compile_append () {
39 if [ "${MACHINE}" = "colibri-vf" ]; then
40 oe_runmake u-boot-nand.imx
41 fi
42
43}