summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorLouai Al-Khanji <louai.al-khanji@qt.io>2016-05-31 14:27:06 -0700
committerLouai Al-Khanji <louai.al-khanji@qt.io>2016-06-01 13:14:48 +0000
commit9280465c4d86bec9b48d8b3d012e39a12049423a (patch)
tree7a052ee0fa4a6defb421ecd609058e4c0b6888fb /meta-fsl-extras
parent8ffb594225f440f7493859c995734fe0a7581100 (diff)
downloadmeta-boot2qt-9280465c4d86bec9b48d8b3d012e39a12049423a.tar.gz
Add bbappend for linux-fslc-imx kernels
Change-Id: I893e03dd3fb15bfac2e16e3f11c5b8370d5f87b5 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-fslc-imx_3.14-1.%.bbappend46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-fslc-imx_3.14-1.%.bbappend b/meta-fsl-extras/recipes/linux/linux-fslc-imx_3.14-1.%.bbappend
new file mode 100644
index 0000000..c21fece
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-fslc-imx_3.14-1.%.bbappend
@@ -0,0 +1,46 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# kernel image files are not needed in the image
31RDEPENDS_kernel-base = ""
32
33do_configure_prepend() {
34 # FunctionFS for adb
35 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
36
37 # Enable USB serial support
38 echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
39 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
40 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
41 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
42 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
43
44 echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
45 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
46}