summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2016-11-21 12:28:18 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-04-21 06:46:19 +0000
commit8afceb4e6a6c40f471f903cdf7f12e136e9ff971 (patch)
treeab0a9f273179b351060684691ca3e1e0c44f622b /meta-fsl-extras
parent70be5526bd98a97c60301c83c1a88e7bb6b19360 (diff)
downloadmeta-boot2qt-8afceb4e6a6c40f471f903cdf7f12e136e9ff971.tar.gz
Add support for i.MX7S WaRP
Change-Id: Ib2c82ccf8d7648bb303e0fc949e3c1aef5b09195 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
new file mode 100644
index 0000000..82604d4
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
@@ -0,0 +1,34 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_configure_prepend() {
31 echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
32 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
33 echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
34}