summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-26 10:47:45 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-28 08:58:03 +0000
commit5e33d73dcdaa1b622460bb082cb011dc9e589d09 (patch)
tree7b7948e877425e95d59175ef7d93d158689816c0 /meta-fsl-extras
parent9dbaed77586edafc16ee0b8fb1091005c62f0832 (diff)
downloadmeta-boot2qt-5e33d73dcdaa1b622460bb082cb011dc9e589d09.tar.gz
warp7: adapt to sumo
Upstream has switched to mainline kernel and the current kernel recipe has been removed. The mainline kernel however does not support the TRULY display. Change-Id: Ic9046efb97fe4f7080c221eb742339423fd7579a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch25
-rw-r--r--meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend52
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch11
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Use-hdmi-as-primary-display-only-if-connected.patch37
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch22
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend4
6 files changed, 5 insertions, 146 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch b/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch
deleted file mode 100644
index dbb7995..0000000
--- a/meta-fsl-extras/recipes/linux/linux-warp7/0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 9ffa222dbaa3b11c3b1399192e0abd478fc3b564 Mon Sep 17 00:00:00 2001
2From: Sami Nurmenniemi <sami.nurmenniemi@qt.io>
3Date: Mon, 18 Sep 2017 12:45:54 +0300
4Subject: [PATCH 1/1] Fix /dev/hwrng by enabling warp7 crypto-device
5
6---
7 arch/arm/boot/dts/imx7d-warp.dts | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/arch/arm/boot/dts/imx7d-warp.dts b/arch/arm/boot/dts/imx7d-warp.dts
11index ee72690..19aee0e 100755
12--- a/arch/arm/boot/dts/imx7d-warp.dts
13+++ b/arch/arm/boot/dts/imx7d-warp.dts
14@@ -181,7 +181,7 @@
15 };
16
17 &crypto {
18- status = "disabled";
19+ status = "okay";
20 };
21
22 &clks {
23--
242.7.4
25
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
deleted file mode 100644
index 3b9fc50..0000000
--- a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
+++ /dev/null
@@ -1,52 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SRCBRANCH = "linux_4.1.29"
31SRCREV = "881845d84e3c2e58a00b9c36616203d748b7df0e"
32LOCALVERSION = "-warp7"
33
34FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
35SRC_URI += " \
36 file://0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch \
37 "
38
39do_configure_prepend() {
40 echo "CONFIG_NAMESPACES=y" >> ${B}/.config
41 echo "CONFIG_FHANDLE=y" >> ${B}/.config
42 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
43
44 echo "CONFIG_MXC_CAMERA_OV2680_MIPI=m" >> ${B}/.config
45 echo "CONFIG_FB_MXC_TRULY_PANEL_TDO_ST7796H=y" >> ${B}/.config
46 echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_CORE=y" >> ${B}/.config
47 echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_RMI_DEV=y >> ${B}/.config
48 echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_FW_UPDATE=y >> ${B}/.config
49
50 echo "CONFIG_FTRACE=y" >> ${B}/.config
51 echo "CONFIG_UPROBE_EVENT=y" >> ${B}/.config
52}
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch
index 928fb8c..fbf83da 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Updated-kernel-arguments-for-sabre-sd.patch
@@ -1,4 +1,4 @@
1From 15ba0d8f9e2ad8f3024734810088e4caddaaec5a Mon Sep 17 00:00:00 2001 1From 2d762386376baadfe6a6447c2c19fa2d6329b985 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@digia.com> 2From: Samuli Piippo <samuli.piippo@digia.com>
3Date: Fri, 9 May 2014 10:23:50 +0300 3Date: Fri, 9 May 2014 10:23:50 +0300
4Subject: [PATCH] Updated kernel arguments for sabre sd 4Subject: [PATCH] Updated kernel arguments for sabre sd
@@ -9,18 +9,15 @@ Subject: [PATCH] Updated kernel arguments for sabre sd
9 1 file changed, 2 insertions(+) 9 1 file changed, 2 insertions(+)
10 10
11diff --git a/include/configs/mx6sabre_common.h b/include/configs/mx6sabre_common.h 11diff --git a/include/configs/mx6sabre_common.h b/include/configs/mx6sabre_common.h
12index a8746a4..251b28b 100644 12index 03d4f34904..50e84d144f 100644
13--- a/include/configs/mx6sabre_common.h 13--- a/include/configs/mx6sabre_common.h
14+++ b/include/configs/mx6sabre_common.h 14+++ b/include/configs/mx6sabre_common.h
15@@ -171,6 +171,8 @@ 15@@ -111,6 +111,8 @@
16 "done\0" \ 16 "done\0" \
17 "mmcargs=setenv bootargs console=${console},${baudrate} " \ 17 "mmcargs=setenv bootargs console=${console},${baudrate} " \
18 "root=${mmcroot} " \ 18 "root=PARTUUID=${uuid} rootwait rw " \
19+ "consoleblank=0 " \ 19+ "consoleblank=0 " \
20+ "vt.global_cursor_default=0 " \ 20+ "vt.global_cursor_default=0 " \
21 VIDEO_ARGS "\0" \ 21 VIDEO_ARGS "\0" \
22 "loadbootscript=" \ 22 "loadbootscript=" \
23 "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \ 23 "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
24--
251.9.1
26
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Use-hdmi-as-primary-display-only-if-connected.patch b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Use-hdmi-as-primary-display-only-if-connected.patch
deleted file mode 100644
index ddd90c6..0000000
--- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-Use-hdmi-as-primary-display-only-if-connected.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 734ccf82db363efddb960b1c4f7db4081f2fdd7c Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@theqtcompany.com>
3Date: Thu, 18 Feb 2016 12:49:01 +0200
4Subject: [PATCH] Use hdmi as primary display only if connected
5
6Test if HDMI display is connected before setting it as primary display.
7Otherwise set lvds as primary display. Test can be overridden by
8setting video_interfaces env.
9---
10 include/configs/mx6sabre_common.h | 10 +++++++++-
11 1 file changed, 9 insertions(+), 1 deletion(-)
12
13diff --git a/include/configs/mx6sabre_common.h b/include/configs/mx6sabre_common.h
14index a8746a4..485f232 100644
15--- a/include/configs/mx6sabre_common.h
16+++ b/include/configs/mx6sabre_common.h
17@@ -163,8 +163,16 @@
18 "video_args_lcd=setenv video_args $video_args " \
19 "video=mxcfb${fb}:dev=lcd,CLAA-WVGA,if=RGB666\0" \
20 "fb=0\0" \
21- "video_interfaces=hdmi lvds lcd\0" \
22+ "video_interfaces=\0" \
23 "video_args_script=" \
24+ "if test -z \"${video_interfaces}\"; then " \
25+ "i2c dev 1; " \
26+ "if i2c probe 0x50; then " \
27+ "setenv video_interfaces hdmi lvds lcd; " \
28+ "else " \
29+ "setenv video_interfaces lvds hdmi lcd; " \
30+ "fi; " \
31+ "fi; " \
32 "for v in ${video_interfaces}; do " \
33 "run video_args_${v}; " \
34 "setexpr fb $fb + 1; " \
35--
361.9.1
37
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch b/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch
deleted file mode 100644
index e8a0573..0000000
--- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc/0001-use-imx7d-warp.dtb.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1From ef2f2eeef6974bda0fd878c5f76b8b05ac16aa3d Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Wed, 13 Sep 2017 09:40:44 +0300
4Subject: [PATCH] use imx7d-warp.dtb
5
6---
7 include/configs/warp7.h | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/include/configs/warp7.h b/include/configs/warp7.h
11index b3e1f2e..edbd43f 100644
12--- a/include/configs/warp7.h
13+++ b/include/configs/warp7.h
14@@ -35,7 +35,7 @@
15 "ethact=usb_ether\0" \
16 "fdt_high=0xffffffff\0" \
17 "initrd_high=0xffffffff\0" \
18- "fdt_file=imx7s-warp.dtb\0" \
19+ "fdt_file=imx7d-warp.dtb\0" \
20 "fdt_addr=0x83000000\0" \
21 "boot_fdt=try\0" \
22 "ip_dyn=yes\0" \
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend
index b1df421..f17045d 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-fslc_%.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -30,6 +30,4 @@
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" 30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31SRC_URI += " \ 31SRC_URI += " \
32 file://0001-Updated-kernel-arguments-for-sabre-sd.patch \ 32 file://0001-Updated-kernel-arguments-for-sabre-sd.patch \
33 file://0001-Use-hdmi-as-primary-display-only-if-connected.patch \
34 file://0001-use-imx7d-warp.dtb.patch \
35 " 33 "