summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras/recipes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-29 15:38:36 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-12-30 07:10:46 +0000
commit2388fea63d0e4170c3e4f71f864f7705a78049e8 (patch)
tree4c205fe5f80c470aefccb9a977ef1991790aac7a /meta-fsl-extras/recipes
parente267546e874fb7dbe90422fc6193b0f28d71ec85 (diff)
downloadmeta-boot2qt-2388fea63d0e4170c3e4f71f864f7705a78049e8.tar.gz
imx6: update to latest revision of meta-fsl-arm/-extra
This updates kernel version for boundary devices, but fixes video playback problems. Change-Id: If76b9c6ee4346d2d818ae933385d07fcc88ff5c3 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras/recipes')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend50
-rw-r--r--meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend24
2 files changed, 24 insertions, 50 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
deleted file mode 100644
index c25739b..0000000
--- a/meta-fsl-extras/recipes/linux/linux-boundary_3.10.%.bbappend
+++ /dev/null
@@ -1,50 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/../../../recipes/linux/linux:"
24SRC_URI += "\
25 file://ARM-perf-add-support-for-perf-registers-API.diff \
26 file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \
27 "
28
29# kernel image files are not needed in the image
30RDEPENDS_kernel-base = ""
31
32do_configure_prepend() {
33 # fix imx-vpu break on video decoding
34 echo "CONFIG_VMSPLIT_2G=y" >> ${WORKDIR}/defconfig
35
36 # include H4 UART for Broadcom BT on Nitrogen6_Lite
37 echo "CONFIG_BT_HCIUART_H4=y" >> ${WORKDIR}/defconfig
38
39 # include Broadcom WiFi for Nitrogen6_Lite
40 echo "CONFIG_BRCMFMAC=m" >> ${WORKDIR}/defconfig
41
42 # include LEDS_GPIO for Nitrogen6_Lite
43 echo "CONFIG_LEDS_GPIO=y" >> ${WORKDIR}/defconfig
44
45 # enable uvcvideo module
46 echo "CONFIG_MEDIA_USB_SUPPORT=y" >> ${WORKDIR}/defconfig
47 echo "CONFIG_USB_VIDEO_CLASS=m" >> ${WORKDIR}/defconfig
48
49 echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
50}
diff --git a/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
new file mode 100644
index 0000000..8059c93
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-boundary_3.14.%.bbappend
@@ -0,0 +1,24 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# kernel image files are not needed in the image
24RDEPENDS_kernel-base = ""