diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-12 13:51:49 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-12 13:16:28 +0000 |
commit | b51b11cd16c115f8aba0d25cd79ca2bae6bd8353 (patch) | |
tree | 6cdf33b02740d08aaa54b5d2af52e3c60fae143c /meta-fsl-extras/recipes/u-boot | |
parent | c23e67cc73e4fe0d7c07dd79bd2380367d2047d6 (diff) | |
download | meta-boot2qt-b51b11cd16c115f8aba0d25cd79ca2bae6bd8353.tar.gz |
apalis-imx6: modify u-boot to provide support for ixora v1.0
Allow user to change drive slot where u-boot should use for booting.
Ixora v1.1 and v1.0 are using different slots.
Task-number: QTBUG-63458
Change-Id: I490438cb6d56910d84d9a392bb84a33f574375ce
Reviewed-by: Sami Nurmenniemi <sami.nurmenniemi@qt.io>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch | 37 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | 3 |
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch new file mode 100644 index 0000000..1bf7c27 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex/0003-apalis-imx6-Ixora-v1.0-support.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 1f3926a8e90a7e582d28b845e812d0642a4dc5ce Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Thu, 12 Oct 2017 11:02:54 +0300 | ||
4 | Subject: [PATCH 3/3] apalis-imx6: Ixora v1.0 support | ||
5 | |||
6 | Add sddrive variable that can be changed to boot from different mmc card | ||
7 | slot when using different versions of ixora carrier board. | ||
8 | Default to drive 1, which is correct for Ixora v1.1. | ||
9 | --- | ||
10 | include/configs/apalis_imx6.h | 9 +++++---- | ||
11 | 1 file changed, 5 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h | ||
14 | index 121eaa7..77a8874 100644 | ||
15 | --- a/include/configs/apalis_imx6.h | ||
16 | +++ b/include/configs/apalis_imx6.h | ||
17 | @@ -227,15 +227,16 @@ | ||
18 | "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
19 | |||
20 | #define SD_BOOTCMD \ | ||
21 | - "sdargs=ip=off root=/dev/mmcblk1p2 ro rootfstype=ext4 " \ | ||
22 | + "sddrive=1\0" \ | ||
23 | + "sdsetup=setenv sdargs ip=off root=/dev/mmcblk${sddrive}p2 ro rootfstype=ext4 " \ | ||
24 | "rootwait\0" \ | ||
25 | - "sdboot=run setup; " \ | ||
26 | + "sdboot=run setup; run sdsetup; " \ | ||
27 | "setenv bootargs ${defargs} ${sdargs} ${setupargs} " \ | ||
28 | "${vidargs}; echo Booting from SD card; " \ | ||
29 | - "run sddtbload; load mmc 1:1 ${kernel_addr_r} " \ | ||
30 | + "run sddtbload; load mmc ${sddrive}:1 ${kernel_addr_r} " \ | ||
31 | "${boot_file} && run fdt_fixup && " \ | ||
32 | "bootm ${kernel_addr_r} ${dtbparam}\0" \ | ||
33 | - "sddtbload=setenv dtbparam; load mmc 1:1 ${fdt_addr_r} " \ | ||
34 | + "sddtbload=setenv dtbparam; load mmc ${sddrive}:1 ${fdt_addr_r} " \ | ||
35 | "${fdt_file} && setenv dtbparam \" - ${fdt_addr_r}\" && true\0" | ||
36 | |||
37 | #define USB_BOOTCMD \ | ||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend index e501f5e..78e32d3 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_%.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | ############################################################################ | 1 | ############################################################################ |
2 | ## | 2 | ## |
3 | ## Copyright (C) 2016 The Qt Company Ltd. | 3 | ## Copyright (C) 2017 The Qt Company Ltd. |
4 | ## Contact: https://www.qt.io/licensing/ | 4 | ## Contact: https://www.qt.io/licensing/ |
5 | ## | 5 | ## |
6 | ## This file is part of the Boot to Qt meta layer. | 6 | ## This file is part of the Boot to Qt meta layer. |
@@ -31,4 +31,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
31 | SRC_URI += " \ | 31 | SRC_URI += " \ |
32 | file://0001-Make-sdboot-default-on-all-boards.patch \ | 32 | file://0001-Make-sdboot-default-on-all-boards.patch \ |
33 | file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \ | 33 | file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \ |
34 | file://0003-apalis-imx6-Ixora-v1.0-support.patch \ | ||
34 | " | 35 | " |