diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-01-13 09:36:03 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2016-01-13 10:59:33 +0000 |
commit | 9da0b34d08b24160d1f0fb901fa6f23c5a234acc (patch) | |
tree | 789cef2563eb2fa29843731967a7682472258a7b /meta-fsl-extras/recipes/u-boot | |
parent | 542039ccc44d57c0f602805000d048b7d72df3e5 (diff) | |
download | meta-boot2qt-9da0b34d08b24160d1f0fb901fa6f23c5a234acc.tar.gz |
nitrogen6x: update u-boot script
Set screen resolution for touch controller (ft5x06) so that touch events
are processed correctly on Qt.
Apply CMA argument to the correct u-boot script
Change-Id: I128f32b64c9bdc987c158a1e193d56cd8001106e
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
4 files changed, 58 insertions, 28 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch new file mode 100644 index 0000000..7d8e8ec --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 3fdf74d6934858d04d9e7df7cd24779bf7d9fdbb Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 13 Jan 2016 08:55:41 +0200 | ||
4 | Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display | ||
5 | |||
6 | --- | ||
7 | board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 6 ++++++ | ||
8 | 1 file changed, 6 insertions(+) | ||
9 | |||
10 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
11 | index 7c11f4c..86242b5 100644 | ||
12 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
13 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
14 | @@ -105,6 +105,12 @@ else | ||
15 | setenv bootargs "${bootargs} root=/dev/mmcblk${disk}p${bpart}" | ||
16 | fi | ||
17 | |||
18 | +if test "hannstar" = "${fb_lvds}" || test "hannstar" = "${fb_lvds2}" ; then | ||
19 | + setenv bootargs ${bootargs} ft5x06_ts.screenres=1024,600 | ||
20 | +elif test "hannstar7" = "${fb_lvds}" || test "hannstar7" = "${fb_lvds2}" ; then | ||
21 | + setenv bootargs ${bootargs} ft5x06_ts.screenres=1280,800 | ||
22 | +fi | ||
23 | + | ||
24 | if itest.s "x" != "x${disable_giga}" ; then | ||
25 | setenv bootargs ${bootargs} fec.disable_giga=1 | ||
26 | fi | ||
27 | -- | ||
28 | 1.9.1 | ||
29 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch deleted file mode 100644 index f42b213..0000000 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From b21614109fb3cca15c4b0d296b3ab6cc1b778e3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Yoann Lopes <yoann.lopes@theqtcompany.com> | ||
3 | Date: Wed, 10 Jun 2015 16:36:10 +0100 | ||
4 | Subject: [PATCH] nitrogen6x: update bootargs. | ||
5 | |||
6 | - disable console cursor blinking | ||
7 | - set CMA reserved size to 384MB | ||
8 | --- | ||
9 | board/boundary/nitrogen6x/6x_bootscript-yocto.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto.txt | ||
13 | index d933fa0..2d7c575 100644 | ||
14 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto.txt | ||
15 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto.txt | ||
16 | @@ -56,7 +56,7 @@ while test "4" -ne $nextcon ; do | ||
17 | done | ||
18 | |||
19 | setenv bootargs $bootargs $fbmem | ||
20 | -setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait" | ||
21 | +setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 cma=384M rootwait" | ||
22 | |||
23 | if itest.s x$bootpart == x ; then | ||
24 | bootpart=1 | ||
25 | -- | ||
26 | 1.7.10.4 | ||
27 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch new file mode 100644 index 0000000..d648340 --- /dev/null +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 3bb661da09e2a57ef452d388d69b8d01044136f1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 13 Jan 2016 09:26:33 +0200 | ||
4 | Subject: [PATCH] set CMA reserved size to 384MB | ||
5 | |||
6 | Increased from 256MB (the default) to 384MB. Without this, HW-accelerated | ||
7 | video decoding cannot work for high resolution videos. | ||
8 | --- | ||
9 | board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
13 | index 86242b5..da4ea05 100644 | ||
14 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
15 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | ||
16 | @@ -92,7 +92,7 @@ if itest.s "x" == "x${cmd_xxx_present}" ; then | ||
17 | echo "!!!!!!!!!!!!!!!!" | ||
18 | fi | ||
19 | |||
20 | -setenv bootargs "${bootargs} console=${console},115200 vmalloc=400M consoleblank=0 rootwait fixrtc" | ||
21 | +setenv bootargs "${bootargs} console=${console},115200 vmalloc=400M cma=384M consoleblank=0 rootwait fixrtc" | ||
22 | |||
23 | |||
24 | bpart=2 | ||
25 | -- | ||
26 | 1.9.1 | ||
27 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend index a6cee2b..d2294ba 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend | |||
@@ -22,5 +22,6 @@ | |||
22 | 22 | ||
23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
24 | SRC_URI += " \ | 24 | SRC_URI += " \ |
25 | file://0001-nitrogen6x-update-bootargs.patch \ | 25 | file://0001-set-CMA-reserved-size-to-384MB.patch \ |
26 | file://0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch \ | ||
26 | " | 27 | " |