diff options
author | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-12-07 08:49:47 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@theqtcompany.com> | 2015-12-07 08:49:47 +0200 |
commit | 85e2dbf78e6ba044fea744367f16ccd1808c1810 (patch) | |
tree | 87b31ac6c770274cf7e219c312b32d9d25af8b40 /meta-fsl-extras/recipes/u-boot | |
parent | 3587c4fb32e5046729608513bf4c189e846fefd4 (diff) | |
parent | c97f13c28d29bd71c98043f709a5875606300142 (diff) | |
download | meta-boot2qt-85e2dbf78e6ba044fea744367f16ccd1808c1810.tar.gz |
Merge remote-tracking branch 'origin/dizzy' into dev
* origin/dizzy:
Use openembedded mirror from github
nitrogen6x: add u-boot binary back to the image
ostree: Add TLS support
ostree: patch upstream project
ostree: Add GNUPG to runtime dependencies.
Revert "Build nativesdk-ostree"
Remove unused b2qt-update-framework
Conflicts:
conf/distro/include/nitrogen6x.conf
recipes/ostree/ostree.bb
scripts/manifest.xml
scripts/manifest_fido.xml
Change-Id: Ie3884fa026fc8b8d7d05a9bff4b2beb124e4fd03
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot')
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0002-nitrogen6x-update.patch | 84 | ||||
-rw-r--r-- | meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend | 1 |
2 files changed, 0 insertions, 85 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0002-nitrogen6x-update.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0002-nitrogen6x-update.patch deleted file mode 100644 index dd699d8..0000000 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0002-nitrogen6x-update.patch +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | From 3d7276b2b27317c5067d2095ea5c3952d11f4390 Mon Sep 17 00:00:00 2001 | ||
2 | From: Rainer Keller <rainer.keller@digia.com> | ||
3 | Date: Fri, 5 Sep 2014 14:39:50 +0200 | ||
4 | Subject: [PATCH] Add support for update recovery linux | ||
5 | |||
6 | --- | ||
7 | board/boundary/nitrogen6x/6x_bootscript-yocto.txt | 61 +++++++++++++++++++++++ | ||
8 | 1 file changed, 61 insertions(+) | ||
9 | |||
10 | diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto.txt | ||
11 | index 5bc6170..4116ed4 100644 | ||
12 | --- a/board/boundary/nitrogen6x/6x_bootscript-yocto.txt | ||
13 | +++ b/board/boundary/nitrogen6x/6x_bootscript-yocto.txt | ||
14 | @@ -1,3 +1,67 @@ | ||
15 | +# Boot2Qt update part begin | ||
16 | +echo "Boot to Qt" | ||
17 | +mw.b 0x13000000 0x76 1 # v | ||
18 | +mw.b 0x13000001 0x75 1 # u | ||
19 | +mw.b 0x13000002 0x74 1 # t | ||
20 | +mw.b 0x13000003 0x69 1 # i | ||
21 | + | ||
22 | +fdtaddr=0x12000000 | ||
23 | + | ||
24 | +if test "x$boot2qt_update_state" = "x" ; then | ||
25 | + setenv boot2qt_update_state valid | ||
26 | + saveenv | ||
27 | +fi | ||
28 | + | ||
29 | +# This is a workaround because environment partition is read-only. | ||
30 | +if fatload mmc 1:1 0x12000000 update/state ; then | ||
31 | + if cmp.b 0x12000000 0x13000000 1 ; then | ||
32 | + echo "State: Valid" | ||
33 | + setenv boot2qt_fat_state valid | ||
34 | + setenv boot2qt_update_state valid | ||
35 | + saveenv | ||
36 | + fi | ||
37 | + if cmp.b 0x12000000 0x13000001 1 ; then | ||
38 | + echo "State: Update" | ||
39 | + setenv boot2qt_fat_state update | ||
40 | + fi | ||
41 | + if cmp.b 0x12000000 0x13000002 1 ; then | ||
42 | + echo "State: Testing" | ||
43 | + setenv boot2qt_fat_state testing | ||
44 | + fi | ||
45 | +fi | ||
46 | + | ||
47 | +if test "x$boot2qt_fat_state" = "xupdate" || test "x$boot2qt_update_state" = "xinvalid" ; then | ||
48 | + setenv boot2qt_update_state testing | ||
49 | + saveenv | ||
50 | + echo "Recovery linux starting..." | ||
51 | + setenv bootargs "console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 root=/dev/ram0" | ||
52 | + | ||
53 | + # Guess dtb name | ||
54 | + dtbname="imx6"; | ||
55 | + if itest.s x6S != "x$cpu" ; then | ||
56 | + dtbname=${dtbname}q-; | ||
57 | + else | ||
58 | + dtbname=${dtbname}s-; | ||
59 | + fi | ||
60 | + | ||
61 | + if itest.s x == "x$board" ; then | ||
62 | + board=sabrelite | ||
63 | + fi | ||
64 | + dtbname=${dtbname}${board}.dtb; | ||
65 | + | ||
66 | + fatload mmc 1:1 ${loadaddr} update/uImage | ||
67 | + fatload mmc 1:1 ${fdtaddr} update/${dtbname} | ||
68 | + fatload mmc 1:1 0x13000000 update/uRamdisk | ||
69 | + bootm ${loadaddr} 0x13000000 ${fdtaddr} | ||
70 | +fi | ||
71 | + | ||
72 | +if test "x$boot2qt_fat_state" = "xtesting" || test "x$boot2qt_update_state" = "xtesting"; then | ||
73 | + setenv boot2qt_update_state invalid | ||
74 | + saveenv | ||
75 | +fi | ||
76 | + | ||
77 | +# Boot2Qt update part end | ||
78 | + | ||
79 | # Yocto-specifics | ||
80 | setenv bootpart 2 | ||
81 | setenv bootdir / | ||
82 | -- | ||
83 | 1.8.5.5 | ||
84 | |||
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend index abbc222..a6cee2b 100644 --- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend +++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend | |||
@@ -23,5 +23,4 @@ | |||
23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | 23 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
24 | SRC_URI += " \ | 24 | SRC_URI += " \ |
25 | file://0001-nitrogen6x-update-bootargs.patch \ | 25 | file://0001-nitrogen6x-update-bootargs.patch \ |
26 | file://0002-nitrogen6x-update.patch \ | ||
27 | " | 26 | " |