summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-04-09 16:17:11 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-04-17 12:28:34 +0000
commitc3f5d0d537a0a79adbf3771e550f83e341cb5897 (patch)
tree87b04bf7a1cae7604b5bcb2060d9f2a0652d1641 /meta-boot2qt
parenta0c975500f2b64ed327bd20a61cf9ceca75493ec (diff)
downloadmeta-boot2qt-c3f5d0d537a0a79adbf3771e550f83e341cb5897.tar.gz
Update all automotive components
Latest revisions from 5.11 branch for all automotive components and changing the recipe to for neptune3, which replaces both neptune-ui and multiscreen-demo. Neptune3 uses git-lfs, which needs to be enabled in the host system. Task-number: QTAUTO-928 Change-Id: I8494f31267f5362655493155929264698a96d7b5 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
Diffstat (limited to 'meta-boot2qt')
-rw-r--r--meta-boot2qt/conf/layer.conf2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/gammaray_git.bb4
-rw-r--r--meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb67
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service (renamed from meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service)2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb (renamed from meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb)46
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive/qmllive-target.patch19
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive_git.bb13
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb4
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb10
9 files changed, 51 insertions, 116 deletions
diff --git a/meta-boot2qt/conf/layer.conf b/meta-boot2qt/conf/layer.conf
index de3f836..43c8441 100644
--- a/meta-boot2qt/conf/layer.conf
+++ b/meta-boot2qt/conf/layer.conf
@@ -41,3 +41,5 @@ BBFILE_PRIORITY_b2qt = "20"
41LICENSE_PATH += "${LAYERDIR}/licenses" 41LICENSE_PATH += "${LAYERDIR}/licenses"
42QT_LICENSE = "${LAYERDIR}/licenses/The-Qt-Company-DCLA-2.1" 42QT_LICENSE = "${LAYERDIR}/licenses/The-Qt-Company-DCLA-2.1"
43B2QTBASE = "${LAYERDIR}" 43B2QTBASE = "${LAYERDIR}"
44
45HOSTTOOLS += "git-lfs"
diff --git a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
index 7466822..7676b2d 100644
--- a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
@@ -8,8 +8,8 @@ inherit cmake_qt5
8 8
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" 9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10 10
11BRANCH = "5.9" 11BRANCH = "5.11"
12SRCREV = "87656b9c344077d84682b53ba3e4676e18b57f9e" 12SRCREV = "3b701f3ce0ffb23762271cba9c531775bae941df"
13PV = "${BRANCH}+git${SRCPV}" 13PV = "${BRANCH}+git${SRCPV}"
14 14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \ 15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
diff --git a/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb b/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb
deleted file mode 100644
index c81adee..0000000
--- a/meta-boot2qt/recipes-qt/automotive/multiscreen-demo_git.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Multiscreen Demo"
31LICENSE = "GPLv3 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073"
33
34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc
36
37QT_GIT_PROJECT = "qt-apps"
38QT_MODULE_BRANCH = "master"
39
40SRC_URI += "\
41 git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets \
42 file://automotivedemo.service \
43 "
44
45SRCREV_multiscreen-demo = "6d02e36c4280cee5b0c31323016ae666c73afef4"
46SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264"
47
48SRCREV_FORMAT = "multiscreen-demo_assets"
49
50DEPENDS = "qtbase qtdeclarative qt3d"
51RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard"
52
53EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt"
54
55do_install_append() {
56 rm ${D}/opt/automotivedemo/start.sh
57
58 install -d ${D}${systemd_system_unitdir}
59 install -m 0644 ${WORKDIR}/automotivedemo.service ${D}${systemd_system_unitdir}/
60}
61
62FILES_${PN} += "\
63 /opt/automotivedemo \
64 "
65
66SYSTEMD_SERVICE_${PN} = "automotivedemo.service"
67SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
index 16b6a1f..d64a119 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune-ui/neptune.service
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
@@ -5,7 +5,7 @@ After=dbus.service dbus-session.service systemd-user-sessions.service
5[Service] 5[Service]
6ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml 6ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
7Restart=on-failure 7Restart=on-failure
8WorkingDirectory=/usr/neptune-ui 8WorkingDirectory=/opt/neptune3
9 9
10[Install] 10[Install]
11WantedBy=multi-user.target 11WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index 5898424..f6be9cb 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -28,11 +28,11 @@
28## 28##
29############################################################################ 29############################################################################
30 30
31DESCRIPTION = "Neptune IVI UI" 31DESCRIPTION = "Neptune 3 IVI UI"
32LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" 32LICENSE = "Apache-2.0 & ( GPL-3.0 | The-Qt-Company-DCLA-2.1 )"
33LIC_FILES_CHKSUM = "\ 33LIC_FILES_CHKSUM = "\
34 file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82 \ 34 file://LICENSE.GPL3;md5=0d02f21f8e2533ecc519e2ed96bc94a2 \
35 file://imports/assets/fonts/OFL.txt;md5=a729250f3548d9d2deab9bfeb8a7ad51 \ 35 file://imports/assets/fonts/LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
36" 36"
37 37
38inherit qt5-module systemd 38inherit qt5-module systemd
@@ -44,12 +44,26 @@ SRC_URI += " \
44 file://neptune.service \ 44 file://neptune.service \
45 " 45 "
46 46
47SRCREV = "7b64754e5d1aa3ea3b63347bc5637bae9795e193" 47SRCREV = "716aadcbd88fbaa8f2b7bbf399cde1a4754e0def"
48 48
49DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager" 49DEPENDS = "\
50RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \ 50 qtbase \
51 qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ 51 qtdeclarative \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" 52 qttools-native \
53 qtquickcontrols2 \
54 qtapplicationmanager \
55 qtivi qtivi-native \
56 qtremoteobjects qtremoteobjects-native \
57 "
58RDEPENDS_${PN} = "\
59 dbus \
60 otf-noto ttf-opensans \
61 qtapplicationmanager qtapplicationmanager-tools \
62 qtvirtualkeyboard \
63 qtquickcontrols2-qmlplugins \
64 qtgraphicaleffects-qmlplugins \
65 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)} \
66 "
53 67
54do_install_append() { 68do_install_append() {
55 install -m 0755 -d ${D}${systemd_unitdir}/system 69 install -m 0755 -d ${D}${systemd_unitdir}/system
@@ -57,17 +71,23 @@ do_install_append() {
57 71
58 # Move the fonts to the system-wide font location 72 # Move the fonts to the system-wide font location
59 install -m 0755 -d ${D}${datadir}/fonts/ttf/ 73 install -m 0755 -d ${D}${datadir}/fonts/ttf/
60 mv ${D}/usr/neptune-ui/imports/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/ 74 mv ${D}/opt/neptune3/imports/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/
61 rm -rf ${D}/usr/neptune-ui/imports/assets/fonts/ 75 rm -rf ${D}/opt/neptune3/imports/assets/fonts/
76
77 # Don't package tests
78 rm -rf ${D}/usr/share/tests
62} 79}
63 80
64PACKAGES =+ "${PN}-apps" 81PACKAGES =+ "${PN}-apps"
65RRECOMMENDS_${PN} += "${PN}-apps" 82RRECOMMENDS_${PN} += "${PN}-apps"
66 83
67FILES_${PN}-apps += "/usr/neptune-ui/apps" 84FILES_${PN}-apps += "/opt/neptune3/apps"
68FILES_${PN} += "\ 85FILES_${PN} += "\
69 /usr/neptune-ui \ 86 /opt/neptune3 \
70 ${datadir}/fonts/ttf \ 87 ${datadir}/fonts/ttf \
71 " 88 "
89FILES_${PN}-dev += "\
90 /opt/neptune3/lib/*.so \
91 "
72 92
73SYSTEMD_SERVICE_${PN} = "neptune.service" 93SYSTEMD_SERVICE_${PN} = "neptune.service"
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive/qmllive-target.patch b/meta-boot2qt/recipes-qt/automotive/qmllive/qmllive-target.patch
deleted file mode 100644
index e3f81fa..0000000
--- a/meta-boot2qt/recipes-qt/automotive/qmllive/qmllive-target.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1diff --git a/runtime.pro b/runtime.pro
2index 73dd6d7..e569b23 100644
3--- a/runtime.pro
4+++ b/runtime.pro
5@@ -1,5 +1,4 @@
6 TARGET = qmlliveruntime
7-DESTDIR = ../../bin
8
9 QT *= widgets quick
10 osx: CONFIG -= app_bundle
11@@ -14,6 +13,6 @@ include(../src.pri)
12 RESOURCES += \
13 qml.qrc
14
15-
16-
17+target.path += /usr/bin
18+INSTALLS += target
19
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
index ce1bb82..1b6e02e 100644
--- a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
@@ -30,7 +30,7 @@
30DESCRIPTION = "QML Live target runtime" 30DESCRIPTION = "QML Live target runtime"
31 31
32LICENSE = "GPL-3.0" 32LICENSE = "GPL-3.0"
33LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" 33LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
34 34
35inherit qmake5 35inherit qmake5
36require recipes-qt/qt5/qt5-git.inc 36require recipes-qt/qt5/qt5-git.inc
@@ -38,12 +38,9 @@ require recipes-qt/qt5/qt5-git.inc
38QT_GIT_PROJECT = "qt-apps" 38QT_GIT_PROJECT = "qt-apps"
39QT_MODULE_BRANCH = "master" 39QT_MODULE_BRANCH = "master"
40 40
41SRC_URI += " \ 41SRCREV = "4d360892c7a21b4b2aad0ec47ef3f60fb0b0b381"
42 file://qmllive-target.patch \
43 "
44
45SRCREV = "d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
46
47S = "${WORKDIR}/git/src/runtime"
48 42
49DEPENDS = "qtbase qtdeclarative" 43DEPENDS = "qtbase qtdeclarative"
44
45EXTRA_QMAKEVARS_PRE += "CONFIG+=skip-tests CONFIG+=skip-examples"
46EXTRA_QMAKEVARS_POST += "QMAKE_RPATHDIR="
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index ae66e8a..8c41333 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,10 +34,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=ff238b33ff354a0d8d79851a9c061717"
34inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37SRCREV = "5581e400c95a1ff736c55c9d93bd451302970c11" 37SRCREV = "6aa3295386b0a0f0b8c7ae1b0f827dd28b6323ca"
38 38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
41 41
42RDEPENDS_${PN} = "libcrypto ${PN}-tools" 42RDEPENDS_${PN} = "libcrypto ${PN}-tools"
43RDEPENDS_${PN}_remove_mingw32 = "libcrypto" 43RDEPENDS_${PN}_remove_mingw32 = "libcrypto"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 5cbf131..5c17935 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -37,7 +37,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
37 37
38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native" 38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native"
39DEPENDS_class-native = "qtbase" 39DEPENDS_class-native = "qtbase"
40DEPENDS_class-nativesdk = "qtbase" 40DEPENDS_class-nativesdk = "qtbase qtivi-native"
41 41
42inherit qt5-module 42inherit qt5-module
43inherit python3native 43inherit python3native
@@ -50,12 +50,12 @@ SRC_URI += " \
50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ 50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
51" 51"
52 52
53SRCREV_qtivi = "8d482b27c6c0c2b664104fd777ddee92652ab65c" 53SRCREV_qtivi = "8658258f2f8d8dac3327a870573dc046029b74bc"
54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8" 54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8"
55SRCREV = "${SRCREV_qtivi}" 55SRCREV = "${SRCREV_qtivi}"
56SRCREV_FORMAT = "qtivi_qface" 56SRCREV_FORMAT = "qtivi_qface"
57 57
58PACKAGECONFIG ?= "taglib ivigenerator" 58PACKAGECONFIG ?= "taglib ivigenerator remoteobjects"
59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib" 59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon" 60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon"
61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only" 61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only"
@@ -65,8 +65,10 @@ PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python
65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only" 65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only"
66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator" 66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator"
67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator" 67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator"
68PACKAGECONFIG[remoteobjects] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtremoteobjects"
69PACKAGECONFIG[remoteobjects-native] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtremoteobjects"
68 70
69PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" 71PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native remoteobjects-native"
70PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" 72PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
71PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only" 73PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
72 74