summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-04-09 16:17:11 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-04-17 12:28:34 +0000
commitc3f5d0d537a0a79adbf3771e550f83e341cb5897 (patch)
tree87b04bf7a1cae7604b5bcb2060d9f2a0652d1641 /meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
parenta0c975500f2b64ed327bd20a61cf9ceca75493ec (diff)
downloadmeta-boot2qt-c3f5d0d537a0a79adbf3771e550f83e341cb5897.tar.gz
Update all automotive components
Latest revisions from 5.11 branch for all automotive components and changing the recipe to for neptune3, which replaces both neptune-ui and multiscreen-demo. Neptune3 uses git-lfs, which needs to be enabled in the host system. Task-number: QTAUTO-928 Change-Id: I8494f31267f5362655493155929264698a96d7b5 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive/qtivi_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 5cbf131..5c17935 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -37,7 +37,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
37 37
38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native" 38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native"
39DEPENDS_class-native = "qtbase" 39DEPENDS_class-native = "qtbase"
40DEPENDS_class-nativesdk = "qtbase" 40DEPENDS_class-nativesdk = "qtbase qtivi-native"
41 41
42inherit qt5-module 42inherit qt5-module
43inherit python3native 43inherit python3native
@@ -50,12 +50,12 @@ SRC_URI += " \
50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ 50 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
51" 51"
52 52
53SRCREV_qtivi = "8d482b27c6c0c2b664104fd777ddee92652ab65c" 53SRCREV_qtivi = "8658258f2f8d8dac3327a870573dc046029b74bc"
54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8" 54SRCREV_qface = "9da793d6cbc63d617ad5e2ffd13e9f6d055c88e8"
55SRCREV = "${SRCREV_qtivi}" 55SRCREV = "${SRCREV_qtivi}"
56SRCREV_FORMAT = "qtivi_qface" 56SRCREV_FORMAT = "qtivi_qface"
57 57
58PACKAGECONFIG ?= "taglib ivigenerator" 58PACKAGECONFIG ?= "taglib ivigenerator remoteobjects"
59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib" 59PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon" 60PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon"
61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only" 61PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only"
@@ -65,8 +65,10 @@ PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python
65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only" 65PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only"
66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator" 66PACKAGECONFIG[simulator] = "QMAKE_EXTRA_ARGS+=-feature-simulator,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtsimulator"
67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator" 67PACKAGECONFIG[simulator-native] = "QMAKE_EXTRA_ARGS+=-feature-simulator QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtsimulator"
68PACKAGECONFIG[remoteobjects] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects,QMAKE_EXTRA_ARGS+=-no-feature-simulator,qtremoteobjects"
69PACKAGECONFIG[remoteobjects-native] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtremoteobjects"
68 70
69PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native" 71PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native remoteobjects-native"
70PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}" 72PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
71PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only" 73PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
72 74