summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-04-09 16:17:11 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-04-17 12:28:34 +0000
commitc3f5d0d537a0a79adbf3771e550f83e341cb5897 (patch)
tree87b04bf7a1cae7604b5bcb2060d9f2a0652d1641 /meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
parenta0c975500f2b64ed327bd20a61cf9ceca75493ec (diff)
downloadmeta-boot2qt-c3f5d0d537a0a79adbf3771e550f83e341cb5897.tar.gz
Update all automotive components
Latest revisions from 5.11 branch for all automotive components and changing the recipe to for neptune3, which replaces both neptune-ui and multiscreen-demo. Neptune3 uses git-lfs, which needs to be enabled in the host system. Task-number: QTAUTO-928 Change-Id: I8494f31267f5362655493155929264698a96d7b5 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
new file mode 100644
index 0000000..f6be9cb
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -0,0 +1,93 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Copyright (C) 2018 Pelagicore AG.
5## Contact: https://www.qt.io/licensing/
6##
7## This file is part of the Boot to Qt meta layer.
8##
9## $QT_BEGIN_LICENSE:GPL$
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at https://www.qt.io/contact-us.
17##
18## GNU General Public License Usage
19## Alternatively, this file may be used under the terms of the GNU
20## General Public License version 3 or (at your option) any later version
21## approved by the KDE Free Qt Foundation. The licenses are as published by
22## the Free Software Foundation and appearing in the file LICENSE.GPL3
23## included in the packaging of this file. Please review the following
24## information to ensure the GNU General Public License requirements will
25## be met: https://www.gnu.org/licenses/gpl-3.0.html.
26##
27## $QT_END_LICENSE$
28##
29############################################################################
30
31DESCRIPTION = "Neptune 3 IVI UI"
32LICENSE = "Apache-2.0 & ( GPL-3.0 | The-Qt-Company-DCLA-2.1 )"
33LIC_FILES_CHKSUM = "\
34 file://LICENSE.GPL3;md5=0d02f21f8e2533ecc519e2ed96bc94a2 \
35 file://imports/assets/fonts/LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
36"
37
38inherit qt5-module systemd
39require recipes-qt/qt5/qt5-git.inc
40
41QT_GIT_PROJECT = "qt-apps"
42
43SRC_URI += " \
44 file://neptune.service \
45 "
46
47SRCREV = "716aadcbd88fbaa8f2b7bbf399cde1a4754e0def"
48
49DEPENDS = "\
50 qtbase \
51 qtdeclarative \
52 qttools-native \
53 qtquickcontrols2 \
54 qtapplicationmanager \
55 qtivi qtivi-native \
56 qtremoteobjects qtremoteobjects-native \
57 "
58RDEPENDS_${PN} = "\
59 dbus \
60 otf-noto ttf-opensans \
61 qtapplicationmanager qtapplicationmanager-tools \
62 qtvirtualkeyboard \
63 qtquickcontrols2-qmlplugins \
64 qtgraphicaleffects-qmlplugins \
65 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)} \
66 "
67
68do_install_append() {
69 install -m 0755 -d ${D}${systemd_unitdir}/system
70 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
71
72 # Move the fonts to the system-wide font location
73 install -m 0755 -d ${D}${datadir}/fonts/ttf/
74 mv ${D}/opt/neptune3/imports/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/
75 rm -rf ${D}/opt/neptune3/imports/assets/fonts/
76
77 # Don't package tests
78 rm -rf ${D}/usr/share/tests
79}
80
81PACKAGES =+ "${PN}-apps"
82RRECOMMENDS_${PN} += "${PN}-apps"
83
84FILES_${PN}-apps += "/opt/neptune3/apps"
85FILES_${PN} += "\
86 /opt/neptune3 \
87 ${datadir}/fonts/ttf \
88 "
89FILES_${PN}-dev += "\
90 /opt/neptune3/lib/*.so \
91 "
92
93SYSTEMD_SERVICE_${PN} = "neptune.service"