summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt/recipes-qt/automotive/gammaray_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/automotive/gammaray_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
new file mode 100644
index 0000000..7466822
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "GammaRay Qt introspection probe"
2HOMEPAGE = "http://www.kdab.com/gammaray"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=a5b28ec9718d4516f7a621cd0232afc1"
6
7inherit cmake_qt5
8
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10
11BRANCH = "5.9"
12SRCREV = "87656b9c344077d84682b53ba3e4676e18b57f9e"
13PV = "${BRANCH}+git${SRCPV}"
14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
16 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF -DGAMMARAY_CORE_ONLY_LAUNCHER=ON"
21
22FILES_${PN}-dev += " \
23 /usr/lib/cmake/* \
24 /usr/mkspecs/modules/* \
25"
26FILES_${PN}-dbg += " \
27 /usr/lib/.debug/* \
28 /usr/lib/gammaray/*/*/.debug \
29 /usr/lib/gammaray/*/*/styles/.debug \
30"