summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-devtools
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt/recipes-devtools
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt/recipes-devtools')
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc53
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb42
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb42
-rw-r--r--meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.service12
-rwxr-xr-xmeta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.sh17
-rw-r--r--meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb65
-rw-r--r--meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb62
7 files changed, 293 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
new file mode 100644
index 0000000..3d8c083
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
@@ -0,0 +1,53 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "PSFv2"
31
32LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4b8a9367e6bb2acb6f26dc08654f6ee5"
33
34do_unpack[depends] += "p7zip-native:do_populate_sysroot"
35
36inherit bin_package nativesdk python3-dir
37
38PV = "3.5.2"
39
40S = "${WORKDIR}"
41
42do_install() {
43 install -d ${D}${includedir}/${PYTHON_DIR}
44 install -m 0644 ${S}/include/* ${D}${includedir}/${PYTHON_DIR}
45
46 install -d ${D}${libdir}
47 install -m 0644 ${S}/libs/*.a ${D}${libdir}
48
49 install -d ${D}${bindir}
50 install -m 0644 ${S}/python.exe ${D}${bindir}
51 install -m 0644 ${S}/python35.dll ${D}${bindir}
52 install -m 0644 ${S}/python35.zip ${D}${bindir}
53}
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
new file mode 100644
index 0000000..2ff4f76
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require nativesdk-prebuild-python.inc
31
32COMPATIBLE_HOST = "i686.*-mingw.*"
33
34SRC_URI = "\
35 https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \
36 https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \
37 "
38
39SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f"
40SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2"
41SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca"
42SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954"
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
new file mode 100644
index 0000000..8e69fbd
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30require nativesdk-prebuild-python.inc
31
32COMPATIBLE_HOST = "x86_64.*-mingw.*"
33
34SRC_URI = "\
35 https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \
36 https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \
37 "
38
39SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f"
40SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124"
41SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e"
42SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066"
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.service b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.service
new file mode 100644
index 0000000..7c7211f
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=QtSimulator Shared Mount Point
3After=systemd-user-sessions.service
4
5[Service]
6Type=oneshot
7RemainAfterExit=yes
8ExecStart=/usr/bin/mount-vboxsf.sh start
9ExecStop=/usr/bin/mount-vboxsf.sh stop
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.sh b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.sh
new file mode 100755
index 0000000..80476de
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf/mount-vboxsf.sh
@@ -0,0 +1,17 @@
1#!/bin/sh
2
3MOUNTPOINT=/var/vqvideo
4
5case "$1" in
6start)
7 mkdir -p /var/vqvideo
8 /usr/bin/mount.vboxsf vqvideo $MOUNTPOINT
9 ;;
10stop)
11 umount $MOUNTPOINT
12 ;;
13*)
14 echo "Usage: $0 {start|stop}"
15 exit 1
16esac
17exit 0
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb
new file mode 100644
index 0000000..1eb2652
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/virtualbox/mount-vboxsf_4.3.30.bb
@@ -0,0 +1,65 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "VirtualBox Guest Additions for Linux: mount"
31LICENSE = "GPLv2"
32LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
33
34SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2 \
35 file://mount-vboxsf.sh \
36 file://mount-vboxsf.service \
37 "
38
39SRC_URI[md5sum] = "cc053340f88922a11ad9d4fab56557bd"
40SRC_URI[sha256sum] = "ea9569ec16cd6202ee61bcadb2506d31ac12fd343adb91565773a05eaaea9a36"
41
42S = "${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/sharedfolders"
43
44do_compile() {
45 ${CC} ${LDFLAGS} mount.vboxsf.c vbsfmount.c -o mount.vboxsf
46}
47
48do_install() {
49 install -m 0755 -d ${D}${bindir}/
50 install -m 0755 mount.vboxsf ${D}${bindir}/
51 install -m 0755 ${WORKDIR}/mount-vboxsf.sh ${D}${bindir}/
52
53 install -m 0755 -d ${D}${sysconfdir}/init.d
54 ln -s ${bindir}/mount-vboxsf.sh ${D}${sysconfdir}/init.d/
55
56 install -m 0755 -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/mount-vboxsf.service ${D}${systemd_unitdir}/system/
58}
59
60INITSCRIPT_NAME = "mount-vboxsf.sh"
61INITSCRIPT_PARAMS = "defaults 33"
62
63SYSTEMD_SERVICE_${PN} = "mount-vboxsf.service"
64
65inherit update-rc.d systemd
diff --git a/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb b/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb
new file mode 100644
index 0000000..752d8cb
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/virtualbox/virtualbox-guest-additions_5.1.16.bb
@@ -0,0 +1,62 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Kernel drivers for the VirtualBox guest additions"
31LICENSE = "GPLv2"
32LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
33
34inherit module
35
36MACHINE_KERNEL_PR_append = "a"
37PR = "${MACHINE_KERNEL_PR}"
38
39SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2"
40
41SRC_URI[md5sum] = "37ebbd51370841eed8ab80f2f38446d6"
42SRC_URI[sha256sum] = "78071c3172f3bd3c7981c352c3ae6c6a9c01f6ab24bc0aa7ec79f3528b2291a7"
43
44S = "${WORKDIR}/vbox"
45
46export KERN_DIR="${STAGING_KERNEL_DIR}"
47export KBUILD_VERBOSE="1"
48export BUILD_TARGET_ARCH="${ARCH}"
49
50do_compile_prepend() {
51 ${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/export_modules ${WORKDIR}/vbox.tar.gz
52 tar xf ${WORKDIR}/vbox.tar.gz -C ${WORKDIR}/vbox
53}
54
55do_install() {
56 install -m 0755 -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
57 install -m 0644 vboxsf.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
58 install -m 0644 vboxguest.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
59 install -m 0644 vboxvideo.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
60}
61
62PKG_${PN} = "kernel-module-vbox"