summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-06-27 10:38:35 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-06-28 12:14:34 +0000
commit651adf5a48ebb74db1f93f6e00cc5f426a194bf9 (patch)
tree34fda0758f23655b5185023dc84d8eed0ba2328a /meta-boot2qt-distro
parente794cd92f9f6cfe6334a55974f433de6ea743c15 (diff)
downloadmeta-boot2qt-651adf5a48ebb74db1f93f6e00cc5f426a194bf9.tar.gz
meta-qt5: update layer
* Includes merged commits from upstream/master & new recipe for Qt3DStudio runtime libraries * gsteamer1.0-plugins-bad appends added to meta-boot2qt-distro specific bbappend as plugins-bad was moved to plugins-good as upstream/master is built against poky (sumo) and we're still at pyro branch. * qtbase bbappend updated with new getentropy packageconfig. Change-Id: I612040526fa73ba8866187c0f6931b2194444b9a Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/conf/layer.conf1
-rw-r--r--meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend18
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend3
3 files changed, 20 insertions, 2 deletions
diff --git a/meta-boot2qt-distro/conf/layer.conf b/meta-boot2qt-distro/conf/layer.conf
index 268f6d3..9a218d9 100644
--- a/meta-boot2qt-distro/conf/layer.conf
+++ b/meta-boot2qt-distro/conf/layer.conf
@@ -34,6 +34,7 @@ BBPATH .= ":${LAYERDIR}"
34BBFILES += "${LAYERDIR}/recipes*/*/*.bb \ 34BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
35 ${LAYERDIR}/recipes*/*/*.bbappend \ 35 ${LAYERDIR}/recipes*/*/*.bbappend \
36 " 36 "
37BBMASK += "meta-qt5/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend"
37 38
38BBFILE_COLLECTIONS += "b2qt-distro" 39BBFILE_COLLECTIONS += "b2qt-distro"
39BBFILE_PATTERN_b2qt-distro := "^${LAYERDIR}/" 40BBFILE_PATTERN_b2qt-distro := "^${LAYERDIR}/"
diff --git a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index f42e121..0271b6d 100644
--- a/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/meta-boot2qt-distro/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -28,3 +28,19 @@
28############################################################################ 28############################################################################
29 29
30PACKAGECONFIG_append = " faad" 30PACKAGECONFIG_append = " faad"
31
32inherit qmake5_paths
33
34PACKAGECONFIG[qt5] = '--enable-qt \
35 --with-moc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/moc" \
36 --with-uic="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/uic" \
37 --with-rcc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/rcc" \
38 ,--disable-qt,qtbase qtdeclarative qtbase-native'
39
40# The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled
41python() {
42 cur_packageconfig = d.getVar('PACKAGECONFIG',True).split()
43 if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)):
44 gl_packageconfig = d.getVar('PACKAGECONFIG_GL',True)
45 d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig)
46}
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
index e7c7adf..5f62fbb 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
@@ -1,6 +1,6 @@
1############################################################################ 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
@@ -37,6 +37,7 @@ PACKAGECONFIG += " \
37 cups \ 37 cups \
38 fontconfig \ 38 fontconfig \
39 freetype \ 39 freetype \
40 getentropy \
40 gif \ 41 gif \
41 glib \ 42 glib \
42 ico \ 43 ico \