summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-25 15:05:08 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-30 08:12:14 +0000
commitc6cf6f303ad64f3243c4541e3d4ab5957326ad38 (patch)
tree7c890bbeaf522003bfe518eaa33b56dca1cb3e1c /meta-boot2qt-distro
parentda8985fae240e7cf189a1376a6c7593656a024da (diff)
downloadmeta-boot2qt-c6cf6f303ad64f3243c4541e3d4ab5957326ad38.tar.gz
cmake: fix cmake configurations for QtCreator
Include cmake and make as explicitly to the toolchain. Fix nativesdk-cmake compilation for mingw toolchain. Add CMake registration code to the QBSP installer scripts. Task-number: QTBUG-71315 Change-Id: If29e12d6ce24546ba8a834969b6f60e3216e6962 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb2
-rw-r--r--meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend36
-rw-r--r--meta-boot2qt-distro/recipes-extended/libarchive/libarchive_%.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-support/curl/curl_%.bbappend31
4 files changed, 99 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 21552d7..c22a46c 100644
--- a/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -43,6 +43,8 @@ python __anonymous() {
43 43
44RDEPENDS_${PN} = "\ 44RDEPENDS_${PN} = "\
45 nativesdk-gperf \ 45 nativesdk-gperf \
46 nativesdk-cmake \
47 nativesdk-make \
46 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \ 48 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \
47 " 49 "
48 50
diff --git a/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend b/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend
new file mode 100644
index 0000000..d3603bf
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend
@@ -0,0 +1,36 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DEPENDS_remove_mingw32 = "ncurses"
31
32cmake_do_generate_toolchain_file_append_mingw32() {
33 cat >> ${WORKDIR}/toolchain.cmake <<EOF
34set( CMAKE_SYSTEM_NAME Windows )
35EOF
36}
diff --git a/meta-boot2qt-distro/recipes-extended/libarchive/libarchive_%.bbappend b/meta-boot2qt-distro/recipes-extended/libarchive/libarchive_%.bbappend
new file mode 100644
index 0000000..937c746
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-extended/libarchive/libarchive_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30EXTRA_OECONF_append_mingw32 = " --without-cng"
diff --git a/meta-boot2qt-distro/recipes-support/curl/curl_%.bbappend b/meta-boot2qt-distro/recipes-support/curl/curl_%.bbappend
new file mode 100644
index 0000000..6545343
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-support/curl/curl_%.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG_remove_class-nativesdk_mingw32 = "ssl"
31RRECOMMENDS_lib${BPN}_remove_mingw32 = "ca-certificates"