summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt/qt5
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-qt/qt5
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/qt5')
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend44
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend34
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch157
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch25
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri6
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri10
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri4
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx2/oe-device-extra.pri4
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri10
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri11
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/oe-device-extra.pri3
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri11
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/smarc-samx6i/oe-device-extra.pri3
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/tegra-t18x/oe-device-extra.pri11
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri6
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend64
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend32
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch23
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend34
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtmultimedia_git.bbappend32
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtsystems_git.bbappend31
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend31
22 files changed, 586 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
new file mode 100644
index 0000000..2ae2206
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -0,0 +1,44 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
31
32SRC_URI += "\
33 file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
34 "
35
36PACKAGECONFIG += "openssl"
37PACKAGECONFIG_remove_mingw32 += "openssl"
38
39PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
40
41fakeroot do_generate_qt_environment_file_mingw32() {
42}
43
44SRC_URI_append_mingw32 = "file://0001-disable-qt_random_cpu.patch"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
new file mode 100644
index 0000000..821c6d3
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
@@ -0,0 +1,34 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
31
32SRC_URI += "\
33 file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
34 "
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch
new file mode 100644
index 0000000..ac4fe40
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch
@@ -0,0 +1,157 @@
1From 0386cb5f9a46e56a0a94f2a92e87ed52d41cf4ea Mon Sep 17 00:00:00 2001
2From: David Schulz <david.schulz@theqtcompany.com>
3Date: Fri, 3 Jul 2015 16:06:59 +0200
4Subject: [PATCH] Add win32-g++-oe mkspec that uses the OE_ environment.
5
6Upstream-Status: Inappropriate [embedded specific]
7 too OE specific, probably cannot be upstreamed
8
9Change-Id: Ic60b32f88ee6a792b0d8938e40e2d6cb19fb93aa
10---
11 mkspecs/win32-g++-oe/qmake.conf | 87 ++++++++++++++++++++++++++++++++++++
12 mkspecs/win32-g++-oe/qplatformdefs.h | 42 +++++++++++++++++
13 2 files changed, 129 insertions(+)
14 create mode 100644 mkspecs/win32-g++-oe/qmake.conf
15 create mode 100644 mkspecs/win32-g++-oe/qplatformdefs.h
16
17diff --git a/mkspecs/win32-g++-oe/qmake.conf b/mkspecs/win32-g++-oe/qmake.conf
18new file mode 100644
19index 0000000..76eefe5
20--- /dev/null
21+++ b/mkspecs/win32-g++-oe/qmake.conf
22@@ -0,0 +1,87 @@
23+#
24+# qmake configuration for win32-g++
25+#
26+# Written for MinGW / gcc 4.6 or higher
27+#
28+# Cross compile example for i686-w64-mingw32-g++:
29+# configure -xplatform win32-g++ -device-option CROSS_COMPILE=i686-w64-mingw32-
30+#
31+
32+load(device_config)
33+include(../common/g++-base.conf)
34+
35+MAKEFILE_GENERATOR = MINGW
36+QMAKE_PLATFORM = win32 mingw
37+CONFIG += debug_and_release debug_and_release_target precompile_header
38+DEFINES += UNICODE
39+QMAKE_COMPILER_DEFINES += __GNUC__ WIN32
40+
41+QMAKE_EXT_OBJ = .o
42+QMAKE_EXT_RES = _res.o
43+
44+QMAKE_COMPILER = $$(OE_QMAKE_COMPILER)
45+
46+QMAKE_CC = $$(OE_QMAKE_CC)
47+QMAKE_LEX = flex
48+QMAKE_LEXFLAGS =
49+QMAKE_YACC = bison -y
50+QMAKE_YACCFLAGS = -d
51+QMAKE_CFLAGS += -fno-keep-inline-dllexport $$(OE_QMAKE_CFLAGS)
52+QMAKE_CFLAGS_WARN_ON += -Wextra
53+QMAKE_CFLAGS_SSE2 += -mstackrealign
54+
55+QMAKE_CXX = $$(OE_QMAKE_CXX)
56+QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
57+QMAKE_CXXFLAGS_RTTI_ON = -frtti
58+QMAKE_CXXFLAGS_RTTI_OFF = -fno-rtti
59+QMAKE_CXXFLAGS_EXCEPTIONS_ON = -fexceptions -mthreads
60+
61+QMAKE_INCDIR =
62+
63+QMAKE_RUN_CC = $(CC) -c $(CFLAGS) $(INCPATH) -o $obj $src
64+QMAKE_RUN_CC_IMP = $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
65+QMAKE_RUN_CXX = $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $obj $src
66+QMAKE_RUN_CXX_IMP = $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $@ $<
67+
68+QMAKE_LINK = $$(OE_QMAKE_LINK)
69+QMAKE_LINK_C = $$(OE_QMAKE_LINK)
70+QMAKE_LFLAGS = $$(OE_QMAKE_LDFLAGS)
71+QMAKE_LFLAGS_EXCEPTIONS_ON = -mthreads
72+QMAKE_LFLAGS_RELEASE = -Wl,-s
73+QMAKE_LFLAGS_CONSOLE = -Wl,-subsystem,console
74+QMAKE_LFLAGS_WINDOWS = -Wl,-subsystem,windows
75+QMAKE_LFLAGS_DLL = -shared
76+QMAKE_LFLAGS_GCSECTIONS = -Wl,--gc-sections
77+QMAKE_LINK_OBJECT_MAX = 10
78+QMAKE_LINK_OBJECT_SCRIPT = object_script
79+QMAKE_PREFIX_SHLIB =
80+QMAKE_EXTENSION_SHLIB = dll
81+QMAKE_PREFIX_STATICLIB = lib
82+QMAKE_EXTENSION_STATICLIB = a
83+QMAKE_LIB_EXTENSIONS = a dll.a
84+
85+QMAKE_LIBS =
86+QMAKE_LIBS_CORE = -lole32 -luuid -lws2_32 -ladvapi32 -lshell32 -luser32 -lkernel32
87+QMAKE_LIBS_GUI = -lgdi32 -lcomdlg32 -loleaut32 -limm32 -lwinmm -lws2_32 -lole32 -luuid -luser32 -ladvapi32
88+QMAKE_LIBS_NETWORK = -lws2_32
89+QMAKE_LIBS_OPENGL = -lglu32 -lopengl32 -lgdi32 -luser32
90+QMAKE_LIBS_OPENGL_ES2 = -lgdi32 -luser32
91+QMAKE_LIBS_OPENGL_ES2_DEBUG = -lgdi32 -luser32
92+QMAKE_LIBS_COMPAT = -ladvapi32 -lshell32 -lcomdlg32 -luser32 -lgdi32 -lws2_32
93+QMAKE_LIBS_QT_ENTRY = -lmingw32 -lqtmain
94+
95+QMAKE_IDL = midl
96+QMAKE_LIB = $$(OE_QMAKE_AR) -rc
97+QMAKE_RC = $$(RC)
98+
99+QMAKE_STRIP = $$(OE_QMAKE_STRIP)
100+QMAKE_STRIPFLAGS_LIB += --strip-unneeded
101+QMAKE_OBJCOPY = $${CROSS_COMPILE}objcopy
102+QMAKE_NM = $${CROSS_COMPILE}nm -P
103+
104+isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG)
105+
106+include(../common/angle.conf)
107+include(../common/gcc-base.conf)
108+
109+load(qt_config)
110diff --git a/mkspecs/win32-g++-oe/qplatformdefs.h b/mkspecs/win32-g++-oe/qplatformdefs.h
111new file mode 100644
112index 0000000..9d63527
113--- /dev/null
114+++ b/mkspecs/win32-g++-oe/qplatformdefs.h
115@@ -0,0 +1,42 @@
116+/****************************************************************************
117+**
118+** Copyright (C) 2012 Digia Plc and/or its subsidiary(-ies).
119+** Contact: http://www.qt-project.org/legal
120+**
121+** This file is part of the qmake spec of the Qt Toolkit.
122+**
123+** $QT_BEGIN_LICENSE:LGPL$
124+** Commercial License Usage
125+** Licensees holding valid commercial Qt licenses may use this file in
126+** accordance with the commercial license agreement provided with the
127+** Software or, alternatively, in accordance with the terms contained in
128+** a written agreement between you and Digia. For licensing terms and
129+** conditions see http://qt.digia.com/licensing. For further information
130+** use the contact form at http://qt.digia.com/contact-us.
131+**
132+** GNU Lesser General Public License Usage
133+** Alternatively, this file may be used under the terms of the GNU Lesser
134+** General Public License version 2.1 as published by the Free Software
135+** Foundation and appearing in the file LICENSE.LGPL included in the
136+** packaging of this file. Please review the following information to
137+** ensure the GNU Lesser General Public License version 2.1 requirements
138+** will be met: http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
139+**
140+** In addition, as a special exception, Digia gives you certain additional
141+** rights. These rights are described in the Digia Qt LGPL Exception
142+** version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
143+**
144+** GNU General Public License Usage
145+** Alternatively, this file may be used under the terms of the GNU
146+** General Public License version 3.0 as published by the Free Software
147+** Foundation and appearing in the file LICENSE.GPL included in the
148+** packaging of this file. Please review the following information to
149+** ensure the GNU General Public License version 3.0 requirements will be
150+** met: http://www.gnu.org/copyleft/gpl.html.
151+**
152+**
153+** $QT_END_LICENSE$
154+**
155+****************************************************************************/
156+
157+#include "../win32-g++/qplatformdefs.h"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch
new file mode 100644
index 0000000..26c7838
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch
@@ -0,0 +1,25 @@
1From 655618933b78f53bb4338c8b7e3109da780ad3c6 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Thu, 23 Nov 2017 11:28:47 +0200
4Subject: [PATCH] disable qt_random_cpu
5
6The code caused internal compiler error when compiling for mingw32
7
8Change-Id: Ieba798a9599a6d683c6630c6cd3731b2b909b628
9---
10 src/corelib/global/qrandom.cpp | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/corelib/global/qrandom.cpp b/src/corelib/global/qrandom.cpp
14index 6769190..c1a775a 100644
15--- a/src/corelib/global/qrandom.cpp
16+++ b/src/corelib/global/qrandom.cpp
17@@ -92,7 +92,7 @@ DECLSPEC_IMPORT BOOLEAN WINAPI SystemFunction036(PVOID RandomBuffer, ULONG Rando
18
19 QT_BEGIN_NAMESPACE
20
21-#if defined(Q_PROCESSOR_X86) && QT_COMPILER_SUPPORTS_HERE(RDRND)
22+#if 0
23 static qsizetype qt_random_cpu(void *buffer, qsizetype count) Q_DECL_NOTHROW;
24
25 # ifdef Q_PROCESSOR_X86_64
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri
new file mode 100644
index 0000000..d29adb2
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/emulator/oe-device-extra.pri
@@ -0,0 +1,6 @@
1QMAKE_LIBS_EGL = -lQtGlesStreamClient
2QMAKE_LIBS_OPENGL_ES2 = -lQtGlesStreamClient
3
4QMAKE_PLATFORM += boot2qt
5QT_QPA_DEFAULT_PLATFORM = eglfs
6EGLFS_DEVICE_INTEGRATION = eglfs_emu
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri
new file mode 100644
index 0000000..cdb6204
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/intel-corei7-64/oe-device-extra.pri
@@ -0,0 +1,10 @@
1NUC_CFLAGS = -m64
2QMAKE_LIBS_EGL += -lEGL
3QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
4QMAKE_CFLAGS += $$NUC_CFLAGS
5QMAKE_CXXFLAGS += $$NUC_CFLAGS
6
7QMAKE_PLATFORM += boot2qt
8
9QT_QPA_DEFAULT_PLATFORM = eglfs
10EGLFS_DEVICE_INTEGRATION = eglfs_kms
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri
new file mode 100644
index 0000000..d4c14ca
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx1/oe-device-extra.pri
@@ -0,0 +1,4 @@
1QMAKE_PLATFORM += boot2qt
2
3QT_QPA_DEFAULT_PLATFORM = eglfs
4EGLFS_DEVICE_INTEGRATION = eglfs_kms_egldevice
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx2/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx2/oe-device-extra.pri
new file mode 100644
index 0000000..d4c14ca
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/jetson-tx2/oe-device-extra.pri
@@ -0,0 +1,4 @@
1QMAKE_PLATFORM += boot2qt
2
3QT_QPA_DEFAULT_PLATFORM = eglfs
4EGLFS_DEVICE_INTEGRATION = eglfs_kms_egldevice
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri
new file mode 100644
index 0000000..f5445e3
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/mx6/oe-device-extra.pri
@@ -0,0 +1,10 @@
1IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
2QMAKE_LIBS_EGL += -lEGL
3QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL
4QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL
5QMAKE_CFLAGS += $$IMX6_CFLAGS
6QMAKE_CXXFLAGS += $$IMX6_CFLAGS
7
8QMAKE_PLATFORM += boot2qt
9QT_QPA_DEFAULT_PLATFORM = eglfs
10EGLFS_DEVICE_INTEGRATION = eglfs_viv
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri
new file mode 100644
index 0000000..6554742
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/nvidia-logan/oe-device-extra.pri
@@ -0,0 +1,11 @@
1TK1_CFLAGS = -DWIN_INTERFACE_CUSTOM
2QMAKE_LIBS_EGL += -lEGL
3QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
4QMAKE_CFLAGS += $$TK1_CFLAGS
5QMAKE_CXXFLAGS += $$TK1_CFLAGS
6
7QMAKE_PLATFORM += boot2qt
8
9QT_QPA_DEFAULT_PLATFORM = eglfs
10EGLFS_DEVICE_INTEGRATION = eglfs_kms_egldevice
11
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/oe-device-extra.pri
new file mode 100644
index 0000000..250c999
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/oe-device-extra.pri
@@ -0,0 +1,3 @@
1# This file contains device-specific qmake.conf settings
2QMAKE_PLATFORM += boot2qt
3QT_QPA_DEFAULT_PLATFORM = eglfs
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri
new file mode 100644
index 0000000..9f64808
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/rpi/oe-device-extra.pri
@@ -0,0 +1,11 @@
1QMAKE_INCDIR_EGL = $$[QT_SYSROOT]/usr/include/interface/vcos/pthreads \
2 $$[QT_SYSROOT]/usr/include/interface/vmcs_host/linux
3QMAKE_INCDIR_OPENGL_ES2 = $${QMAKE_INCDIR_EGL}
4
5QMAKE_LIBS_EGL = -lEGL -lGLESv2
6QMAKE_CFLAGS += $$RPI_CFLAGS
7QMAKE_CXXFLAGS += $$RPI_CFLAGS
8
9QMAKE_PLATFORM += boot2qt
10QT_QPA_DEFAULT_PLATFORM = eglfs
11EGLFS_DEVICE_INTEGRATION = eglfs_brcm
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/smarc-samx6i/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/smarc-samx6i/oe-device-extra.pri
new file mode 100644
index 0000000..ae04468
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/smarc-samx6i/oe-device-extra.pri
@@ -0,0 +1,3 @@
1QMAKE_PLATFORM += boot2qt
2QT_QPA_DEFAULT_PLATFORM = eglfs
3EGLFS_DEVICE_INTEGRATION = eglfs_kms
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/tegra-t18x/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/tegra-t18x/oe-device-extra.pri
new file mode 100644
index 0000000..4597a84
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/tegra-t18x/oe-device-extra.pri
@@ -0,0 +1,11 @@
1TEGRA_T18X_CFLAGS = -DWIN_INTERFACE_CUSTOM
2QMAKE_LIBS_EGL += -lEGL
3QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
4QMAKE_CFLAGS += $$TEGRA_T18X_CFLAGS
5QMAKE_CXXFLAGS += $$TEGRA_T18X_CFLAGS
6
7QMAKE_PLATFORM += boot2qt
8
9QT_QPA_DEFAULT_PLATFORM = eglfs
10EGLFS_DEVICE_INTEGRATION = eglfs_kms_egldevice
11
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri
new file mode 100644
index 0000000..0a18a5d
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/ti33x/oe-device-extra.pri
@@ -0,0 +1,6 @@
1QMAKE_LIBS_EGL = -lEGL -lIMGegl -lsrv_um
2QMAKE_LIBS_OPENGL_ES2 = -lGLESv2 $${QMAKE_LIBS_EGL}
3QMAKE_LIBS_OPENVG = -lOpenVG $${QMAKE_LIBS_EGL}
4
5QMAKE_PLATFORM += boot2qt
6QT_QPA_DEFAULT_PLATFORM = eglfs
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
new file mode 100644
index 0000000..e7c7adf
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
@@ -0,0 +1,64 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 eglfs', 'no-opengl', d)}"
31
32# emulator is exception due to qtglesstream
33PACKAGECONFIG_GL_emulator = "gles2 eglfs"
34
35PACKAGECONFIG += " \
36 accessibility \
37 cups \
38 fontconfig \
39 freetype \
40 gif \
41 glib \
42 ico \
43 icu \
44 libinput \
45 linuxfb \
46 sql-sqlite \
47 tslib \
48 xkbcommon-evdev \
49 "
50
51PACKAGECONFIG_remove = "tests"
52
53FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
54
55SRC_URI += " \
56 file://oe-device-extra.pri \
57 file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
58 "
59do_configure_prepend() {
60 install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs
61}
62
63# make other libgbm providers possible
64PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend
new file mode 100644
index 0000000..d9144a8
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtdeclarative_git.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILES_${PN}-plugins_mingw32 = " \
31 ${OE_QMAKE_PATH_PLUGINS}/*/*.dll \
32"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch
new file mode 100644
index 0000000..ad4c7b8
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation/0001-location-disable-simulator-content-under-plugins.patch
@@ -0,0 +1,23 @@
1From a7af02fe34bd8e067c7654ac366e19783b89e990 Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Wed, 25 Oct 2017 13:22:16 +0300
4Subject: [PATCH] location: disable simulator content under plugins
5
6Does not build against more recent simulator
7---
8 src/plugins/position/position.pro | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/plugins/position/position.pro b/src/plugins/position/position.pro
12index 1687a9d..347963f 100644
13--- a/src/plugins/position/position.pro
14+++ b/src/plugins/position/position.pro
15@@ -5,7 +5,7 @@ QT_FOR_CONFIG += positioning-private
16 qtHaveModule(dbus):SUBDIRS += geoclue
17 qtConfig(gypsy):SUBDIRS += gypsy
18 qtConfig(winrt_geolocation):SUBDIRS += winrt
19-qtHaveModule(simulator):SUBDIRS += simulator
20+#qtHaveModule(simulator):SUBDIRS += simulator
21 osx|ios|tvos:SUBDIRS += corelocation
22 android:SUBDIRS += android
23 win32:qtHaveModule(serialport):SUBDIRS += serialnmea
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend
new file mode 100644
index 0000000..d6ee6a1
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend
@@ -0,0 +1,34 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG += "geoservices_mapboxgl"
31
32FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
33
34SRC_URI += "file://0001-location-disable-simulator-content-under-plugins.patch"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtmultimedia_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtmultimedia_git.bbappend
new file mode 100644
index 0000000..fbae3ba
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtmultimedia_git.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
31 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'gstreamer010', 'gstreamer010', 'gstreamer', d)}"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtsystems_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtsystems_git.bbappend
new file mode 100644
index 0000000..e8fe1f3
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtsystems_git.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30EXTRA_QMAKEVARS_PRE_append_emulator = " CONFIG+=simulator"
31DEPENDS_append_emulator = " qtsimulator"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
new file mode 100644
index 0000000..4f48099
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
@@ -0,0 +1,31 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30PACKAGECONFIG_append = " hunspell"
31RDEPENDS_${PN} += "hunspell-dicts"