summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2018-02-06 11:04:39 +0100
committerMaurice Kalinowski <maurice.kalinowski@qt.io>2019-01-02 12:13:31 +0000
commit0f191b2fb735243df629b93e2bb1d7cc7e8c63fc (patch)
tree50ec3652c1b0937a61dbcc5369b0cb2768c8e590 /meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
parent0103760ff29668af74f40d3d344de48dbe920c63 (diff)
downloadmeta-boot2qt-0f191b2fb735243df629b93e2bb1d7cc7e8c63fc.tar.gz
Add Automation related modules and target
For OpcUA we are missing the backend libraries as they are not available upstream yet. However, building the Qt OpcUA module is a first step. Task-number: QTBUG-72001 Change-Id: I41cdce87d16b9a6dd15d381f1e0995ecac87b059 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb')
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
new file mode 100644
index 0000000..257ef0f
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Target packages for B2Qt Automation Qt5 SDK"
31LICENSE = "The-Qt-Company-Commercial"
32PR = "r0"
33
34inherit packagegroup
35
36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37
38RDEPENDS_${PN} += " \
39 qtmqtt-dev \
40 qtknx-dev \
41 qtopcua-dev \
42 "