summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb')
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb
new file mode 100644
index 0000000..d8743a5
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt5-image.bb
@@ -0,0 +1,55 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt embedded Qt5 image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33PR = "r0"
34
35DEPLOY_CONF_TYPE = "Boot2Qt"
36
37IMAGE_FEATURES += "\
38 package-management \
39 ssh-server-dropbear \
40 tools-debug \
41 debug-tweaks \
42 hwcodecs \
43 "
44
45inherit core-image qbsp-image
46inherit consistent_timestamps
47
48IMAGE_INSTALL += "\
49 packagegroup-b2qt-embedded-base \
50 packagegroup-b2qt-embedded-tools \
51 ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
52 ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
53 packagegroup-b2qt-qt5-modules \
54 packagegroup-b2qt-embedded-addons \
55 "