summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-11-20 13:43:51 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-11-21 11:43:18 +0000
commitc5a5bce25764de55420664b6896fd76ba5d18f45 (patch)
tree37946f9fcb4cf9dc9f09e0f693cb2b95a1c1f775 /meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
parent41105c273d58293be70f23d8e0ac24f41042d3f0 (diff)
downloadmeta-boot2qt-c5a5bce25764de55420664b6896fd76ba5d18f45.tar.gz
Remove default expansion parameter from getVarv5.12.0-rc
getVar defaults to expanding the variable, the second True parameter is unnecessary. Change-Id: Iafaf179c67ffedaba2946c078c1810a80198cf5e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb')
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
index 1afeb7e..8d63166 100644
--- a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-ci-image.bb
@@ -55,11 +55,11 @@ python remove_qt_from_rootfs() {
55 import subprocess 55 import subprocess
56 56
57 # remove qtbase and all dependent packages 57 # remove qtbase and all dependent packages
58 image_rootfs = d.getVar('IMAGE_ROOTFS', True) 58 image_rootfs = d.getVar('IMAGE_ROOTFS')
59 opkg_conf = d.getVar("IPKGCONF_TARGET", True) 59 opkg_conf = d.getVar("IPKGCONF_TARGET")
60 opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg") 60 opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg")
61 opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs) 61 opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs)
62 opkg_args += d.getVar("OPKG_ARGS", True) 62 opkg_args += d.getVar("OPKG_ARGS")
63 63
64 cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \ 64 cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \
65 (opkg_cmd, opkg_args, 'qtbase') 65 (opkg_cmd, opkg_args, 'qtbase')