summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-devtools
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-devtools
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-devtools')
-rw-r--r--meta-boot2qt-distro/recipes-devtools/binutils/binutils-cross_%.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend56
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gdb/gdb/0001-Do-not-use-win32-specific-filehandling.patch24
-rw-r--r--meta-boot2qt-distro/recipes-devtools/perl/perl_5.%.bbappend32
-rw-r--r--meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend1
-rw-r--r--meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb21
-rw-r--r--meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend11
7 files changed, 175 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/binutils/binutils-cross_%.bbappend b/meta-boot2qt-distro/recipes-devtools/binutils/binutils-cross_%.bbappend
new file mode 100644
index 0000000..8a069ed
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/binutils/binutils-cross_%.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LDGOLD_sdkmingw32 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '--enable-gold=default --enable-threads', '--enable-gold --enable-ld=default --enable-threads', d)}"
diff --git a/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend b/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend
new file mode 100644
index 0000000..4e55e66
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_7.%.bbappend
@@ -0,0 +1,56 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend_sdkmingw32 := "${THISDIR}/${BPN}:"
31SRC_URI_append_sdkmingw32 = " file://0001-Do-not-use-win32-specific-filehandling.patch"
32
33DEPENDS_append_sdkmingw32 = " nativesdk-prebuild-python"
34RDEPENDS_${PN}_append_sdkmingw32 = " nativesdk-prebuild-python"
35EXTRA_OECONF_remove_sdkmingw32 = "--without-python --with-python=no"
36EXTRA_OECONF_append_sdkmingw32 = " --with-python=${WORKDIR}/python_win"
37CXXFLAGS_append_sdkmingw32 = " -D_hypot=hypot"
38
39do_configure_prepend_sdkmingw32() {
40cat > ${WORKDIR}/python_win << EOF
41#! /bin/sh
42case "\$2" in
43 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}" ;;
44 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -lpython35" ;;
45 --exec-prefix) echo "${exec_prefix}" ;;
46 *) exit 1 ;;
47esac
48exit 0
49EOF
50 chmod +x ${WORKDIR}/python_win
51}
52
53do_install_append_sdkmingw32() {
54 ln -s ../python35.dll ${D}${bindir}/
55 ln -s ../python35.zip ${D}${bindir}/
56}
diff --git a/meta-boot2qt-distro/recipes-devtools/gdb/gdb/0001-Do-not-use-win32-specific-filehandling.patch b/meta-boot2qt-distro/recipes-devtools/gdb/gdb/0001-Do-not-use-win32-specific-filehandling.patch
new file mode 100644
index 0000000..c9a20ed
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/gdb/gdb/0001-Do-not-use-win32-specific-filehandling.patch
@@ -0,0 +1,24 @@
1From 3c928a3bf8d873f6173a076da6e4c1bc85e9a3a0 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Wed, 28 Jun 2017 20:41:49 +0300
4Subject: [PATCH] Do not use win32 specific filehandling
5
6PyFile_FromString and PyFile_AsFile are no longer available in python3
7see https://sourceware.org/bugzilla/show_bug.cgi?id=15600
8---
9 gdb/python/python.c | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/gdb/python/python.c b/gdb/python/python.c
13index 9bccaa9..1d58dff 100644
14--- a/gdb/python/python.c
15+++ b/gdb/python/python.c
16@@ -374,7 +374,7 @@ python_interactive_command (char *arg, int from_tty)
17 static void
18 python_run_simple_file (FILE *file, const char *filename)
19 {
20-#ifndef _WIN32
21+#ifdef _WIN32
22
23 PyRun_SimpleFile (file, filename);
24
diff --git a/meta-boot2qt-distro/recipes-devtools/perl/perl_5.%.bbappend b/meta-boot2qt-distro/recipes-devtools/perl/perl_5.%.bbappend
new file mode 100644
index 0000000..5f4baf7
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/perl/perl_5.%.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_install_append_class-nativesdk () {
31 sed -i -e 's|$OECORE_NATIVE_SYSROOT/|${SDKPATHNATIVE}|g' ${D}${bindir}/perl
32}
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend b/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend
new file mode 100644
index 0000000..9015f3f
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/python/python3-native_%.bbappend
@@ -0,0 +1 @@
SRC_URI_remove = "file://python-3.3-multilib.patch"
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb b/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb
new file mode 100644
index 0000000..cc091b8
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/python/python3-virtualenv.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Virtual Python Environment builder"
2HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51910050bd6ad04a50033f3e15d6ce43"
6
7PV="15.1.0"
8SRC_URI = "https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-15.1.0.tar.gz"
9
10SRC_URI[md5sum] = "44e19f4134906fe2d75124427dc9b716"
11SRC_URI[sha256sum] = "02f8102c2436bb03b3ee6dede1919d1dac8a427541652e5ec95171ec8adbc93a"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/virtualenv/"
14UPSTREAM_CHECK_REGEX = "/virtualenv/(?P<pver>(\d+[\.\-_]*)+)"
15
16S = "${WORKDIR}/virtualenv-${PV}"
17
18BBCLASSEXTEND = "native nativesdk"
19
20inherit setuptools3
21
diff --git a/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend b/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend
new file mode 100644
index 0000000..b3a5eb7
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/python/python3_%.bbappend
@@ -0,0 +1,11 @@
1SRC_URI_remove = "file://python-3.3-multilib.patch"
2
3# We need to install the python3 binary into the sysroot to let qtivi install that binary
4# into the correct location.
5# We can't install it directly into ${bindir} as this would be picked up by other recipes
6# and produce a lot of errors. Instead put it inside a qt5 folder where only qtivi picks it up
7# This is a workaround and needs to be replaced by a proper solution discussed here:
8# https://bugreports.qt.io/browse/AUTOSUITE-176
9sysroot_stage_all_append_class-nativesdk () {
10 sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}/qt5
11}