summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-core
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-core
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-core')
-rw-r--r--meta-boot2qt-distro/recipes-core/base-files/base-files/blacklist.conf1
-rw-r--r--meta-boot2qt-distro/recipes-core/base-files/base-files_3.0.14.bbappend44
-rw-r--r--meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session-address5
-rw-r--r--meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.init112
-rw-r--r--meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.service13
-rw-r--r--meta-boot2qt-distro/recipes-core/dbus/dbus_%.bbappend72
-rw-r--r--meta-boot2qt-distro/recipes-core/initscripts/initscripts_1.0.bbappend32
-rw-r--r--meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend35
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb60
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb58
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer.bb48
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb66
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb52
-rw-r--r--meta-boot2qt-distro/recipes-core/systemd/systemd/usb-rndis.network5
-rw-r--r--meta-boot2qt-distro/recipes-core/systemd/systemd_%.bbappend52
15 files changed, 655 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-core/base-files/base-files/blacklist.conf b/meta-boot2qt-distro/recipes-core/base-files/base-files/blacklist.conf
new file mode 100644
index 0000000..a8b8885
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/base-files/base-files/blacklist.conf
@@ -0,0 +1 @@
blacklist evbug
diff --git a/meta-boot2qt-distro/recipes-core/base-files/base-files_3.0.14.bbappend b/meta-boot2qt-distro/recipes-core/base-files/base-files_3.0.14.bbappend
new file mode 100644
index 0000000..1dc5501
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -0,0 +1,44 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "\
32 file://blacklist.conf \
33 "
34
35do_install_append() {
36 ln -s /home/root ${D}/root
37 echo ${MACHINE_HOSTNAME} > ${D}${sysconfdir}/hostname
38
39 install -m 0755 -d ${D}${sysconfdir}/modprobe.d
40 install -m 0644 ${WORKDIR}/blacklist.conf ${D}${sysconfdir}/modprobe.d
41
42 # Add quotes around command expansion, since tty may return "not a tty"
43 sed -i 's#test `tty | cut -c1-8`#test "`tty | cut -c1-8`"#' ${D}${sysconfdir}/profile
44}
diff --git a/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session-address b/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session-address
new file mode 100644
index 0000000..3f85306
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session-address
@@ -0,0 +1,5 @@
1#!/bin/sh
2
3if [ -e /var/run/dbus/session_bus_address ]; then
4 . /var/run/dbus/session_bus_address
5fi
diff --git a/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.init b/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.init
new file mode 100644
index 0000000..0690511
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.init
@@ -0,0 +1,112 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides: dbus
4# Required-Start: $remote_fs $syslog
5# Required-Stop: $remote_fs $syslog
6# Default-Start: 2 3 4 5
7# Default-Stop: 1
8# Short-Description: D-Bus session message bus
9# Description: D-Bus is a simple interprocess messaging system, used
10# for sending messages between applications.
11### END INIT INFO
12#
13# -*- coding: utf-8 -*-
14# Debian init.d script for D-BUS
15# Copyright © 2003 Colin Walters <walters@debian.org>
16
17# set -e
18
19# Source function library.
20#. /etc/init.d/functions
21
22DAEMON=@bindir@/dbus-launch
23NAME=dbus-session
24ADDRESSFILE=/var/run/dbus/session_bus_address
25UUIDDIR=/var/lib/dbus
26DESC="session message bus"
27APPCONTROLLERPATH="/tmp/b2qt/appcontroller.conf.d"
28APPCONTROLLERADDRESSFILE="session_bus_address"
29
30
31test -x $DAEMON || exit 0
32
33# Source defaults file; edit that file to configure this script.
34ENABLED=1
35PARAMS=""
36if [ -e /etc/default/dbus ]; then
37 . /etc/default/dbus
38fi
39
40if [ -e $ADDRESSFILE ]; then
41 . $ADDRESSFILE
42fi
43
44if [ ! -d $APPCONTROLLERPATH ]; then
45mkdir -p $APPCONTROLLERPATH
46fi
47
48test "$ENABLED" != "0" || exit 0
49
50start_it_up()
51{
52 echo -n "Starting $DESC: "
53 $DAEMON --auto-syntax > $ADDRESSFILE
54 ADDR=`cat $ADDRESSFILE|grep -i DBUS_SESSION_BUS_ADDRESS=`
55 echo "env=${ADDR%?}" |tr -d \' > ${APPCONTROLLERPATH}/${APPCONTROLLERADDRESSFILE}
56 echo "$NAME."
57}
58
59shut_it_down()
60{
61 echo -n "Stopping $DESC: "
62 kill $DBUS_SESSION_BUS_PID
63 echo "$NAME."
64}
65
66reload_it()
67{
68 echo -n "Reloading $DESC config: "
69 dbus-send --print-reply --session --type=method_call \
70 --dest=org.freedesktop.DBus \
71 / org.freedesktop.DBus.ReloadConfig > /dev/null
72 # hopefully this is enough time for dbus to reload it's config file.
73 echo "done."
74}
75
76status_it()
77{
78 if kill -0 $DBUS_SESSION_BUS_PID 2>/dev/null; then
79 echo "$NAME (pid $DBUS_SESSION_BUS_PID) is running..."
80 return 0
81 else
82 echo "$NAME is stopped"
83 fi
84 return 3
85}
86
87case "$1" in
88 start)
89 start_it_up
90 ;;
91 stop)
92 shut_it_down
93 ;;
94 status)
95 status_it
96 exit $?
97 ;;
98 reload|force-reload)
99 reload_it
100 ;;
101 restart)
102 shut_it_down
103 sleep 1
104 start_it_up
105 ;;
106 *)
107 echo "Usage: /etc/init.d/$NAME {start|stop|status|restart|reload|force-reload}" >&2
108 exit 1
109 ;;
110esac
111
112exit 0
diff --git a/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.service b/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.service
new file mode 100644
index 0000000..8dcf081
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/dbus/dbus/dbus-session.service
@@ -0,0 +1,13 @@
1[Unit]
2Description=D-BUS Session Message Bus.
3After=dbus.service
4
5[Service]
6Type=forking
7ExecStart=/usr/bin/dbus-session.init.sh start
8ExecStop=/usr/bin/dbus-session.init.sh stop
9Environment=HOME=/home/root
10
11[Install]
12WantedBy=multi-user.target
13
diff --git a/meta-boot2qt-distro/recipes-core/dbus/dbus_%.bbappend b/meta-boot2qt-distro/recipes-core/dbus/dbus_%.bbappend
new file mode 100644
index 0000000..64d750c
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/dbus/dbus_%.bbappend
@@ -0,0 +1,72 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30inherit systemd
31
32FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
33SRC_URI += " \
34 file://dbus-session.init \
35 file://dbus-session.service \
36 file://dbus-session-address \
37 "
38INITSCRIPT_PACKAGES = "${PN} ${PN}-session-init"
39INITSCRIPT_NAME_${PN}-session-init = "dbus-session"
40INITSCRIPT_PARAMS_${PN}-session-init = "start 20 5 3 2 . stop 10 0 1 6 ."
41
42PACKAGES =+ "${PN}-session-init"
43SYSTEMD_PACKAGES =+ "${PN}-session-init"
44
45FILES_${PN}-session-init = " \
46 ${sysconfdir}/init.d/dbus-session \
47 ${sysconfdir}/profile.d/dbus-session-address \
48 ${bindir}/dbus-session.init.sh \
49 ${systemd_unitdir}/system/dbus-session.service \
50 "
51
52do_install_append_class-target() {
53 sed 's:@bindir@:${bindir}:' < ${WORKDIR}/dbus-session.init >${WORKDIR}/dbus-session.init.sh
54
55 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
56 install -d ${D}${sysconfdir}/init.d
57 install -m 0755 ${WORKDIR}/dbus-session.init.sh ${D}${sysconfdir}/init.d/dbus-session
58 fi
59
60 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
61 install -m 0755 -d ${D}${bindir}/
62 install -m 0755 ${WORKDIR}/dbus-session.init.sh ${D}${bindir}/
63
64 install -m 0755 -d ${D}${systemd_unitdir}/system
65 install -m 0644 ${WORKDIR}/dbus-session.service ${D}${systemd_unitdir}/system/
66 fi
67
68 install -d ${D}${sysconfdir}/profile.d
69 install -m 0755 ${WORKDIR}/dbus-session-address ${D}${sysconfdir}/profile.d/
70}
71
72SYSTEMD_SERVICE_${PN}-session-init = "dbus-session.service"
diff --git a/meta-boot2qt-distro/recipes-core/initscripts/initscripts_1.0.bbappend b/meta-boot2qt-distro/recipes-core/initscripts/initscripts_1.0.bbappend
new file mode 100644
index 0000000..e2550b1
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/initscripts/initscripts_1.0.bbappend
@@ -0,0 +1,32 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_configure_append() {
31 sed -i -e "/echo/d" ${WORKDIR}/banner.sh
32}
diff --git a/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend b/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend
new file mode 100644
index 0000000..65cc6b3
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend
@@ -0,0 +1,35 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30inherit image-buildinfo
31
32toolchain_create_sdk_version_append () {
33 echo 'Layer Revisions:' >> $versionfile
34 echo '${@get_layer_revs(d)}' >> $versionfile
35}
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
new file mode 100644
index 0000000..9f43fff
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -0,0 +1,60 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Host packages for B2Qt on embedded Linux SDK"
31PR = "r0"
32LICENSE = "The-Qt-Company-DCLA-2.1"
33
34inherit nativesdk packagegroup
35
36MACHINE_EXTRA_INSTALL_SDK_HOST ?= ""
37
38python __anonymous() {
39 overrides = d.getVar("OVERRIDES", True).split(":")
40 if "mingw32" not in overrides:
41 d.appendVar("OVERRIDES", ":linux")
42}
43
44RDEPENDS_${PN} = "\
45 nativesdk-gperf \
46 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \
47 "
48
49RDEPENDS_${PN}_append_linux = "\
50 nativesdk-python3-modules \
51 nativesdk-python3-misc \
52 nativesdk-perl-modules \
53 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland-dev", "", d)} \
54 "
55
56RDEPENDS_${PN}_append_mingw32 = "\
57 nativesdk-make \
58 nativesdk-libgcc \
59 nativesdk-libstdc++ \
60 "
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 0000000..b6573e2
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,58 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34inherit packagegroup
35
36MACHINE_EXTRA_INSTALL ?= ""
37
38RDEPENDS_${PN} = "\
39 kernel-modules \
40 linux-firmware \
41 ca-certificates \
42 liberation-fonts \
43 ttf-devanagari \
44 ttf-opensans \
45 ttf-dejavu-common \
46 ttf-dejavu-sans \
47 ttf-freefont-mono \
48 otf-noto \
49 dbus-session-init \
50 tzdata \
51 tzdata-americas \
52 tzdata-asia \
53 tzdata-europe \
54 connman \
55 rng-tools \
56 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "weston weston-examples", "", d)} \
57 ${MACHINE_EXTRA_INSTALL} \
58 "
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer.bb
new file mode 100644
index 0000000..b1bec0e
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer.bb
@@ -0,0 +1,48 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34inherit packagegroup
35
36MACHINE_GSTREAMER_1_0_PLUGIN ?= ""
37
38RDEPENDS_${PN} = "\
39 gstreamer1.0-meta-base \
40 gstreamer1.0-meta-video \
41 gstreamer1.0-meta-audio \
42 gstreamer1.0-plugins-base-meta \
43 gstreamer1.0-plugins-good-meta \
44 gstreamer1.0-plugins-ugly-meta \
45 gstreamer1.0-plugins-bad-meta \
46 gstreamer1.0-libav \
47 ${MACHINE_GSTREAMER_1_0_PLUGIN} \
48 "
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb
new file mode 100644
index 0000000..af291c7
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-gstreamer010.bb
@@ -0,0 +1,66 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34inherit packagegroup
35
36RDEPENDS_${PN} = "\
37 gst-meta-video \
38 gst-meta-audio \
39 gst-plugins-good \
40 gst-plugins-base-app \
41 gst-plugins-base-audiorate \
42 gst-plugins-base-videorate \
43 gst-plugins-base-encodebin \
44 gst-plugins-good-videofilter \
45 gst-plugins-good-id3demux \
46 gst-plugins-good-auparse \
47 gst-plugins-good-isomp4 \
48 gst-plugins-good-icydemux \
49 gst-plugins-good-video4linux2 \
50 gst-plugins-good-multifile \
51 gst-plugins-good-videocrop \
52 gst-plugins-good-jpeg \
53 gst-plugins-ugly-rmdemux \
54 gst-plugins-ugly-asf \
55 gst-plugins-ugly-a52dec \
56 gst-plugins-bad-mpegdemux \
57 gst-plugins-bad-faad \
58 gst-plugins-bad-camerabin2 \
59 gst-plugins-bad-jpegformat \
60 gst-plugins-ugly-mad \
61 gst-plugins-ugly-mpegaudioparse \
62 gst-plugins-ugly-mpeg2dec \
63 gst-plugins-ugly-mpegstream \
64 gst-plugins-bad-mpegvideoparse \
65 gst-ffmpeg \
66 "
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb
new file mode 100644
index 0000000..7644f6f
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-tools.bb
@@ -0,0 +1,52 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Additional tools packagegroup for B2Qt embedded Linux image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34inherit packagegroup
35
36RDEPENDS_${PN} = "\
37 alsa-utils-amixer \
38 binutils \
39 binutils-symlinks \
40 connman-client \
41 htop \
42 i2c-tools \
43 iproute2 \
44 ldd \
45 openssh-sftp-server \
46 perf \
47 procps \
48 rsync \
49 tslib-calibrate \
50 valgrind \
51 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd-analyze", "", d)} \
52 "
diff --git a/meta-boot2qt-distro/recipes-core/systemd/systemd/usb-rndis.network b/meta-boot2qt-distro/recipes-core/systemd/systemd/usb-rndis.network
new file mode 100644
index 0000000..d529eeb
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/systemd/systemd/usb-rndis.network
@@ -0,0 +1,5 @@
1[Match]
2Type=gadget
3
4[Network]
5LinkLocalAddressing=yes
diff --git a/meta-boot2qt-distro/recipes-core/systemd/systemd_%.bbappend b/meta-boot2qt-distro/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..96b8910
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,52 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \
32 file://usb-rndis.network \
33"
34
35PACKAGECONFIG_append = " networkd"
36
37# By default sytemd uses it's build time as epoch. This causes problems when
38# using yocto cache since systemd build time might be more than day older than
39# the actual image build time. If that kind of image is booted with a device
40# that does not have backup battery for RTC, the first fsck interprets successful
41# result as failure because last mount time is in the future. This can be worked
42# around by setting TIME_EPOCH to 0, which causes fsck to detect the system time as
43# insane and ignore the mount time error.
44EXTRA_OECONF_append = " --with-time-epoch=0"
45
46do_install_append() {
47 # remove login from tty1
48 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
49 # set up link-local IPs for USB network interface
50 install -d ${D}${prefix}/lib/systemd/network/
51 install -m 0644 ${WORKDIR}/usb-rndis.network ${D}${prefix}/lib/systemd/network/
52}