summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-connectivity/connman
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-connectivity/connman
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-connectivity/connman')
-rw-r--r--meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend24
-rw-r--r--meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch21
-rw-r--r--meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch11
3 files changed, 56 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend b/meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend
new file mode 100644
index 0000000..fda246a
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-connectivity/connman/connman_%.bbappend
@@ -0,0 +1,24 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
23
24SRC_URI += "file://0001-disable-connman-when-booting-over-nfs-${PV}.patch"
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch
new file mode 100644
index 0000000..f893746
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.33.patch
@@ -0,0 +1,21 @@
1From df70770f33280a915abb413678088a078d82341a Mon Sep 17 00:00:00 2001
2From: Mikko Gronoff <mikko.gronoff@qt.io>
3Date: Tue, 20 Sep 2016 11:02:50 +0300
4Subject: [PATCH] Disable connman when booting over NFS
5
6---
7 src/connman.service.in | 1 +
8 1 file changed, 1 insertion(+)
9
10diff --git a/src/connman.service.in b/src/connman.service.in
11index 09dfec9..4132cf7 100644
12--- a/src/connman.service.in
13+++ b/src/connman.service.in
14@@ -6,6 +6,7 @@ RequiresMountsFor=@localstatedir@/lib/connman
15 After=dbus.service network-pre.target systemd-sysusers.service
16 Before=network.target multi-user.target shutdown.target
17 Wants=network.target
18+ConditionKernelCommandLine=!root=/dev/nfs
19
20 [Service]
21 Type=dbus
diff --git a/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch
new file mode 100644
index 0000000..8b46666
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-connectivity/connman/files/0001-disable-connman-when-booting-over-nfs-1.34.patch
@@ -0,0 +1,11 @@
1--- a/src/connman.service.in
2+++ b/src/connman.service.in
3@@ -7,6 +7,7 @@
4 Before=network.target multi-user.target shutdown.target
5 Wants=network.target
6 Conflicts=systemd-resolved.service
7+ConditionKernelCommandLine=!root=/dev/nfs
8
9 [Service]
10 Type=dbus
11