summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-bsp
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-bsp
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
downloadmeta-boot2qt-344c2f97025c6504ec986600498121bb83aaeb8f.tar.gz
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-bsp')
-rw-r--r--meta-boot2qt-distro/recipes-bsp/alsa/alsa-state.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/emulator/asound.conf4
-rw-r--r--meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/raspberrypi/asound.conf9
-rwxr-xr-xmeta-boot2qt-distro/recipes-bsp/v86d/v86d/fbsetup3
-rw-r--r--meta-boot2qt-distro/recipes-bsp/v86d/v86d/uvesafb.options.conf1
-rw-r--r--meta-boot2qt-distro/recipes-bsp/v86d/v86d_0.1.10.bbappend39
6 files changed, 86 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state.bbappend b/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state.bbappend
new file mode 100644
index 0000000..dbeb030
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/emulator/asound.conf b/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/emulator/asound.conf
new file mode 100644
index 0000000..edd2e82
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/emulator/asound.conf
@@ -0,0 +1,4 @@
1pcm.!default {
2 type plug
3 slave.pcm "dmix"
4}
diff --git a/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/raspberrypi/asound.conf b/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/raspberrypi/asound.conf
new file mode 100644
index 0000000..83f7f9a
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-bsp/alsa/alsa-state/raspberrypi/asound.conf
@@ -0,0 +1,9 @@
1pcm.!default {
2 type hw
3 card 0
4}
5
6ctl.!default {
7 type hw
8 card 0
9}
diff --git a/meta-boot2qt-distro/recipes-bsp/v86d/v86d/fbsetup b/meta-boot2qt-distro/recipes-bsp/v86d/v86d/fbsetup
new file mode 100755
index 0000000..064e080
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-bsp/v86d/v86d/fbsetup
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3/sbin/modprobe uvesafb mode_option=800x600-32 mtrr=3 scroll=ywrap
diff --git a/meta-boot2qt-distro/recipes-bsp/v86d/v86d/uvesafb.options.conf b/meta-boot2qt-distro/recipes-bsp/v86d/v86d/uvesafb.options.conf
new file mode 100644
index 0000000..7d0dc96
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-bsp/v86d/v86d/uvesafb.options.conf
@@ -0,0 +1 @@
options uvesafb mode_option=800x600-32 mtrr=3 scroll=ywrap
diff --git a/meta-boot2qt-distro/recipes-bsp/v86d/v86d_0.1.10.bbappend b/meta-boot2qt-distro/recipes-bsp/v86d/v86d_0.1.10.bbappend
new file mode 100644
index 0000000..bf72dee
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-bsp/v86d/v86d_0.1.10.bbappend
@@ -0,0 +1,39 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31
32SRC_URI += "file://uvesafb.options.conf"
33
34do_install_append() {
35 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
36 install -d ${D}${sysconfdir}/modprobe.d
37 install -m 0644 ${WORKDIR}/uvesafb.options.conf ${D}${sysconfdir}/modprobe.d/uvesafb.conf
38 fi
39}