diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-09-30 13:04:54 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-10-02 10:35:06 +0300 |
commit | 4307d00609cce928c8bab7ec63de0935647322fb (patch) | |
tree | 5bfb4a91fe0b58a2d192a233a433844dffe3c87d /meta-beagleboard-extras/recipes | |
parent | 8d1d0edf3a7ca9d37cd814d1956d80764cf7c899 (diff) | |
download | meta-boot2qt-4307d00609cce928c8bab7ec63de0935647322fb.tar.gz |
bbb: use boneblack u-boot config for eMMC storage
The boneblack u-boot config adds support for environment storage
in eMMC. Kernel image type is changed to zImage to reflect which
is what the u-boot defaults to. For older versions of u-boot that
try to use uImage, set extra u-boot arguments in uEnv.txt.
Change-Id: I98bd37db41a7c80a1aa75e9ae53c1e00589fde64
Reviewed-by: Andy Nichols <andy.nichols@digia.com>
Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
Diffstat (limited to 'meta-beagleboard-extras/recipes')
-rw-r--r-- | meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend | 1 | ||||
-rw-r--r-- | meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt | 5 |
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend b/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend index e5518bc..f91ea8e 100644 --- a/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend +++ b/meta-beagleboard-extras/recipes/linux/linux-mainline_3.8.bbappend | |||
@@ -6,3 +6,4 @@ SRC_URI += "\ | |||
6 | " | 6 | " |
7 | 7 | ||
8 | INSANE_SKIP_${PN} = "installed-vs-shipped" | 8 | INSANE_SKIP_${PN} = "installed-vs-shipped" |
9 | KERNEL_IMAGETYPE = "zImage" | ||
diff --git a/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt b/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt index 6b23df1..d41ef60 100644 --- a/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt +++ b/meta-beagleboard-extras/recipes/u-boot/u-boot-uenv-script/uEnv.txt | |||
@@ -1 +1,6 @@ | |||
1 | optargs=consoleblank=0 vt.global_cursor_default=0 quiet | 1 | optargs=consoleblank=0 vt.global_cursor_default=0 quiet |
2 | # extra options to support older u-boot (2013) | ||
3 | bootfile=zImage | ||
4 | loadaddr=0x80200000 | ||
5 | loaduimage=load mmc ${bootpart} ${loadaddr} ${bootdir}/${bootfile} | ||
6 | mmcboot=echo Booting from mmc ...; run mmcargs; bootz ${loadaddr} - ${fdtaddr} | ||