summaryrefslogtreecommitdiffstats
path: root/meta-architech-extras
diff options
context:
space:
mode:
authoraavit <eirik.aavitsland@digia.com>2014-09-26 10:17:00 +0200
committerEirik Aavitsland <eirik.aavitsland@digia.com>2014-11-10 12:11:58 +0200
commit59f1923832b301df6743ed3fa0b92556aa68ffbd (patch)
tree4fb21fc0523696ba2a5ca96638e51afd7feeedb7 /meta-architech-extras
parentf309d05bccefc29977d474df734fecbe311f8f7b (diff)
downloadmeta-boot2qt-59f1923832b301df6743ed3fa0b92556aa68ffbd.tar.gz
Add Silica ArchiTech tibidabo board
Builds & runs ok! The current implementation is done with the strategy of using the vendor's defined repo versions for the yocto stack, instead of the common versions defined by b2qt. The intention is to build upon the vendor stack as closely as possible, as that is (hopefully) tested and maintained. Task-number: QTEE-801 Change-Id: Ib93b54178de870b5f288b2fae982ea2b4bb74e50 Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-architech-extras')
-rw-r--r--meta-architech-extras/conf/layer.conf33
-rw-r--r--meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch17
-rw-r--r--meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend26
3 files changed, 76 insertions, 0 deletions
diff --git a/meta-architech-extras/conf/layer.conf b/meta-architech-extras/conf/layer.conf
new file mode 100644
index 0000000..1cd742f
--- /dev/null
+++ b/meta-architech-extras/conf/layer.conf
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23# We have a conf and classes directory, append to BBPATH
24BBPATH .= ":${LAYERDIR}"
25
26# We have a recipes directory, add to BBFILES
27BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
28 ${LAYERDIR}/recipes*/*/*.bbappend \
29 "
30
31BBFILE_COLLECTIONS += "b2qt_architech"
32BBFILE_PATTERN_b2qt_architech := "^${LAYERDIR}/"
33BBFILE_PRIORITY_b2qt_architech = "20"
diff --git a/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch
new file mode 100644
index 0000000..6df6cd6
--- /dev/null
+++ b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd/0001-Updated-kernel-arguments-for-tibidabo.patch
@@ -0,0 +1,17 @@
1From 020c8ffc859d03b26ae50d0b4cf008ec655e26a0 Mon Sep 17 00:00:00 2001
2From: aavit <eirik.aavitsland@theqtcompany.com>
3Date: Mon, 27 Oct 2014 12:41:32 +0100
4Subject: [PATCH] Updated kernel arguments for tibidabo
5
6
7diff --git a/recipes-bsp/bootscript/tibidabo-bootscript-sd-1.0/bootscript.source b/recipes-bsp/bootscript/tibidabo-bootscript-sd-1.0/bootscript.source
8index 1902d81..4247a08 100644
9--- a/bootscript.source
10+++ b/bootscript.source
11@@ -1,5 +1,6 @@
12 setenv bootargs ${bootargs} vmalloc=400M root=/dev/mmcblk0p2 rw,rootwait consoleblank=0 video=mxcfb0:dev=hdmi,1280x720M@60,if=RGB24 video=mxcfb1:dev=lcd,CLAA-WVGA,if=RGB666 fbmem=28M,10M
13 mmc dev 0
14+setenv bootargs ${bootargs} vt.global_cursor_default=0
15 for file_system in fat ext2; do
16 ${file_system}load mmc 0:1 ${loadaddr} /uImage && bootm ${loadaddr}
17 done
diff --git a/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend
new file mode 100644
index 0000000..d07b6a6
--- /dev/null
+++ b/meta-architech-extras/recipes/bootscript/tibidabo-bootscript-sd_1.0.bbappend
@@ -0,0 +1,26 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
24SRC_URI += " \
25 file://0001-Updated-kernel-arguments-for-tibidabo.patch \
26 "