summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-09-30 11:55:35 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-06 05:57:58 +0000
commit323408406d9133a5462a24fea4ec86e649088180 (patch)
tree685f5a0ad6a76fc0488fa207ec517b2b3e554f8f /conf
parent80402502806c94d2954852549d6549c9e333c586 (diff)
downloadmeta-boot2qt-323408406d9133a5462a24fea4ec86e649088180.tar.gz
tegra: update to latest vibrante pdk
[RC 2.5] 25.11.01 Vibrante 4.0 Linux Drive CX2 - PDK Drop support for nvidia-logan Change-Id: Ic8c76313704c3e666050284f02cb1a40237366e5 Reviewed-by: Risto Avila <risto.avila@qt.io>
Diffstat (limited to 'conf')
-rw-r--r--conf/bblayers.conf.nvidia-logan.sample53
-rw-r--r--conf/distro/include/nvidia-logan.conf66
-rw-r--r--conf/distro/include/tegra-t18x.conf18
-rw-r--r--conf/distro/include/tegra.inc17
4 files changed, 6 insertions, 148 deletions
diff --git a/conf/bblayers.conf.nvidia-logan.sample b/conf/bblayers.conf.nvidia-logan.sample
deleted file mode 100644
index 9a7272c..0000000
--- a/conf/bblayers.conf.nvidia-logan.sample
+++ /dev/null
@@ -1,53 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
31# changes incompatibly
32POKY_BBLAYERS_CONF_VERSION = "2"
33
34BBPATH = "${TOPDIR}"
35BBFILES ?= ""
36BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}"
37
38BBLAYERS ?= " \
39 ${BSPDIR}/sources/poky/meta \
40 ${BSPDIR}/sources/poky/meta-poky \
41 ${BSPDIR}/sources/nvidia-layer/meta-tegra \
42 ${BSPDIR}/sources/nvidia-layer/meta-vib3 \
43 ${BSPDIR}/sources/meta-openembedded/meta-oe \
44 ${BSPDIR}/sources/meta-openembedded/meta-python \
45 ${BSPDIR}/sources/meta-openembedded/meta-networking \
46 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
47 ${BSPDIR}/sources/meta-openembedded/meta-multimedia \
48 ${BSPDIR}/sources/meta-boot2qt \
49 ${BSPDIR}/sources/meta-boot2qt/meta-vib3-extras \
50 ${BSPDIR}/sources/meta-boot2qt/meta-tegra-extras \
51 ${BSPDIR}/sources/meta-mingw \
52 ${BSPDIR}/sources/meta-qt5 \
53 "
diff --git a/conf/distro/include/nvidia-logan.conf b/conf/distro/include/nvidia-logan.conf
deleted file mode 100644
index 0dc1d84..0000000
--- a/conf/distro/include/nvidia-logan.conf
+++ /dev/null
@@ -1,66 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30TARGET_CFLAGS += " -DWIN_INTERFACE_CUSTOM"
31
32DEFAULTTUNE = "cortexa15hf-neon"
33
34KERN_DIR ?= '${@os.path.normpath("${TOPDIR}/../sources/jetson-tk1-pro/vibrante-vcm30t124-linux")}'
35PLATFORM_TOPDIR ?= '${@os.path.normpath("${TOPDIR}/../sources/jetson-tk1-pro/vibrante-vcm30t124-linux")}'
36NVLAYER_DIR ?= "${TOPDIR}/../sources/nvidia-layer"
37
38MACHINE_EXTRA_INSTALL = "\
39 libegl \
40 libgles2 \
41 tegra-firmware-gk20a \
42 graphics-fw \
43 libdrm-nv \
44"
45
46MACHINE_EXTRA_INSTALL_SDK = "\
47 libegl-dev \
48 libgles2-dev \
49 graphics-headers-dev \
50 libdrm-nv-dev \
51"
52
53PREFERRED_PROVIDER_libdrm ?= "libdrm-nv"
54PREFERRED_PROVIDER_drm ?= "libdrm-nv"
55
56BBMASK += "\
57 meta-vib3/recipes-kernel/linux-libc-headers \
58 meta-vib3/recipes-devtools/binutils \
59 meta-vib3/recipes-core/eglibc \
60 meta-vib3/recipes-core/systemd \
61 meta-vib3/recipes-connectivity \
62 meta-vib3/recipes-multimedia/pulseaudio \
63 meta-vib3/recipes-core/meta \
64 meta-vib3/recipes-core/packagegroups \
65 meta-vib3/recipes-devtools/gcc \
66 "
diff --git a/conf/distro/include/tegra-t18x.conf b/conf/distro/include/tegra-t18x.conf
index 515eb8d..f317ca9 100644
--- a/conf/distro/include/tegra-t18x.conf
+++ b/conf/distro/include/tegra-t18x.conf
@@ -20,15 +20,13 @@
20## 20##
21############################################################################# 21#############################################################################
22 22
23include conf/distro/include/tegra.inc
24
25OLDEST_KERNEL_aarch64 = "3.18" 23OLDEST_KERNEL_aarch64 = "3.18"
26 24
27TARGET_CFLAGS += " -DWIN_INTERFACE_CUSTOM" 25TARGET_CFLAGS += " -DWIN_INTERFACE_CUSTOM"
28DISTRO_FEATURES_DEFAULT += "wayland" 26DISTRO_FEATURES_DEFAULT += "wayland"
29 27
30KERN_DIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186/kernel")}' 28KERN_DIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186/kernel")}'
31PLATFORM_TOPDIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186/vibrante-t186ref-linux")}' 29PLATFORM_TOPDIR ?= '${@os.path.normpath("${TOPDIR}/../sources/vibrante-t186")}'
32NVLAYER_DIR ?= "${TOPDIR}/../sources/nvidia-layer" 30NVLAYER_DIR ?= "${TOPDIR}/../sources/nvidia-layer"
33 31
34MACHINE_EXTRA_INSTALL = "\ 32MACHINE_EXTRA_INSTALL = "\
@@ -48,7 +46,6 @@ MACHINE_EXTRA_INSTALL = "\
48 virtual/libegl \ 46 virtual/libegl \
49 virtual/libgles2 \ 47 virtual/libgles2 \
50 libdrm-nv \ 48 libdrm-nv \
51 asound-conf \
52 " 49 "
53 50
54PREFERRED_PROVIDER_virtual/libgles2 ?= "tegra-drivers" 51PREFERRED_PROVIDER_virtual/libgles2 ?= "tegra-drivers"
@@ -60,21 +57,18 @@ PREFERRED_PROVIDER_virtual/libgl ?= "tegra-drivers"
60PREFERRED_PROVIDER_virtual/libgles1 ?= "tegra-drivers" 57PREFERRED_PROVIDER_virtual/libgles1 ?= "tegra-drivers"
61PREFERRED_PROVIDER_virtual/mesa ?= "tegra-drivers" 58PREFERRED_PROVIDER_virtual/mesa ?= "tegra-drivers"
62 59
63PREFERRED_PROVIDER_wayland ?= "wayland-nv"
64PREFERRED_PROVIDER_wayland-native ?= "wayland-nv"
65PREFERRED_PROVIDER_nativesdk-wayland ?= "wayland-nv"
66
67BBMASK += "\ 60BBMASK += "\
68 meta-vib4/recipes-connectivity/connman \ 61 meta-vib4/recipes-connectivity/connman \
69 meta-vib4/recipes-core/busybox \ 62 meta-vib4/recipes-core/toybox \
70 meta-vib4/recipes-core/images \ 63 meta-vib4/recipes-core/images \
71 meta-vib4/recipes-core/meta \
72 meta-vib4/recipes-core/packagegroups \ 64 meta-vib4/recipes-core/packagegroups \
73 meta-vib4/recipes-core/systemd/systemd \
74 meta-vib4/recipes-devtools \
75 meta-vib4/recipes-extended \ 65 meta-vib4/recipes-extended \
76 meta-vib4/recipes-multimedia/audiomanager \ 66 meta-vib4/recipes-multimedia/audiomanager \
77 meta-vib4/recipes-core/glibc \ 67 meta-vib4/recipes-core/glibc \
78 meta-vib4/recipes-support/lvm2 \ 68 meta-vib4/recipes-support/lvm2 \
79 meta-vib4/recipes-kernel/linux-libc-headers \ 69 meta-vib4/recipes-kernel/linux-libc-headers \
70 meta-vib4/recipes-devtools/binutils \
71 meta-vib4/recipes-yocto-ivi/packagegroups \
72 meta-vib4/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend \
73 meta-vib4/recipes-graphics/wayland/libinput_%.bbappend \
80 " 74 "
diff --git a/conf/distro/include/tegra.inc b/conf/distro/include/tegra.inc
deleted file mode 100644
index 618a634..0000000
--- a/conf/distro/include/tegra.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1python set_nv_drv_version () {
2 # Boiler plate code to setup bitbake objects
3 d = e.data
4
5 nv_drv_version = d.getVar('NV_DRV_VER', True)
6 if nv_drv_version != "ignore":
7 # FIXME: When we add support to internal builds, both debug and release
8 # builds will need to be considered
9 path = d.getVar('PLATFORM_TOPDIR', True)
10 get_nv_drv_cmd = "strings " + path + "/lib-target/nvidia_drv.so \
11| grep -o -P '(?<=Driver ).*(?=Release)' | awk {'print $1'}"
12 # Execute cmd
13 nv_drv_version = bb.process.run(get_nv_drv_cmd)[0].strip()
14 # Store returned value in NV_DRV_VER
15 d.setVar('NV_DRV_VER', nv_drv_version)
16}
17