diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 15:59:05 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2016-08-22 15:59:05 +0300 |
commit | 83b656eb3219ee37d95d6453d692562406fe7be0 (patch) | |
tree | 47b52b59932c23c4e9cfeb8bfc0a3e75c23117de /classes/qtquickcompiler.bbclass | |
parent | 1778a81a6d214b27f20cb5242b28d5c41fbbf5b6 (diff) | |
parent | 797b8c96bd53cd15b6540a989353f89d285c8de9 (diff) | |
download | meta-boot2qt-83b656eb3219ee37d95d6453d692562406fe7be0.tar.gz |
Merge remote-tracking branch 'origin/fido' into jethro
* origin/fido:
Correctly update qtquickcompiler SHA1
Reuse qt5-git.inc to define git repo location
Remove automotive recipes
Update Qt5 submodules
Handle qtquickcompiler in update-qt5-modules.sh script
Correctly use QtQuickCompiler when available
Change git protocol from ssh to http
Update qtdeclarative module
Update boot2qt-demos version
Conflicts:
conf/distro/b2qt-auto.conf
recipes-qt/automotive/gammaray_git.bb
recipes-qt/automotive/neptune-ui/neptune.service
recipes-qt/automotive/neptune-ui_git.bb
recipes-qt/automotive/qtapplicationmanager_git.bb
recipes-qt/automotive/qtivi_git.bb
recipes-qt/automotive/qtwebbrowser_git.bb
recipes-qt/b2qt-addons/b2qt-demos.bb
recipes-qt/b2qt-addons/b2qt-launcher.bb
recipes-qt/b2qt-addons/democompositor_git.bb
recipes-qt/images/b2qt-automotive-qt5-image.bb
recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb
recipes-qt/qt5/nativesdk-qtbase_git.bbappend
recipes-qt/qt5/qt3d_git.bbappend
recipes-qt/qt5/qtbase-native_git.bbappend
recipes-qt/qt5/qtbase_git.bbappend
recipes-qt/qt5/qtcanvas3d_git.bbappend
recipes-qt/qt5/qtcharts_git.bb
recipes-qt/qt5/qtconnectivity_git.bbappend
recipes-qt/qt5/qtdatavis3d_git.bb
recipes-qt/qt5/qtdeclarative-render2d_git.bb
recipes-qt/qt5/qtdeclarative_git.bbappend
recipes-qt/qt5/qtgraphicaleffects_git.bbappend
recipes-qt/qt5/qtimageformats_git.bbappend
recipes-qt/qt5/qtlocation_git.bbappend
recipes-qt/qt5/qtmultimedia_git.bbappend
recipes-qt/qt5/qtquickcompiler_git.bb
recipes-qt/qt5/qtquickcontrols2_git.bb
recipes-qt/qt5/qtquickcontrols_git.bbappend
recipes-qt/qt5/qtsensors_git.bbappend
recipes-qt/qt5/qtserialbus_git.bb
recipes-qt/qt5/qtserialport_git.bbappend
recipes-qt/qt5/qtsvg_git.bbappend
recipes-qt/qt5/qttools_git.bbappend
recipes-qt/qt5/qttranslations_git.bbappend
recipes-qt/qt5/qtvirtualkeyboard_git.bb
recipes-qt/qt5/qtvirtualkeyboard_git.bbappend
recipes-qt/qt5/qtwayland-native_5.7-wip.bb
recipes-qt/qt5/qtwayland-native_git.bbappend
recipes-qt/qt5/qtwayland_5.7-wip.bb
recipes-qt/qt5/qtwayland_git.bbappend
recipes-qt/qt5/qtwebchannel_git.bbappend
recipes-qt/qt5/qtwebengine_git.bbappend
recipes-qt/qt5/qtwebsockets_git.bbappend
recipes-qt/qt5/qtxmlpatterns_git.bbappend
scripts/manifest.xml
Change-Id: Ibf7f89a35c9e19bd8cf81c49cb44f6fd454838b4
Diffstat (limited to 'classes/qtquickcompiler.bbclass')
-rw-r--r-- | classes/qtquickcompiler.bbclass | 20 |
1 files changed, 10 insertions, 10 deletions
diff --git a/classes/qtquickcompiler.bbclass b/classes/qtquickcompiler.bbclass index 8dbaf49..3564ad1 100644 --- a/classes/qtquickcompiler.bbclass +++ b/classes/qtquickcompiler.bbclass | |||
@@ -28,18 +28,18 @@ | |||
28 | ############################################################################ | 28 | ############################################################################ |
29 | 29 | ||
30 | python __anonymous() { | 30 | python __anonymous() { |
31 | provider = "qtquickcompiler" | 31 | provider = "" |
32 | sdk_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk" | ||
33 | pn = d.getVar("PN", True) | ||
32 | 34 | ||
33 | sdk_path = d.getVar('QT_SDK_PATH', True) or "" | 35 | if d.getVar('ENABLE_QTQUICKCOMPILER', True) == "1": |
34 | if len(sdk_path) != 0: | 36 | provider = "qtquickcompiler" |
35 | qtquickcompiler_path = d.getVar('B2QTBASE', True) + "/recipes-qt/qt5-addons/qtquickcompiler-sdk" | 37 | elif os.path.isdir(sdk_path): |
36 | if not os.path.isdir(qtquickcompiler_path): | 38 | provider = "qtquickcompiler-sdk" |
37 | bb.note("QtQuickCompiler not available") | 39 | else: |
38 | return | 40 | bb.note("qtquickcompiler not enabled for %s" % pn) |
39 | else: | 41 | return |
40 | provider = "qtquickcompiler-sdk" | ||
41 | 42 | ||
42 | pn = d.getVar("PN", True) | ||
43 | if "toolchain-host" in pn: | 43 | if "toolchain-host" in pn: |
44 | d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider) | 44 | d.appendVar('RDEPENDS_' + pn, " nativesdk-%s-tools" % provider) |
45 | if "toolchain-target" in pn: | 45 | if "toolchain-target" in pn: |